Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007692opensim[GRID] Asset Servicepublic2015-08-20 14:032019-02-11 06:09
ReporterAstro Balut 
Assigned Totampa 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformWindowsOSWindows ServerOS Version2008 R2
Product Version 
Target VersionFixed in Version 
Summary0007692: Rezzed objects lost from region after server restart ("sim crash")
DescriptionToday my provider restarted my virtual Windows server without notice. Because of that the running Robust + sim crashed by nature. That should be no big problem as such; but after starting Robust.exe and Opensim.exe the past two days' rezzed objects were gone. I took the grid nicely down and up again, cleared cache and relogged, but the objects seem gone for good. Normally the automatic BACKUP / resistancy command should prevent that from happening, right?
Is there any known issue with lost prims after a sim crash? Or could it by chance be because the lost prims are all mesh objects?
Steps To Reproduce1) Rez some objects and let them stick for some time (hours/days).
2) Close Opensim.exe hard (to simulate a server restart)
3) Restart the grid
4) Log on the viewer and check the objects
Additional InformationThe objects are meshes of varying complexity - some extremely complex, others very simple.
Tagspersistence
Git Revision or version number0.8.0.3
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 4.6.9 (42974)
Attached Files

- Relationships

-  Notes
(0034724)
tampa (reporter)
2019-02-11 06:07

The way at which persistence is called can depend on a lot of things and it may very well not be called for a long time. Running the automatic backup module can help prevent this. Manually calling backup or restarting simulator to be sure assets are committed is also an option if system stability is to question.

- Issue History
Date Modified Username Field Change
2015-08-20 14:03 Astro Balut New Issue
2015-08-20 14:49 Astro Balut Tag Attached: persistence
2019-02-11 06:07 tampa Note Added: 0034724
2019-02-11 06:07 tampa Status new => resolved
2019-02-11 06:07 tampa Resolution open => no change required
2019-02-11 06:07 tampa Assigned To => tampa
2019-02-11 06:09 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker