Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007686opensim[REGION] OpenSim Corepublic2015-08-17 02:472019-02-06 11:50
Reporterkenvc 
Assigned Tokenvc 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformHP Dual Quad Core Xeon CPUsOSWindows 32GBOS VersionServer 2012 64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007686: Starting the last 1-4 days there are huge CPU usage spikes on instances where nothing is happening.
DescriptionStarting sometime in the last 1 to 4 days, we are seeing the CPU on our servers that are running several instances of Opensim with 1-4 sims in each instance, go from using a steady 50-53% CPU at idle, jumping from 50-80% CPU at ide. This is jumping way up and down with each sample check of the Windows task manager.

On the sever where the CPU is spiking up close to 80-90 at times, there is a very noticeable overall slowdown in the response of the server to bring up menus etc. The simulators are also showing many more timeouts than before and they sometimes do not respond to logins or teleports.

The memory usage appears to still be OK as it has not changed compared to what it was before this started happening.
Steps To ReproduceNot sure how to monitor this in Linux, but in Windows simply run the task manager and monitor the CPU about 15 minutes after your sims have loaded and settled in with no one on the sims and totally at idle. The CPU usage will show lots of quick spikes up and down that have never been there before when the sims are at idle. If your computer is running a lot of instances, you will notice the overall computer running slower feeling very sluggish.
TagsNo tags attached.
Git Revision or version numberr/26174
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0029167)
danbanner (manager)
2015-08-17 03:33

I'm not seeing this on our simulators.. You might check top scripts, etc perhaps a physical vehicle is lost someplace? Most of the plazas are averaging between 2% and 10% with the exception being wright plaza around 25%

You might disable scripts in your ini and restart the sim and see if there is any difference.
(0029179)
kenvc (reporter)
2015-08-17 22:07

I think this is more noticeable on my system because I am running so many instances on one server (16 to be exact with each running 1 to 5 sims). I think what is happening is the high spikes on several of them happen to occur at almost the same time and this suddenly bumps the CPU time way up, then when the low spikes happen about the same time, it suddenly drops way down.

The difference in the high and low spikes when the simulators are empty and idle for a long time (3am in the morning) are a lot greater than they used to be. If I was only running a very small number of instances and sims, I would probably not even have noticed the change in CPU behavior.
(0029723)
kenvc (reporter)
2015-11-27 08:15

This seems to be resolved in the new dev master.
(0034589)
BillBlight (developer)
2019-02-06 11:50

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2015-08-17 02:47 kenvc New Issue
2015-08-17 03:33 danbanner Note Added: 0029167
2015-08-17 22:07 kenvc Note Added: 0029179
2015-11-27 08:15 kenvc Note Added: 0029723
2015-11-27 08:15 kenvc Status new => resolved
2015-11-27 08:15 kenvc Fixed in Version => master (dev code)
2015-11-27 08:15 kenvc Resolution open => fixed
2015-11-27 08:15 kenvc Assigned To => kenvc
2019-02-06 11:50 BillBlight Note Added: 0034589
2019-02-06 11:50 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker