Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007684opensim[REGION] Scripting Enginepublic2015-08-15 09:462015-08-18 09:34
ReporterMata Hari 
Assigned ToMata Hari 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel i7 930 quadOSWindows .NETOS VersionWin10 x64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007684: Dialog box reports Unknown User as owner if owner is an HG user
DescriptionIf you are HGed to another grid where you have build permissions and create a script there that includes use of a dialog box, the dialog box incorrectly reports the owner as "Unknown User" instead of the owner's name.
Steps To ReproduceHG somewhere that you have build and scripting perms and put this in a prim and touch it:

default
{
    touch_start (integer num)
    {
        llDialog(llDetectedKey(0),"This demonstrates how owner name is not being correctly pulled for dialog boxes",["Okay"],-10);
    }
}
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm current
Attached Filespng file icon UU for owner.png [^] (247,905 bytes) 2015-08-15 09:47


patch file icon dialogmodule.patch [^] (2,732 bytes) 2015-08-16 13:05 [Show Content]
diff file icon MANTIS7684.diff [^] (2,557 bytes) 2015-08-16 13:55 [Show Content]

- Relationships

-  Notes
(0029157)
Mata Hari (reporter)
2015-08-15 09:55

Attached picture of what I'm talking about.

Test was done using opensim-8305972 r/26169 2015-08-15 but this issue existed under earlier versions as well (and has possibly always existed...I haven't had occasion to test it much in the past...I did test under 0.8.1.1 and it happens there too).
(0029163)
Chris Weymann (reporter)
2015-08-16 13:05

The sam problem is at llTextBox too.
It is couse of the discontinuous use from the user management module.
I have already make a patch for this in the past before i have started to use this mantis system.
(0029164)
cinderblocks (reporter)
2015-08-16 13:57

Since UserManagementModule is already a member of Scene, you don't need to request the interface. I've attached a second patch that does what Chris's does, only a little cleaner.
(0029165)
Diva (administrator)
2015-08-16 21:24

[21:24] <cia-opensim> opensim: cinder * rfc6fe75268d6 OpenSim/Region/CoreModules/Avatar/Dialog (DialogModule.cs):
[21:24] <cia-opensim> MANTIS-7684 - Use the user management module to get username for script dialogs
[21:24] <cia-opensim>
[21:24] <cia-opensim> Signed-off-by: Diva Canto <diva@metaverseink.com>
(0029168)
Mata Hari (reporter)
2015-08-17 06:54

Thank you Chris, Cinder and Diva...that resolves the issue perfectly. :)
(0029169)
Mata Hari (reporter)
2015-08-17 06:55

tested and confirmed fixed under opensim-0cdd116 r26176
(0029180)
aiaustin (developer)
2015-08-18 09:34

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2015-08-15 09:46 Mata Hari New Issue
2015-08-15 09:47 Mata Hari File Added: UU for owner.png
2015-08-15 09:55 Mata Hari Note Added: 0029157
2015-08-16 13:05 Chris Weymann Note Added: 0029163
2015-08-16 13:05 Chris Weymann File Added: dialogmodule.patch
2015-08-16 13:05 Chris Weymann Status new => patch included
2015-08-16 13:55 cinderblocks File Added: MANTIS7684.diff
2015-08-16 13:57 cinderblocks Note Added: 0029164
2015-08-16 21:24 Diva Note Added: 0029165
2015-08-17 06:54 Mata Hari Note Added: 0029168
2015-08-17 06:55 Mata Hari Note Added: 0029169
2015-08-17 06:55 Mata Hari Status patch included => resolved
2015-08-17 06:55 Mata Hari Fixed in Version => master (dev code)
2015-08-17 06:55 Mata Hari Resolution open => fixed
2015-08-17 06:55 Mata Hari Assigned To => Mata Hari
2015-08-18 09:34 aiaustin Note Added: 0029180
2015-08-18 09:34 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker