Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007649opensim[REGION] OpenSim Corepublic2015-07-23 02:452015-08-18 09:34
ReporterQuillLittlefeather 
Assigned Tomelanie 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOperating SystemOperating System Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007649: Fixed issue with classifieds not charging on region with money
Descriptionadding classifieds on money enabled regions would not charge.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
Script Engine
EnvironmentMono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX, .NET / Windows32, .NET / Windows64
Mono Version4.0
Viewer
Attached Filespatch file icon 0002-Fixed-not-being-charged-to-create-classifeids-on-mon.patch [^] (2,281 bytes) 2015-07-25 17:12 [Show Content]

- Relationships

-  Notes
(0028961)
QuillLittlefeather (reporter)
2015-07-23 10:50

Reuploaded patch as the commit id was incorrect
(0028974)
cinderblocks (reporter)
2015-07-25 13:57

A few things, you could be calling s rather than p.Scene as it's the same thing, and there's not really a need to null check twice. You can group your calls together.

I'd strongly suggest this is also not the right way to handle parcel dwell. For one, handling of parcel dwell is the responsibility of the Dwell module, not the Land Management module, and simply incrementing the value every time an agent enters a parcel is, imo, not the right thing to do. In my dwell module, the values are increased over time depending not only on how many agents are on the parcel but how long they stay, the value is also decayed over time once the agents have left. Incrementing every agent entry could get out of hand rather quickly once someone decides to generate a few hundred npc and walk them back and forth a few meters. The boolean also seems superfluous here since it's constant.
(0028976)
melanie (administrator)
2015-07-25 15:34

Please do not attempt to sneak in code not declared in the patch description.

HARD -1 on the attempt to sneak that unusable "dwell" code past scrutiny.

Please resubmit a clean patch. Dwell is the responsibility of the dwell module only.
(0028977)
QuillLittlefeather (reporter)
2015-07-25 16:54

Sorry, Here is an "Cleaned" patch.

Fixed the repeated null check and reused existing scene information.
(0028978)
melanie (administrator)
2015-07-25 17:04

patch will not apply. Please dont't use "git show" to produce a patch, use "git format-patch".

Also, your code will charge the user for editing an existing ad also, as far as I can tell. That may be addressed in a later patch. For now, please use git format-patch to create a proper, applyable patch.
(0028979)
QuillLittlefeather (reporter)
2015-07-25 17:14

This patch should good.
(0028980)
melanie (administrator)
2015-07-25 17:32

r4735514a888b
(0029200)
aiaustin (developer)
2015-08-18 09:34

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2015-07-23 02:45 QuillLittlefeather New Issue
2015-07-23 02:45 QuillLittlefeather File Added: Classified.patch
2015-07-23 02:45 QuillLittlefeather Status new => patch included
2015-07-23 02:59 QuillLittlefeather File Added: updated_classified.patch
2015-07-23 02:59 QuillLittlefeather File Deleted: Classified.patch
2015-07-23 08:24 QuillLittlefeather Status patch included => patch feedback
2015-07-23 10:50 QuillLittlefeather Note Added: 0028961
2015-07-23 23:22 QuillLittlefeather File Deleted: updated_classified.patch
2015-07-23 23:22 QuillLittlefeather File Added: updated_classified.patch
2015-07-25 13:57 cinderblocks Note Added: 0028974
2015-07-25 15:34 melanie Note Added: 0028976
2015-07-25 16:25 QuillLittlefeather File Deleted: updated_classified.patch
2015-07-25 16:52 QuillLittlefeather File Added: Cleaned_updated_classified.patch
2015-07-25 16:54 QuillLittlefeather Note Added: 0028977
2015-07-25 17:04 melanie Note Added: 0028978
2015-07-25 17:12 QuillLittlefeather File Added: 0002-Fixed-not-being-charged-to-create-classifeids-on-mon.patch
2015-07-25 17:14 QuillLittlefeather Note Added: 0028979
2015-07-25 17:15 QuillLittlefeather File Deleted: Cleaned_updated_classified.patch
2015-07-25 17:32 melanie Note Added: 0028980
2015-07-25 17:32 melanie Status patch feedback => resolved
2015-07-25 17:32 melanie Resolution open => fixed
2015-07-25 17:32 melanie Assigned To => melanie
2015-08-18 09:34 aiaustin Note Added: 0029200
2015-08-18 09:34 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker