Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007648opensim[GRID] Asset Servicepublic2015-07-22 05:482015-08-18 09:34
ReporterMata Hari 
Assigned ToMata Hari 
PriorityimmediateSeverityblockReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformIntel i7 930 quad coreOSWindows .NETOS VersionWin7 x64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007648: Incompatibility between objects sent via HG from a linux-hosted region/grid and then opened on a Win-hosted region
DescriptionI thought there was already a mantis on this but I can't locate it.

I am constantly seeing the following when attempting to rez an object that I picked up while HGed or that has been sent to me by someone from another grid when I am standing in any of my Windows-hosted regions:

08:37:13 - [SERIALIZER]: Deserialization of xml failed. Exception System.Xml.XmlException: The ':' character, hexadecimal value 0x3A, cannot be included in a n
ame. Line 1, position 57.
   at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)
   at System.Xml.XmlTextReaderImpl.ParseAttributes()
   at System.Xml.XmlTextReaderImpl.ParseElement()
   at System.Xml.XmlTextReaderImpl.ParseElementContent()
   at System.Xml.XmlCharCheckingReader.Read()
   at System.Xml.XmlReader.ReadToFollowing(String name)
   at OpenSim.Region.Framework.Scenes.Serialization.SceneObjectSerializer.FromOriginalXmlFormat(XmlReader reader) in c:\opensim-refuge\opensim-8cc7433\OpenSim\R
egion\Framework\Scenes\Serialization\SceneObjectSerializer.cs:line 85

The object will fail to rez.

If I tp to a linux-hosted region elsewhere in Refugegrid I am able to rez the object, and can then take it back into inventory and subsequently rez it in my own regions.

People coming to my Hedonism region (hosted under linux) to pick up copies of my various items report the exact same issue upon returning to their own grids and attempting to rez it in a windows-hosted region.
Steps To ReproduceHG to any linux-hosted region and pick up something that doesn't already exist in your own grid. TP back home and go to a windows-hosted region. Attempt to rez the object.
Additional InformationI am seeing this for an object I pick up in OSG Wright Plaza (which I assume is running relatively reccent git) and attempting to rez it on my regions which are running opensim-8cc7433 r/26108 2015-07-22
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships
duplicate of 0007514closedDiva Can't rez items from OSGrid on my own grid. 

-  Notes
(0028953)
JeffKelley (reporter)
2015-07-23 04:08

Fixed in r877371411a9e

NOTE: This requires an update to the server that runs HGAssetService on the grid from where assets are being copied.

It would be highly useful if someone could confirm that updating the Linux grid actually solves the issue. Since we usually have no control on the originating grid, the issue will exist until the whole hypergrid has been updated.
(0028959)
Ferd Frederix (reporter)
2015-07-23 07:45
edited on: 2015-07-23 07:49

This may be a duplicate of 7514, but 7514 is not yet fixed. I think we should open a new Mantis to report this problem in a different way. I thought Mantis is a per-bug reporting systenm, and failing to rez an asset that is in my inventory is a bug that requires a different patch than 7514, which fixes the originating bug.

Is it possible to make the receiving system remove the extra header and thus fix the asset? I've wanted to make a bit of Perl and a Regex to fix this for a long time and have sopent a several days looking into the XML but do not yet know of the appropriate regex to do the fix. Part of my problem is when I rename it to .gz and unpack it, the unpacked IAR on a Windows box does not have the same 3-folder structure reported in the docs.

If a fix is never made for this, this problem will never, ever go away. Anyone who rezzes such an object on a Windows box permaently has an invisible object stuck in-world where it clutters up log files with errors on backups. OARS get the corrupted asset, IARS are corrupted, too, and though they load, you get a console full of red messages on the IAR dump, or load. .

(0028964)
JeffKelley (reporter)
2015-07-23 15:09
edited on: 2015-07-23 15:09

7514 is supposed to be fixed in master. The issue will go away when all MONO grids have upgraded to 0.8.2 which, admittedly, will take a long time. Hacking the receiving system is partial solution and won't solve the issue globally. I see no other option than re-serializing bad objects from the original grid once upgraded.

(0029080)
Mata Hari (reporter)
2015-08-03 04:51

Fixed by r/26127
(0029190)
aiaustin (developer)
2015-08-18 09:34

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2015-07-22 05:48 Mata Hari New Issue
2015-07-22 05:51 Mata Hari Additional Information Updated View Revisions
2015-07-23 03:50 JeffKelley Relationship added duplicate of 0007514
2015-07-23 04:08 JeffKelley Note Added: 0028953
2015-07-23 07:45 Ferd Frederix Note Added: 0028959
2015-07-23 07:49 Ferd Frederix Note Edited: 0028959 View Revisions
2015-07-23 15:09 JeffKelley Note Added: 0028964
2015-07-23 15:09 JeffKelley Note Edited: 0028964 View Revisions
2015-08-03 04:51 Mata Hari Note Added: 0029080
2015-08-03 04:51 Mata Hari Status new => resolved
2015-08-03 04:51 Mata Hari Fixed in Version => master (dev code)
2015-08-03 04:51 Mata Hari Resolution open => fixed
2015-08-03 04:51 Mata Hari Assigned To => Mata Hari
2015-08-18 09:34 aiaustin Note Added: 0029190
2015-08-18 09:34 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker