Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007624opensim[GRID] Other Servicepublic2015-06-23 14:472015-08-18 09:34
ReporterQuillLittlefeather 
Assigned ToDiva 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformAnyOperating SystemAnyOperating System VersionAny
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007624: Added support to use <USERNAME> in Welcome Message along with MessageUrl to enable web script messages.
DescriptionI have created a patch that changes the Welcome message.

MessageUrl is used to generate the welcome message from a web script.
If MessageUrl is enabled and set then this will override the WelcomeMessage option in the ini

Note changing the welcome message text in the ini or the webserver no longer requires you to reset opensim/robust. change between MessageUrl and WelcomeMessage requires restarting
    
If you add <USERNAME> anywhere anywhere in the welcome message in the ini or webserver it will replace it with the first and last name of the user logging in
    
Example loginservice config option MessageUrl = "http://www.andromedagrid.com/welcome.txt" [^]

I have tested this patch and it works perfectly.
Tagslogin
Git Revision or version number
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
Script Engine
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Filespng file icon null.png [^] (65,485 bytes) 2015-06-23 14:53


diff file icon WelcomeMessage-fixed.diff [^] (3,698 bytes) 2015-06-23 18:44 [Show Content]
? file icon LLLoginService.cs [^] (49,594 bytes) 2015-06-23 19:29

- Relationships

-  Notes
(0028785)
Diva (administrator)
2015-06-23 14:54

I attached a picture showing what your patch looks like to me. Please resend.
(0028786)
QuillLittlefeather (reporter)
2015-06-23 14:57

why is it doing this?
(0028787)
Diva (administrator)
2015-06-23 15:00

It's being signaled as a binary file.

$ less WelcomeMessage.patch
"WelcomeMessage.patch" may be a binary file. See it anyway?
(0028789)
QuillLittlefeather (reporter)
2015-06-23 15:20

Ok fixed the patch.
(0028790)
Diva (administrator)
2015-06-23 16:22

Thanks, I have a few questions about this patch.

1 - Why this?

+ protected string lastName;
+ protected string firstName;

Where are these being initialized?

2 - Why this?

+ if (m_MessageUrl != String.Empty)
+ {
...
+ }
+ if (m_MessageUrl == String.Empty)
+ {
...
+ }

That should be an else. Also the body of the second one is a subset of the body of the first one. Please refactor.

3 - Indentation seems to be broken.

Please clean up the logic and the indentation, and resubmit. Also, make sure your patch includes your email and name. (this should happen if you have git properly configured before generating the patch)
(0028791)
QuillLittlefeather (reporter)
2015-06-23 18:45

This should be good now I tested the patch and it apply correctly.
(0028816)
Diva (administrator)
2015-06-25 15:05

[15:02] <cia-opensim> opensim: qlittlefeather * r4131fbea0c19 OpenSim/Services/LLLoginService (LLLoginService.cs):
[15:02] <cia-opensim> Changes to Welcome Message sent to clients.
[15:02] <cia-opensim>
[15:02] <cia-opensim> .gitignore | 1 +
[15:02] <cia-opensim> OpenSim/Services/LLLoginService/LLLoginService.cs | 32 +++++++++++++++--------
[15:02] <cia-opensim> 1 files changed, 22 insertions(+), 11 deletions(-)
[15:02] <cia-opensim> http://opensimulator.org/viewgit/?a=commit&p=opensim&h=4131fbea0c190fb5257803fd22758e8b06296df6 [^]
[15:02] <cia-opensim> opensim: diva * rc299414d508d OpenSim/Services/LLLoginService (LLLoginService.cs):
[15:02] <cia-opensim> Fixed bad-ish code in login patch
[15:02] <cia-opensim> http://opensimulator.org/viewgit/?a=commit&p= [^]
(0029209)
aiaustin (developer)
2015-08-18 09:34

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2015-06-23 14:47 QuillLittlefeather New Issue
2015-06-23 14:47 QuillLittlefeather File Added: WelcomeMessage.patch
2015-06-23 14:49 QuillLittlefeather Tag Attached: login
2015-06-23 14:49 QuillLittlefeather Status new => patch included
2015-06-23 14:53 Diva File Added: null.png
2015-06-23 14:54 Diva Note Added: 0028785
2015-06-23 14:56 QuillLittlefeather File Deleted: WelcomeMessage.patch
2015-06-23 14:56 QuillLittlefeather File Added: WelcomeMessage.patch
2015-06-23 14:57 QuillLittlefeather Note Added: 0028786
2015-06-23 15:00 Diva Note Added: 0028787
2015-06-23 15:07 QuillLittlefeather Note Added: 0028788
2015-06-23 15:10 QuillLittlefeather File Deleted: WelcomeMessage.patch
2015-06-23 15:10 QuillLittlefeather File Added: mypatch.patch
2015-06-23 15:19 QuillLittlefeather File Added: mypatch2.patch
2015-06-23 15:19 QuillLittlefeather File Deleted: mypatch.patch
2015-06-23 15:19 QuillLittlefeather File Deleted: mypatch2.patch
2015-06-23 15:20 QuillLittlefeather File Added: WelcomeMessage.patch
2015-06-23 15:20 QuillLittlefeather Note Deleted: 0028788
2015-06-23 15:20 QuillLittlefeather Note Added: 0028789
2015-06-23 16:22 Diva Note Added: 0028790
2015-06-23 18:39 QuillLittlefeather File Added: WelcomeMessage-fixed.diff
2015-06-23 18:43 QuillLittlefeather File Deleted: WelcomeMessage-fixed.diff
2015-06-23 18:44 QuillLittlefeather File Added: WelcomeMessage-fixed.diff
2015-06-23 18:45 QuillLittlefeather Note Added: 0028791
2015-06-23 19:09 QuillLittlefeather File Added: LLoginResponce.diff
2015-06-23 19:16 QuillLittlefeather Note Added: 0028792
2015-06-23 19:26 QuillLittlefeather File Deleted: LLoginResponce.diff
2015-06-23 19:29 QuillLittlefeather File Added: LLLoginService.cs
2015-06-23 19:29 QuillLittlefeather File Deleted: WelcomeMessage.patch
2015-06-23 19:30 QuillLittlefeather Status patch included => patch feedback
2015-06-23 20:09 QuillLittlefeather Note Deleted: 0028792
2015-06-25 15:05 Diva Note Added: 0028816
2015-06-26 16:03 Diva Status patch feedback => resolved
2015-06-26 16:03 Diva Resolution open => fixed
2015-06-26 16:03 Diva Assigned To => Diva
2015-08-18 09:34 aiaustin Note Added: 0029209
2015-08-18 09:34 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker