Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007564opensim[REGION] OpenSim Corepublic2015-05-09 10:182015-06-13 15:01
ReporterDiva 
Assigned ToDiva 
PrioritynormalSeveritymajorReproducibilityunable to reproduce
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0007564: Inventory download hangs temporarily or permanently
DescriptionIn certain simulators in certain grids and for certain avatars, initial inventory download hangs. This happens at least in some sims connected to OSGrid that are far from the servers.

I have been working on this recently, and was able to reduce the time to download considerably, at least as reported by some people. Others, however, still seem to be experiencing hangs in inventory download.

THIS MANTIS IS ABOUT INVENTORY DOWNLOAD GETTING PARTIALLY STUCK AND ABOUT THE TIME IT TAKES TO COMPLETE THE DOWNLOAD.

Anyone having anything to report about this issue, please do it here. For everything else, please open other mantis or go to the general chat that http://opensimulator.org/mantis/view.php?id=7054 [^] has become.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Windows
Mono VersionNone
ViewerAll
Attached Files

- Relationships
related to 0007054closedjustincc Initial inventory fetch seems to hang occasionally 
related to 0007567closedDiva Objects in scene not loading until after avatar and attachments are fully rezzed - change in behaviour at r/25970 
related to 0007563closedDiva Built in AO in viewer doesnt load animation links after relog 
related to 0007593closedaiaustin High memory usage when avatar arrives and is never released 
related to 0007594closedDiva Inventory broken with duplicate requests for the same folder 

-  Notes
(0028354)
Diva (administrator)
2015-05-09 12:56
edited on: 2015-05-09 12:59

@Gavin, can you please explain better what you did, so that I can try to reproduce? (This request goes for everyone reporting issues here)

- Which viewer?
- Left click or right click?
- What should I be doing?

Also, I don't understand your report, as inventory loads once, and from then on it stays loaded. How can you make it download again?

Without details, I won't be able to reproduce. Without reproduction, I won't be able to fix.

(0028356)
Diva (administrator)
2015-05-09 13:17

I could not repro this on either Singularity or Kokua.

In Kokua, in particular, inventory doesn't seem to download automatically. It takes a right click for it to start downloading. It does so without any issues.

If you see this immediately in Singularity, I suspect you may be running a simulator against a robust inventory service that is not updated.
(0028378)
AliciaRaven (manager)
2015-05-15 13:10

Using firestorm 4.7.1 my inventory always shows "Fetching 2,222 items..." I know that the total number of items is 2,222 so I think the simulator has sent all the data but FS is still expecting more for some reason. That happens when i login with a full cache. If i clear cache it loads ok, but then next time i login, it stays on the fetching message again.

Other than this the patch is great, loading times are amazing compared to the old code.

Thanks :)
(0028379)
Diva (administrator)
2015-05-15 13:40

AliciaRaven, there seems to be a separate viewer bug introduced by the latest singulatiry that never gets out of "..." That's independent of this fix being in place or not. If you log in to an older opensim, that happens too. It just happened at around the same time as I was fixing this. Viewer bug.
(0028409)
Mata Hari (reporter)
2015-05-21 08:50

I have now tested under updated ROBUST and regions and can confirm that not only does the inventory fetch hang issue seem to be gone, but the time required to load my entire ~21k inventory from empty cache was *drastically* faster on my own regions now than was the case before. My test under the old system took 20+ minutes to eventually load it when it didn't hang. Under the new system it's under 120 seconds. I'll continue logging to my own regions regularly in case there are intermittent issue, but it certainly seems that the changes have resulted in a huge fix.
(0028412)
aiaustin (developer)
2015-05-21 11:34

Good stuff Mata.

Mata, can you take a look at issue 7567? I believe you also use Windows? Do you see the OSGrid addin region objects rezzing first and then avatar as before or do NO objects appear on your own hosted OSGrid regions until AFTER the avatar rezzes and HUDs are loaded? This was a change of behaviour I noticed between r/25969 and r/25970

http://opensimulator.org/mantis/view.php?id=7567 [^]
(0028594)
Diva (administrator)
2015-06-04 15:30

I'm declaring this particular issue fixed. Please report related inventory issues in other issue reports.

- Issue History
Date Modified Username Field Change
2015-05-09 10:18 Diva New Issue
2015-05-09 10:18 Diva Status new => assigned
2015-05-09 10:18 Diva Assigned To => Diva
2015-05-09 10:18 Diva Relationship added related to 0007054
2015-05-09 10:31 Diva Relationship added related to 0007563
2015-05-09 12:51 Gavin Hird Note Added: 0028353
2015-05-09 12:52 Gavin Hird Note Edited: 0028353 View Revisions
2015-05-09 12:56 Diva Note Added: 0028354
2015-05-09 12:59 Diva Note Edited: 0028354 View Revisions
2015-05-09 13:05 Gavin Hird Note Added: 0028355
2015-05-09 13:17 Diva Note Added: 0028356
2015-05-09 13:21 Gavin Hird Note Added: 0028357
2015-05-10 00:07 Gavin Hird Note Added: 0028358
2015-05-15 07:17 aiaustin Relationship added related to 0007567
2015-05-15 13:10 AliciaRaven Note Added: 0028378
2015-05-15 13:40 Diva Note Added: 0028379
2015-05-21 08:50 Mata Hari Note Added: 0028409
2015-05-21 11:34 aiaustin Note Added: 0028412
2015-05-22 07:40 Gavin Hird Note Deleted: 0028357
2015-05-22 07:40 Gavin Hird Note Deleted: 0028355
2015-05-22 07:40 Gavin Hird Note Deleted: 0028353
2015-05-22 07:40 Gavin Hird Note Deleted: 0028358
2015-05-28 18:25 Seth Nygard Note Added: 0028483
2015-05-28 19:04 danbanner Note Added: 0028484
2015-05-29 05:50 aiaustin Note Added: 0028488
2015-05-29 05:55 Seth Nygard Note Added: 0028489
2015-05-29 13:29 aiaustin Relationship added related to 0007593
2015-05-30 09:16 Seth Nygard Relationship added related to 0007594
2015-06-01 14:34 Diva Note Deleted: 0028483
2015-06-01 14:34 Diva Note Deleted: 0028488
2015-06-01 14:34 Diva Note Deleted: 0028484
2015-06-01 14:34 Diva Note Deleted: 0028489
2015-06-04 15:30 Diva Note Added: 0028594
2015-06-04 15:30 Diva Status assigned => resolved
2015-06-04 15:30 Diva Resolution open => fixed
2015-06-13 15:01 Diva Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker