Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007563opensim[REGION] OpenSim Corepublic2015-05-08 22:572015-05-09 11:44
Reporterdanbanner 
Assigned ToDiva 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0007563: Built in AO in viewer doesnt load animation links after relog
DescriptionSetting up the built-in AO in firestorm requires a folder with animations and a ZHAO style notecard. You open the AO floater and add the notecard to it and firestorm creates a protected folder with links to the anims and displays the animation names in the AO floater. Alternatively, you can skip loading the notecard and drop single animations into the corresponding animation category.

 Either way, upon relog the AO fails to start and the animation names are no longer displayed in the AO floater.
Additional Informationhttp://danbanner.onikenkon.com/screen/Image1431150422.png [^]
TagsNo tags attached.
Git Revision or version numberr/25975
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono Version3.6
ViewerFirestorm
Attached Files? file icon AO.iar [^] (253,157 bytes) 2015-05-08 23:06

- Relationships
related to 0007564closedDiva Inventory download hangs temporarily or permanently 

-  Notes
(0028334)
danbanner (manager)
2015-05-08 23:04

This also seems to affect kokua too
(0028335)
danbanner (manager)
2015-05-08 23:07

I have uploaded an AO with notecard to use for testing.
(0028336)
Jim Jackson (reporter)
2015-05-09 00:37

I can confirm this condition exists with Firestorm and Kokua, Singularity however, seems to be immune. When logging into a region using this build, I had to delete my existing AOs from the AO floater. In Firestorm I had to cleanup the broken links in the Firestorm/AO inventory folder, then reinstall the AO notecard. Logging back into the same region wiped out the links in my Firestorm and Kokua AO.
 The Firestorm AO worked fine when logging into regions using the previous build. It also was ok teleporting to the affected region, just not logging into it.
(0028338)
nebadon (administrator)
2015-05-09 08:09

Here is link to how to use Firestorm AO incase needed for testing purposes > http://wiki.phoenixviewer.com/animation_overrider [^]
(0028340)
Seth Nygard (reporter)
2015-05-09 08:51

I can confirm that I am also seeing the AO links broken in Firestorm with the new build.
(0028341)
Diva (administrator)
2015-05-09 09:00

[08:59] <cia-opensim> opensim: diva * radf0f49a6973 OpenSim/Capabilities/Handlers/FetchInventoryDescendents (FetchInvDescHandler.cs):
[08:59] <cia-opensim> Fix mantis 0007054: AO in Firestorm and Kokua stopped loading after new inventory code in place. Cause: # of descendants was wrong.

Please confirm that this issue is fixed.
(0028350)
danbanner (manager)
2015-05-09 10:43

Yes the links in the AO are back and working correctly with that commit
(0028351)
danbanner (manager)
2015-05-09 11:44

Thanks Diva :)

- Issue History
Date Modified Username Field Change
2015-05-08 22:57 danbanner New Issue
2015-05-08 23:04 danbanner Note Added: 0028334
2015-05-08 23:06 danbanner File Added: AO.iar
2015-05-08 23:07 danbanner Note Added: 0028335
2015-05-09 00:37 Jim Jackson Note Added: 0028336
2015-05-09 07:59 Diva Assigned To => Diva
2015-05-09 07:59 Diva Status new => assigned
2015-05-09 08:09 nebadon Note Added: 0028338
2015-05-09 08:51 Seth Nygard Note Added: 0028340
2015-05-09 09:00 Diva Note Added: 0028341
2015-05-09 09:00 Diva Status assigned => acknowledged
2015-05-09 10:31 Diva Relationship added related to 0007564
2015-05-09 10:43 danbanner Note Added: 0028350
2015-05-09 11:43 Diva Status acknowledged => resolved
2015-05-09 11:43 Diva Resolution open => fixed
2015-05-09 11:44 danbanner Note Added: 0028351
2015-05-09 11:44 danbanner Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker