Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007558opensim[REGION] Scripting Enginepublic2015-05-05 09:072019-02-06 11:50
ReporterLuisillo_Contepomi 
Assigned ToLuisillo_Contepomi 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformWindows LinuxOSWin 0.7 and MONO 3.2.5 OS Version0.8.2.0rc1
Product Versionmaster (dev code) 
Target VersionFixed in Version0.8.1-rc2 
Summary0007558: Script status is not saved.
DescriptionScript status is not saved from 0.8.1 version to now at 0.8.2.0rc1.

In my opensim.ini I have DeleteScriptsOnStartup = "false"

If unmark "running" when region restart script is running again.
Steps To ReproduceCreate a box.
In content folder create a script.

unmark script status as "not running" in script edition window.
close edition window

Type backup in region console.
Restart region

Script is running.!

Edit again the script in box and unmark "again" running.

close edition windows

Restart region

Script is running again.
The status is not saved.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64, .NET / Windows64
Mono Version3.2
Viewer
Attached Filespng file icon scriptstatusnotsaved.png [^] (272,372 bytes) 2015-05-06 08:45

- Relationships
has duplicate 0007599new "Not running" script is set to "running" after restart 

-  Notes
(0028217)
Mata Hari (reporter)
2015-05-05 11:41

Closing this since it was a buggy script (which couldn't have worked in SL as supplied). The fixed script I supplied works perfectly in a 0.8.2 region.
(0028218)
Mata Hari (reporter)
2015-05-05 11:42

My apologies.....accidentally closed the wrong one.
(0028241)
Luisillo_Contepomi (reporter)
2015-05-06 08:46

the script is not important, only the state
(0028247)
Mata Hari (reporter)
2015-05-06 10:26

Tested and confirmed that this bug exists under OpenSim 0.8.2.0 (opensim-8676b01 r/25964 2015-05-06) Dev (Win/.NET) with:

[XEngine]
    DeleteScriptsOnStartup = false


I would expect if this is set to true it would (and should) reset state on startup, but with it false the running state ought to be persisted and isn't.
(0029014)
Luisillo_Contepomi (reporter)
2015-07-29 08:29
edited on: 2015-08-14 10:51

Change severity to "major" because is very important to save the status of scripts in all grids

(0029515)
Luisillo_Contepomi (reporter)
2015-10-24 07:25

Problem is in 0.8.2.0rc1 too.
(0029517)
Luisillo_Contepomi (reporter)
2015-10-26 13:54

Apears as solved in 0.8.2.0rc1 version
(0034599)
BillBlight (developer)
2019-02-06 11:50

Marked as Resolved but never closed, can be reopened if needed.

- Issue History
Date Modified Username Field Change
2015-05-05 09:07 Luisillo_Contepomi New Issue
2015-05-05 11:41 Mata Hari Note Added: 0028217
2015-05-05 11:41 Mata Hari Status new => resolved
2015-05-05 11:41 Mata Hari Resolution open => fixed
2015-05-05 11:41 Mata Hari Assigned To => Mata Hari
2015-05-05 11:42 Mata Hari Note Added: 0028218
2015-05-05 11:42 Mata Hari Status resolved => acknowledged
2015-05-05 11:57 nebadon Assigned To Mata Hari =>
2015-05-05 11:57 nebadon Status acknowledged => new
2015-05-06 08:45 Luisillo_Contepomi File Added: scriptstatusnotsaved.png
2015-05-06 08:46 Luisillo_Contepomi Note Added: 0028241
2015-05-06 10:26 Mata Hari Note Added: 0028247
2015-05-06 10:26 Mata Hari Status new => confirmed
2015-06-02 04:40 AliciaRaven Relationship added has duplicate 0007599
2015-07-29 08:29 Luisillo_Contepomi Note Added: 0029014
2015-07-29 08:29 Luisillo_Contepomi Severity minor => major
2015-08-14 10:51 Luisillo_Contepomi Note Edited: 0029014 View Revisions
2015-10-24 07:25 Luisillo_Contepomi Note Added: 0029515
2015-10-24 07:25 Luisillo_Contepomi OS Version 0.8.1.0 => 0.8.2.0rc1
2015-10-24 07:25 Luisillo_Contepomi Description Updated View Revisions
2015-10-26 13:54 Luisillo_Contepomi Note Added: 0029517
2015-10-26 13:54 Luisillo_Contepomi Status confirmed => resolved
2015-10-26 13:54 Luisillo_Contepomi Fixed in Version => 0.8.1-rc2
2015-10-26 13:54 Luisillo_Contepomi Assigned To => Luisillo_Contepomi
2019-02-06 11:50 BillBlight Note Added: 0034599
2019-02-06 11:50 BillBlight Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker