Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007512opensim[REGION] Script Functionspublic2015-03-26 01:552015-05-04 11:18
ReporterMagnuz 
Assigned ToMagnuz 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionwon't fix 
PlatformIntel Core i7-3770OSUbuntuOS Version12.04
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007512: llCastRay does not use target avatar rotation
DescriptionllCastRay assumes target avatar stands non-rotated, which can give a big difference between visible and actual target profile. Attached is a patch that at least compensates for rotation and facilitates further fine-tuning to avatar shape and pose.

I ran across this when I re-factored and parameterized LSL_Api, so this patch is dependent on the patch "0001-Parameterize-more-constants-in-LSL_Api-and-make-conf.patch" in Mantis 7510. If that patch isn't accepted or applied, wait with this patch.
TagsNo tags attached.
Git Revision or version number0.8.2
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux32
Mono VersionOther
ViewerFirestorm 4.4.2 for OS X
Attached Filespatch file icon 0001-Use-target-avatar-rotation-in-llCastRay.patch [^] (1,997 bytes) 2015-03-26 01:55 [Show Content]

- Relationships
related to 0007546closednebadon llCastRay only partly implemented 

-  Notes
(0028133)
Magnuz (reporter)
2015-04-29 10:43

Mantis 007546 contains a more complete patch for this, so don't apply this one unless the other patch is rejected.
(0028184)
nebadon (administrator)
2015-05-04 10:42

should this mantis be closed now since 7546 is applied?
(0028186)
Magnuz (reporter)
2015-05-04 11:17

Obsolete owing to patch applied from Mantis 7546.
(0028187)
Magnuz (reporter)
2015-05-04 11:18

Code and function verified in patch from Mantis 7546, so closing.

- Issue History
Date Modified Username Field Change
2015-03-26 01:55 Magnuz New Issue
2015-03-26 01:55 Magnuz File Added: 0001-Use-target-avatar-rotation-in-llCastRay.patch
2015-03-26 01:56 Magnuz Status new => patch included
2015-04-29 09:26 Magnuz Relationship added related to 0007546
2015-04-29 10:43 Magnuz Note Added: 0028133
2015-05-04 10:42 nebadon Note Added: 0028184
2015-05-04 11:17 Magnuz Mono Version 2.10 => Other
2015-05-04 11:17 Magnuz Note Added: 0028186
2015-05-04 11:17 Magnuz Status patch included => resolved
2015-05-04 11:17 Magnuz Fixed in Version => master (dev code)
2015-05-04 11:17 Magnuz Resolution open => won't fix
2015-05-04 11:17 Magnuz Assigned To => Magnuz
2015-05-04 11:18 Magnuz Note Added: 0028187
2015-05-04 11:18 Magnuz Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker