Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007488opensim[REGION] Physics Enginespublic2015-03-05 17:472015-04-06 20:37
Reporterkenvc 
Assigned Tokenvc 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual Xeon quad core 32 gbOSWindows 64 bitOS VersionServer 2012
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007488: Flying certain plane scripts on Bulletsim var region fails more often than not and often makes sim unusable until restarted.
DescriptionWhen I try to fly a plane (and sometimes it does this with cars) the vehicle suddenly starts jerking violently and then ends up on the sim border uncontrollable and still violently shaking. I have to TP to get unstuck from the border. From that point forward the sim is virtually unusable.

Walking or trying to fly has a severe rubber band effect with the AV barely moving forward any at all. Reloging does not help. The only way to recover when this happens is to restart the sim. It happens more often that not when trying to use vehicles on this var. These vehicles will work ok on some days for as long as 5 minutes, and other days like today, it happened within 1 minute.
Steps To ReproduceIf you want to test, you can go to OSGrid International sim and try flying a plane. Opensim.log will be attached within a few minutes.

This sim is updated with the latest dev master code as of 745pm cst today.
Additional InformationOpensim.log is attached that starts from the sim startup until after the problem happens with the AV trying to recover by reclogging without restarting the sim. The log contains a ton of Bulletsim login error message about "Bad request for terrain height." and "Reset Position. Mantis this please. Error #9999902" messages, and also "Timeout detected for thread "bulletunmanaged"
TagsNo tags attached.
Git Revision or version numberr/25873
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
Viewersing, fs
Attached Fileslog file icon OpenSim.log [^] (135,701 bytes) 2015-03-05 17:48

- Relationships

-  Notes
(0027778)
Robert Adams (administrator)
2015-03-07 07:17
edited on: 2015-03-07 07:19

The log says that a RezObject happened for a VERY large mesh. The object was fetched from the HG asset server (from an asset server not directly associated with the region) and then something took over a minute to process the mesh. A very large mesh would take a long time to transfer, to store, to process, and then to integrate into the physics world. It is suggestive that BulletSim timed out which could be the physics mesh computation for a large mesh.

After all this time, for some reason, both the object and the avatar were at the position <NaN, NaN, NaN>. Since the mesh was fetched in the middle of processing an incoming avatar, the fetched mesh was probably an attachment.

So, there are two mysteries here: why the attachment inventory request took so long and why the avatar's coordinates ended up as <NaN, NaN, NaN>.

(0027791)
kenvc (reporter)
2015-03-07 10:37

Robert, The AV in that log file was my main AV. I have never used a mesh attachment as long I have been in osg. The plane itself I think is a mesh. As far as the NaN, NaN, NaN position, I assume that refers to the position where the AV flying the plane and the plane ended up after it went crazy. The AV and plane were both right on the sim border under water even though the plane was no where near the border when things went crazy. If the AV unsits to get off the plane at that point, it is standing right on (or maybe even right outside) the sim border and it cannot move away from the border. I can sometimes use the map at this point and teleport back inside the sim and then can sometimes walk and fly. Other times can only turn but cannot move otherwise. The sim often lags way down at that point and has to be restarted to recover.

If needed, I can send you the specific plane and script that does this more often than others in world. If you want it just send a message in-world to Ken Savage and I'll pass it to you.
(0027799)
kenvc (reporter)
2015-03-07 19:53

The NaN code fix misterblue just checked in appears to have fixed the sim crashing lagging issue. The origin of this was a bad script, but now Bullet appears to be insulated from this particular issue.

- Issue History
Date Modified Username Field Change
2015-03-05 17:47 kenvc New Issue
2015-03-05 17:48 kenvc File Added: OpenSim.log
2015-03-05 17:48 kenvc Summary Flying plane on var region fails more often than not and causes sim to be unusable until restarted. => Flying plane on Bulletsim var region fails more often than not and causes sim to be unusable until restarted.
2015-03-07 07:17 Robert Adams Note Added: 0027778
2015-03-07 07:19 Robert Adams Note Edited: 0027778 View Revisions
2015-03-07 10:37 kenvc Note Added: 0027791
2015-03-07 10:37 kenvc Summary Flying plane on Bulletsim var region fails more often than not and causes sim to be unusable until restarted. => Flying certain plane scripts on Bulletsim var region fails more often than not and causes sim to be unusable until restarted.
2015-03-07 10:38 kenvc Summary Flying certain plane scripts on Bulletsim var region fails more often than not and causes sim to be unusable until restarted. => Flying certain plane scripts on Bulletsim var region fails more often than not and often makes sim unusable until restarted.
2015-03-07 19:53 kenvc Note Added: 0027799
2015-03-07 19:53 kenvc Status new => resolved
2015-03-07 19:53 kenvc Fixed in Version => master (dev code)
2015-03-07 19:53 kenvc Resolution open => fixed
2015-03-07 19:53 kenvc Assigned To => kenvc
2015-04-06 20:37 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker