Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007479opensim[GRID] Asset Servicepublic2015-03-04 09:032015-03-04 11:06
Reportercinderblocks 
Assigned ToBlueWall 
PriorityimmediateSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007479: XAssetStore DB needs critical db migration change
DescriptionThis morning I realized that after both my patch to extend the asset description length to 128 does not cover XAssetStore's db tables.

Attaching a patch.
Additional InformationNote that this patch covers MySQL and PGSql, but not SQLite because it appears there is no sqlite migration file for XAssetStore
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono VersionOther
Viewer
Attached Filesdiff file icon XAssetStore-patch.diff [^] (2,942 bytes) 2015-03-04 10:12 [Show Content]

- Relationships

-  Notes
(0027735)
cinderblocks (reporter)
2015-03-04 10:12

Trying again with the patch. Someone with postgresql please test. :)
(0027737)
BlueWall (administrator)
2015-03-04 10:45

This is failing, maybe because of the earlier patch that was applied?
(0027738)
BlueWall (administrator)
2015-03-04 10:47
edited on: 2015-03-04 11:04

OK, reverted the previous patch and it applies cleanly now. Thanks.

(0027740)
BlueWall (administrator)
2015-03-04 11:05

Applied. Thanks for the patches!

PS: In the future, just leave the 1st patch and make the 2nd based on the changes from there.
(0027741)
BlueWall (administrator)
2015-03-04 11:06

Thanks for the patches!

- Issue History
Date Modified Username Field Change
2015-03-04 09:03 cinderblocks New Issue
2015-03-04 09:03 cinderblocks File Added: XAssetStore-patch.diff
2015-03-04 09:05 cinderblocks Status new => patch included
2015-03-04 09:56 cinderblocks File Deleted: XAssetStore-patch.diff
2015-03-04 09:57 cinderblocks File Added: XAssetStore-patch.diff
2015-03-04 10:11 cinderblocks File Deleted: XAssetStore-patch.diff
2015-03-04 10:12 cinderblocks File Added: XAssetStore-patch.diff
2015-03-04 10:12 cinderblocks Note Added: 0027735
2015-03-04 10:25 BlueWall Assigned To => BlueWall
2015-03-04 10:25 BlueWall Status patch included => assigned
2015-03-04 10:45 BlueWall Note Added: 0027737
2015-03-04 10:47 BlueWall Note Added: 0027738
2015-03-04 11:04 BlueWall Note Edited: 0027738 View Revisions
2015-03-04 11:05 BlueWall Note Added: 0027740
2015-03-04 11:06 BlueWall Mono Version trunk => Other
2015-03-04 11:06 BlueWall Note Added: 0027741
2015-03-04 11:06 BlueWall Status assigned => resolved
2015-03-04 11:06 BlueWall Fixed in Version => master (dev code)
2015-03-04 11:06 BlueWall Resolution open => fixed
2015-03-04 11:06 BlueWall Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker