Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007467opensim[REGION] Scripting Enginepublic2015-03-02 12:542015-03-02 17:26
ReporterBlueWall 
Assigned ToBlueWall 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Versionmaster (dev code) 
Summary0007467: Npc movement broken
DescriptionMovement of Npc after using osNpcSetRot is broken at 30b7863 and beyond. Moving the Npc to a location then setting it's rotation causes next move to be very erratic, many times making the Npc travel in directions not assigned, or in loops, sometimes vertical. I found the breaking commit to be 30b7863. I set the level to major because any scripts using rotation of the Npc causes failure of following movements. The Npc in this case are flying to their destinations.
Steps To ReproduceCreate script to rez npc.
move npc to destination via flight
rotate npc
loop over move and rotate to see erratic movements
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono VersionOther
Viewer
Attached Files

- Relationships

-  Notes
(0027680)
BlueWall (administrator)
2015-03-02 17:26

Fixed in master r7e8bad05ec61

- Issue History
Date Modified Username Field Change
2015-03-02 12:54 BlueWall New Issue
2015-03-02 12:55 BlueWall Summary Npc movement borken => Npc movement broken
2015-03-02 17:26 BlueWall Note Added: 0027680
2015-03-02 17:26 BlueWall Status new => resolved
2015-03-02 17:26 BlueWall Fixed in Version => master (dev code)
2015-03-02 17:26 BlueWall Resolution open => fixed
2015-03-02 17:26 BlueWall Assigned To => BlueWall
2015-03-02 17:26 BlueWall Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker