Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007466opensim[REGION] OpenSim Corepublic2015-03-02 12:532015-03-02 14:19
ReporterFreakyTech 
Assigned ToBlueWall 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007466: giving an inventory folder to another user does not work for HG visitor in foreign grid
Descriptionthe attached patch will fix the problem that an inventory folder cannot be given to another user when being an HG visitor.
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region) , Standalone (Multiple Regions) , Grid (1 Region per Sim) , Grid (Multiple Regions per Sim)
Physics EngineBulletSim
EnvironmentUnknown
Mono VersionNone
Viewer
Attached Filespatch file icon 0001-added-missing-senderId-in-GiveInventoryFolder.patch [^] (1,188 bytes) 2015-03-02 12:53 [Show Content]

- Relationships

-  Notes
(0027669)
aiaustin (developer)
2015-03-02 13:07
edited on: 2015-03-02 13:07

If this works, it would be great, as giving a folder to a HG visitor has not worked before, as it does when giving inventory items to a local avatar... you have to pass each item separately for a HG visitor and the receiver has to collect them from various places and add to a new folder.

(0027673)
BlueWall (administrator)
2015-03-02 13:45

So far, giving an item to the HG visitor does not work. There may be some issues with OSGrid though, because the HG avatar is from there and I have no "MySuitcase".
(0027674)
BlueWall (administrator)
2015-03-02 14:03

No luck with giving a folder to my OSGrid avatar either.
(0027675)
BlueWall (administrator)
2015-03-02 14:10

Ok, it does work from a prim in the same region. My initial tests were with a remote vendor (magic box). Patch is good, thanks.
(0027676)
BlueWall (administrator)
2015-03-02 14:17

Applied/Tested OK. Thanks for the patches!

- Issue History
Date Modified Username Field Change
2015-03-02 12:53 FreakyTech New Issue
2015-03-02 12:53 FreakyTech File Added: 0001-added-missing-senderId-in-GiveInventoryFolder.patch
2015-03-02 12:53 FreakyTech Status new => patch included
2015-03-02 13:00 BlueWall Assigned To => BlueWall
2015-03-02 13:00 BlueWall Status patch included => assigned
2015-03-02 13:07 aiaustin Note Added: 0027669
2015-03-02 13:07 aiaustin Note Edited: 0027669 View Revisions
2015-03-02 13:45 BlueWall Note Added: 0027673
2015-03-02 14:03 BlueWall Note Added: 0027674
2015-03-02 14:10 BlueWall Note Added: 0027675
2015-03-02 14:17 BlueWall Note Added: 0027676
2015-03-02 14:17 BlueWall Status assigned => resolved
2015-03-02 14:17 BlueWall Fixed in Version => master (dev code)
2015-03-02 14:17 BlueWall Resolution open => fixed
2015-03-02 14:19 BlueWall Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker