Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007435opensim[REGION] Physics Enginespublic2015-02-03 12:422015-08-18 09:35
Reportermewtwo0641 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version0.8.1-rc1
Product Version0.8.1-rc2 
Target VersionFixed in Version0.8.1-rc2 
Summary0007435: (0.8.1-rc1) Region crossing sometimes results in avatar 'trailing off' until an arrow key is pressed
DescriptionSometimes when walking or running across a region border the avatar will continue walking in that direction until an arrow key is pressed.
Steps To Reproduce1. Walk past a region border

2. As the crossing is taking place let go of the arrow key (it's helpful to let go just before you start to cross i.e. when you feel the 'pull' of the avatar crossing the border)

Expected Result: Avatar should stop moving after the cross is finished

Actual Result: Avatar floats off forward until an arrow key is pressed. This seems to be true whether ODE or BulletSim is selected as the physics engine.
Additional InformationI meant to file this with the 0.8.1-rc1 option but I was unable to locate it.
TagsNo tags attached.
Git Revision or version number
Run Mode Standalone (Multiple Regions)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0027609)
justincc (administrator)
2015-02-25 16:52

Please try git master 412dd7d. This should relieve the issue.
(0027611)
mewtwo0641 (reporter)
2015-02-25 20:02

Working great now; Thank you Justin! :)
(0029263)
aiaustin (developer)
2015-08-18 09:35

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2015-02-03 12:42 mewtwo0641 New Issue
2015-02-03 12:47 mewtwo0641 Steps to Reproduce Updated View Revisions
2015-02-03 13:37 aiaustin Product Version master (dev code) => 0.8.1-rc2
2015-02-25 16:51 justincc Assigned To => justincc
2015-02-25 16:51 justincc Status new => assigned
2015-02-25 16:52 justincc Note Added: 0027609
2015-02-25 20:02 mewtwo0641 Note Added: 0027611
2015-02-25 20:03 mewtwo0641 Status assigned => resolved
2015-02-25 20:03 mewtwo0641 Fixed in Version => 0.8.1-rc2
2015-02-25 20:03 mewtwo0641 Resolution open => fixed
2015-08-18 09:35 aiaustin Note Added: 0029263
2015-08-18 09:35 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker