Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007425opensim[REGION] OpenSim Corepublic2015-01-22 13:562015-03-26 18:42
Reporterkenvc 
Assigned Tokenvc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual Xeon quad core 32 bg ramOSWindows 64 bitOS VersionServer 2012
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007425: Map search sometimes only returns one match even though there may be many matches.
DescriptionMap search often returns only the first match in the list even though there may be many matches. It used to return all the matches in the list, but now you never see more than one. The environment is a Robust grid with a mixture of normal and var region sims.

This is happening now in Singularity and Firestorm so the issue appears to be coming from Opensim. This has been happening at least a week or longer, but cannot specify exactly when it started.
Steps To Reproduce1. Open the map
2. Enter the first few letters of sim names where you know there are a number of sims that start with those same letters. In my case I enter "Moses" because I have several test sims named "Moses #####".
3. The map result list only shows 1 match and the other sims are no longer listed.
Additional InformationThe viewer is running on the same LAN and subnet as the Robust and the simulators. Have not had a chance to try this and see if it happens when the viewer is on a completely different subnet.
TagsNo tags attached.
Git Revision or version numberr/25737
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerSingularity and Firestorm
Attached Files? file icon Odd Map Search Behavior.mp4 [^] (594,497 bytes) 2015-01-27 13:28
jpg file icon 2015-03-10-25875-Map-Search-Test.jpg [^] (113,492 bytes) 2015-03-09 02:23

- Relationships

-  Notes
(0027321)
smxy (reporter)
2015-01-22 14:23

I'm running 97ac80d - r25717 from the 16th, and it's working for me. I have 12 regions that start with the word "The", and when I search for "the", all 12 are returned. I tested in Firestorm (not the current version - one back).

I'll update my grid tonight and see if it still works or not.
(0027322)
smxy (reporter)
2015-01-22 16:01

I'm now running HEAD (edc155c - r25737) and I still get all 12 regions returned when I search for "the". I cannot reproduce your problem.
(0027323)
kenvc (reporter)
2015-01-22 16:07

I'm not sure could be causing this then. smxy, are you also in a windows environment with Robust?
(0027324)
smxy (reporter)
2015-01-22 16:12

Ah, now there's a difference - my grid runs on Linux (CentOS 6.6, to be specific). My viewer runs on MacOS.
(0027325)
kenvc (reporter)
2015-01-22 16:32

Here is some additional info. I went to a non-var sim and waited until everything was rezed, then did a map search for "moses" and all 3 sims showed up in the list! I then exited the map, went back in the map, cleared the search box and entered "moses" again. This time I watched very closely and saw all three sims flash in the list for a split second, then they went away and only the first match remained. I TP'd to a different sim and same problem. I relogged and same problem. Relogged again and it worked the first time, but not again during that login session after that.

Something appears to be almost immediately clearing the listbox after it populates and leaving only a single sim in the list... but it actually worked properly a couple of times. It is actually smelling like some kind of timing issue.
(0027371)
kenvc (reporter)
2015-01-27 13:30

Attached is a new video showing this odd map search behavior. Watch closely and you will momentarily see all the matches flash in the list and then the list clears and only the first match is put in the list.

It acts as if it is receiving the correct list first, then another list that only contains the first match and this wipes out the first list.
(0027451)
kenvc (reporter)
2015-02-01 17:17

I tried the previous Singularity and Firestorm releases and they now have this same behavior. It never did this with these releases before, so it has to be coming from some change in Opensim
(0027823)
aiaustin (developer)
2015-03-09 02:24

I tried on Windows as well.. and it woks fine for me (Servers and Viewer on Windows 8.1, Firestorm 4.6.9 OS 64 bit). See attached image of search for "Vue" on a grid with 4 regions whose names start with "Vue..."

2015-03-10-25875-Map-Search-Test.jpg
(0027944)
kenvc (reporter)
2015-03-26 18:42

I have not seen this issue in the last several weeks, so I assume something changed that has resolved the problem.

- Issue History
Date Modified Username Field Change
2015-01-22 13:56 kenvc New Issue
2015-01-22 14:09 kenvc Steps to Reproduce Updated View Revisions
2015-01-22 14:23 smxy Note Added: 0027321
2015-01-22 14:37 kenvc Description Updated View Revisions
2015-01-22 16:01 smxy Note Added: 0027322
2015-01-22 16:07 kenvc Note Added: 0027323
2015-01-22 16:12 smxy Note Added: 0027324
2015-01-22 16:32 kenvc Note Added: 0027325
2015-01-27 13:28 kenvc File Added: Odd Map Search Behavior.mp4
2015-01-27 13:30 kenvc Note Added: 0027371
2015-01-27 13:39 kenvc File Added: Var Region Reverse Terrain Drawing.mp4
2015-01-27 13:39 kenvc File Deleted: Var Region Reverse Terrain Drawing.mp4
2015-02-01 17:17 kenvc Note Added: 0027451
2015-02-01 17:19 kenvc Description Updated View Revisions
2015-02-01 17:19 kenvc Additional Information Updated View Revisions
2015-03-08 21:14 kenvc Summary Map search is only returning one match even though there may be many matches. => Map search is sometimes only returns one match even though there may be many matches.
2015-03-08 21:15 kenvc Summary Map search is sometimes only returns one match even though there may be many matches. => Map search sometimes only returns one match even though there may be many matches.
2015-03-09 02:23 aiaustin File Added: 2015-03-10-25875-Map-Search-Test.jpg
2015-03-09 02:24 aiaustin Note Added: 0027823
2015-03-26 18:42 kenvc Note Added: 0027944
2015-03-26 18:42 kenvc Status new => resolved
2015-03-26 18:42 kenvc Fixed in Version => master (dev code)
2015-03-26 18:42 kenvc Resolution open => fixed
2015-03-26 18:42 kenvc Assigned To => kenvc
2015-03-26 18:42 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker