Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007404opensim[REGION] OpenSim Corepublic2015-01-06 13:162017-11-23 12:24
ReporterMata Hari 
Assigned ToMata Hari 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionsuspended 
PlatformIntel i7 930 quad coreOperating SystemWindows .NETOperating System VersionWin7 x64
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007404: Terrain editing tools (bulldozer) behaving oddly -- terraforming
DescriptionIt's been a while since I last did conventional terraforming (perhaps 18 months) but I needed to make some tweaks in the last few days and found the behaviour of the basic bulldozen tools to be significantly different than I'd remembered.

- The "raise" tool requires a strength setting of at least 0000030:0000015%-20% before the terrain seems to move at all

- The "lower" tool seems to work fine, making very small changes at near-zero settings

- The "flatten" tool seems to work fine.

- The "smooth" tool seems extremely aggressive in its smoothing, even at near-zero settings. In the past I could set the slider very low and gradually make the contours I wanted, but now even the slightest click at near-zero results in a huge (undesired) smoothing

- The "roughen" tool I can't comment on since I rarely if ever used it in the past so have no basis for comparison

- I haven't tested the revert funtion
Steps To ReproduceTerraform a default flat plane terrain and compare the effects of raise and lower at identical strength settings...they're drastically different

Make a medium "hill" then try to smooth it out to make is suitable for an avatar to walk on (or try making a gently sloping beach to wade in).
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
Viewer4.6.9 (42969) x64 Opensim
Attached Files

- Relationships
related to 0007444new Terrain edit: Smooth , strength slider is not working. 

-  Notes
(0028259)
nebadon (administrator)
2015-05-06 16:29

opps I for some reason resolvd the wrong mantis, sorry!

- Issue History
Date Modified Username Field Change
2015-01-06 13:16 Mata Hari New Issue
2015-02-18 20:05 Mata Hari Relationship added related to 0007444
2015-05-06 11:20 nebadon Note Added: 0028252
2015-05-06 11:20 nebadon Status new => resolved
2015-05-06 11:20 nebadon Resolution open => fixed
2015-05-06 11:20 nebadon Assigned To => nebadon
2015-05-06 16:29 nebadon Note Added: 0028259
2015-05-06 16:29 nebadon Note Deleted: 0028252
2015-05-06 16:29 nebadon Assigned To nebadon =>
2015-05-06 16:29 nebadon Status resolved => new
2017-11-23 12:24 Mata Hari Status new => resolved
2017-11-23 12:24 Mata Hari Resolution fixed => suspended
2017-11-23 12:24 Mata Hari Assigned To => Mata Hari
2017-11-23 12:24 Mata Hari Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker