Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007371opensim[REGION] Physics Enginespublic2014-11-15 06:322015-08-18 09:34
Reportervegaslon 
Assigned ToRobert Adams 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows 7OS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version0.8.1-rc2 
Summary0007371: BulletSim-- Crash when have more then 2-3 cut prims physical.
DescriptionHaving any more then a few cut prims physical will cause a simulator crash. This is really noticable with the use of vehicles that use cut prims for tires to reduce surface friction.

Have included a screencap of what is on the console when it crashes.
Steps To ReproduceRez a cube.
Cut cube.
duplicate cube at least 4 times.
set all cubes physical.
Additional Informationran a git bisect and this is the output

$ git bisect bad
64cf75866e2b555d4d006500f891ba38a8f64bf9 is the first bad commit
commit 64cf75866e2b555d4d006500f891ba38a8f64bf9
Author: Robert Adams <misterblue@misterblue.com>
Date: Mon Aug 18 15:52:49 2014 -0700

    BulletSim: Windows and Linux 32 and 64 bit versions of Bullet 2.82

:040000 040000 efb9c6242c4489421f3073638b38d7d863ff1503 74bca4d3c2831e0d9fd9aeaf
546634c64a268475 M bin
TagsNo tags attached.
Git Revision or version number
Run Mode Standalone (Multiple Regions)
Physics EngineBasicPhysics
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Filespng file icon Bulletsim Crash.png [^] (75,336 bytes) 2014-11-15 06:32

- Relationships

-  Notes
(0027009)
Robert Adams (administrator)
2014-11-22 13:16

This is happening every time on Windows 7. There is no crash on Linux. This means that no one is running anything on windows because this crash makes any linkset vehicle or region with cut objects crash the simulator.
(0027010)
vegaslon (reporter)
2014-11-22 13:47

I thought it was some problem with my configuration. Little did I know it was just my Operating system that is the problem :), I did not think it was serious until it started happening on another test grid after a upgrade.
(0027011)
Mata Hari (reporter)
2014-11-22 14:05

I have several physical linkset vehicles running on a region which is hosted on a Win7(64) system and they don't seem to cause crashes. Could it be limited to Win7-32bit or to people not running Bullet in a separate thread?
(0027046)
Robert Adams (administrator)
2014-11-30 20:00

I just checked in (db2a22e6224164dc80736340c791308150890d03) new BulletSim DLLs which fixes this problem on my test system. Please test and report.
(0029243)
aiaustin (developer)
2015-08-18 09:34

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2014-11-15 06:32 vegaslon New Issue
2014-11-15 06:32 vegaslon File Added: Bulletsim Crash.png
2014-11-15 08:47 vegaslon Additional Information Updated View Revisions
2014-11-15 12:12 Robert Adams Assigned To => Robert Adams
2014-11-15 12:12 Robert Adams Status new => assigned
2014-11-22 13:16 Robert Adams Note Added: 0027009
2014-11-22 13:47 vegaslon Note Added: 0027010
2014-11-22 14:05 Mata Hari Note Added: 0027011
2014-11-30 20:00 Robert Adams Note Added: 0027046
2015-04-06 15:56 vegaslon Status assigned => resolved
2015-04-06 15:56 vegaslon Fixed in Version => 0.8.1-rc2
2015-04-06 15:56 vegaslon Resolution open => fixed
2015-08-18 09:34 aiaustin Note Added: 0029243
2015-08-18 09:34 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker