Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007317opensim[GRID] Hypergridpublic2014-09-08 09:302015-08-18 09:35
Reporterzadark 
Assigned Tozadark 
PriorityurgentSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSMS WindowsOS Version8.1
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007317: HG Teleport. [LLCLIENTVIEW] Exception and objects missing from view
DescriptionDestination simulator console when HG teleporting reports [LLCLIENTVIEW] exception (Additional information). Only a few objects within the destination scene are visible to the visiting avatar.

Commit 41f2f3132bdcbfb8020c7fd6e5f3b7e48c75b1cf 2014-09-05
Steps To ReproduceHG teleport, observe destination simulator console
Additional Information17:09:31 - [SCENE PRESENCE]: Forcing viewers to update the avatar name for attac
h.test @192.168.253.10
17:09:31 - [SCENE PRESENCE]: Restarting scripts in attachments for attach.test @
192.168.253.10 in fun
17:09:31 - [HGFRIENDS MODULE]: Fetched 0 local friends for visitor 1bddc9db-e7c8
-4567-9ebb-9789121dfc0e
17:09:31 - [PRESENCE SERVICE]: ReportAgent: session 4183e7aa-c5fd-40be-b142-bb81
3aad8143, user 1bddc9db-e7c8-4567-9ebb-9789121dfc0e, region 12bed82c-ce35-4ba6-9
e59-2c51eb31992a. Previously: region 12bed82c-ce35-4ba6-9e59-2c51eb31992a
17:09:31 - [LLCLIENTVIEW]: Caught exception while processing OpenMetaverse.Packe
ts.CompleteAgentMovementPacket for attach.test @192.168.253.10, Stat name SendIn
itialDataToClient (attach.test @192.168.253.10 in fun) cannot contain character
. at OpenSim.Framework.Monitoring.Stat..ctor(String shortName, String name, S
tring description, String unitName, String category, String container, StatType
type, MeasuresOfInterest moi, Action`1 pullAction, StatVerbosity verbosity) in c
:\Projects\opensimdev\opensim3\OpenSim\Framework\Monitoring\Stats\Stat.cs:line 1
75
   at OpenSim.Framework.Monitoring.Watchdog.ThreadWatchdogInfo..ctor(Thread thre
ad, Int32 timeout) in c:\Projects\opensimdev\opensim3\OpenSim\Framework\Monitori
ng\Watchdog.cs:line 97
   at OpenSim.Framework.Monitoring.Watchdog.StartThread(ThreadStart start, Strin
g name, ThreadPriority priority, Boolean isBackground, Boolean alarmIfTimeout, F
unc`1 alarmMethod, Int32 timeout, Boolean log) in c:\Projects\opensimdev\opensim
3\OpenSim\Framework\Monitoring\Watchdog.cs:line 223
   at OpenSim.Framework.Monitoring.Watchdog.StartThread(ThreadStart start, Strin
g name, ThreadPriority priority, Boolean isBackground, Boolean alarmIfTimeout, B
oolean log) in c:\Projects\opensimdev\opensim3\OpenSim\Framework\Monitoring\Watc
hdog.cs:line 195
   at OpenSim.Framework.Monitoring.Watchdog.RunInThread(WaitCallback callback, S
tring name, Object obj, Boolean log) in c:\Projects\opensimdev\opensim3\OpenSim\
Framework\Monitoring\Watchdog.cs:line 269
   at OpenSim.Region.Framework.Scenes.ScenePresence.SendInitialDataToClient() in
 c:\Projects\opensimdev\opensim3\OpenSim\Region\Framework\Scenes\ScenePresence.c
s:line 3366
   at OpenSim.Region.Framework.Scenes.ScenePresence.CompleteMovement(IClientAPI
client, Boolean openChildAgents) in c:\Projects\opensimdev\opensim3\OpenSim\Regi
on\Framework\Scenes\ScenePresence.cs:line 1765
   at System.Action`2.Invoke(T1 arg1, T2 arg2)
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleCompleteAgentMovem
ent(IClientAPI sender, Packet Pack) in c:\Projects\opensimdev\opensim3\OpenSim\R
egion\ClientStack\Linden\UDP\LLClientView.cs:line 6755
   at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessSpecificPacketAsy
nc(Object state) in c:\Projects\opensimdev\opensim3\OpenSim\Region\ClientStack\L
inden\UDP\LLClientView.cs:line 741
17:09:32 - [SCENE]: Found presence attach.test @192.168.253.10 1bddc9db-e7c8-456
7-9ebb-9789121dfc0e as root in fun after 1 waits
17:09:32 - [AVFACTORY]: Received texture update for attach.test @192.168.253.10
1bddc9db-e7c8-4567-9ebb-9789121dfc0e
TagsNo tags attached.
Git Revision or version number41f2f3132bdcbfb8020c7fd6e5f3b7e48c75b1cf
Run ModeStandalone (1 Region)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 64 4.6.7.42398
Attached Files

- Relationships

-  Notes
(0026804)
smxy (reporter)
2014-09-08 09:57

I had an HG visitor report the same thing to me in my grid today - about objects being missing and only seeing the bare land. I just checked my logs and see the exact same error as reported in the Additional Information, above.
(0026805)
zadark (reporter)
2014-09-08 10:01

Should emphasize the objects have presence (collision) just not visible.
(0026806)
smxy (reporter)
2014-09-08 10:05

Yes. What he just said. :) They are there, but the visitor doesn't see them, yet is able to collide with them, in spite of that.
(0026807)
hack13 (reporter)
2014-09-08 15:01
edited on: 2014-09-08 15:54

same issue, I have narrowed it down to if you hypergrid from anywhere even grids running the same version of opensimulator (latest master as of this comment) result in this issue.


System Info: OpenSuse 13.1 / Mono 3.6.0 / x86_64
---START ERROR FROM LOG---
17:59:39 - [LLCLIENTVIEW]: Caught exception while processing OpenMetaverse.Packets.CompleteAgentMovementPacket for Timothy.Hoxley @hypergrid.org, Stat name SendInitialDataToClient (Timothy.Hoxley @hypergrid.org in Welcome) cannot contain character . at OpenSim.Framework.Monitoring.Stat..ctor (System.String shortName, System.String name, System.String description, System.String unitName, System.String category, System.String container, StatType type, MeasuresOfInterest moi, System.Action`1 pullAction, StatVerbosity verbosity) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Monitoring.Watchdog+ThreadWatchdogInfo..ctor (System.Threading.Thread thread, Int32 timeout) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Monitoring.Watchdog.StartThread (System.Threading.ThreadStart start, System.String name, ThreadPriority priority, Boolean isBackground, Boolean alarmIfTimeout, System.Func`1 alarmMethod, Int32 timeout, Boolean log) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Monitoring.Watchdog.StartThread (System.Threading.ThreadStart start, System.String name, ThreadPriority priority, Boolean isBackground, Boolean alarmIfTimeout, Boolean log) [0x00000] in <filename unknown>:0
  at OpenSim.Framework.Monitoring.Watchdog.RunInThread (System.Threading.WaitCallback callback, System.String name, System.Object obj, Boolean log) [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.ScenePresence.SendInitialDataToClient () [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.ScenePresence.CompleteMovement (IClientAPI client, Boolean openChildAgents) [0x00000] in <filename unknown>:0
  at (wrapper delegate-invoke) System.Action`2<OpenSim.Framework.IClientAPI, bool>:invoke_void_T1_T2 (OpenSim.Framework.IClientAPI,bool)
  at (wrapper delegate-invoke) System.Action`2<OpenSim.Framework.IClientAPI, bool>:invoke_void_T1_T2 (OpenSim.Framework.IClientAPI,bool)
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleCompleteAgentMovement (IClientAPI sender, OpenMetaverse.Packets.Packet Pack) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessSpecificPacketAsync (System.Object state) [0x00000] in <filename unknown>:0
----END ERROR FROM LOG---

(0026808)
hack13 (reporter)
2014-09-08 15:02

I confirm this happens on teleports from any hg grid, including grids running the same dev code.
(0026815)
zadark (reporter)
2014-09-09 11:50

Initial tests indicate that the issue is resolved with commit b4ce71df1e02c86c6b8470dd7429b21af559d644
(0026816)
zadark (reporter)
2014-09-09 13:42

Issue is resolved commit b4ce71df1e02c86c6b8470dd7429b21af559d644 (r/25236)
(0029299)
aiaustin (developer)
2015-08-18 09:35

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2014-09-08 09:30 zadark New Issue
2014-09-08 09:57 smxy Note Added: 0026804
2014-09-08 10:01 zadark Note Added: 0026805
2014-09-08 10:05 smxy Note Added: 0026806
2014-09-08 15:01 hack13 Note Added: 0026807
2014-09-08 15:02 hack13 Note Added: 0026808
2014-09-08 15:02 hack13 Status new => confirmed
2014-09-08 15:03 hack13 Priority normal => urgent
2014-09-08 15:54 hack13 Note Edited: 0026807 View Revisions
2014-09-09 11:50 zadark Note Added: 0026815
2014-09-09 13:42 zadark Note Added: 0026816
2014-09-09 13:42 zadark Status confirmed => resolved
2014-09-09 13:42 zadark Fixed in Version => master (dev code)
2014-09-09 13:42 zadark Resolution open => fixed
2014-09-09 13:42 zadark Assigned To => zadark
2015-08-18 09:35 aiaustin Note Added: 0029299
2015-08-18 09:35 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker