Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007315opensim[REGION] OpenSim Corepublic2014-09-06 14:482014-09-11 19:31
Reportersmxy 
Assigned Tojustincc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007315: In-region-only "sit position" teleporters broken.
DescriptionOne of my residents uses an (reportedly popular and created by Oddje Otoole in OSGrid) in-region-only "sit position" teleport system, where you place them around the region, set their location in the Description field and reset them through their menu, so that they link up with each other and become visible on each other's menus. To use them, you left click on it, select your destination from the menu, then left click on it again to go there.

The worked perfectly on the code I last built on 7/22. They are broken on HEAD. I was testing with two of them in a region with no neighbors, with one in the NW corner of the sim and one in the NE corner. When they work, they land you on the destination pad. When they fail, they throw you much too far. For example, when I am in the NE and try to go to the NW pad, I either get slammed against the west border or dropped way out past the west border - where there is not actually a region. The same going the other way - either slammed against the east border or put way out past it where there is no region.

Using 'git bisect' (my first time using it - it's really useful! and quick!) it determined that this is the culprit:

[ste@sa5 opensim]$ git bisect bad
a02dae566ce510e7f43c6324996e70442cba3f46 is the first bad commit
commit a02dae566ce510e7f43c6324996e70442cba3f46
Author: Justin Clark-Casey (justincc) <jjustincc@googlemail.com>
Date: Sat Aug 30 00:26:18 2014 +0100

    Fix issue where moving a seated avatar would not adjust their subsequent stand position.

    Addresses http://opensimulator.org/mantis/view.php?id=7299 [^]

:040000 040000 3742d1531521620d1e4964b19927f331f236b76f 3b98963fbe685dc673bc7fa08f12e43b0c6f7be3 M OpenSim
[ste@sa5 opensim]$
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono Version3.6
Viewer
Attached Files

- Relationships

-  Notes
(0026800)
smxy (reporter)
2014-09-06 16:20

Building HEAD, less the change made in the problem commit, results in working telepads.
(0026801)
smxy (reporter)
2014-09-06 16:56
edited on: 2014-09-06 17:01

Oddje also sells a version of these telepads on the Kitely Market, so this may impact a bunch of folks if not fixed.

(0026817)
justincc (administrator)
2014-09-09 16:05

I need an LSL script that demonstrates the problem.
(0026820)
smxy (reporter)
2014-09-09 16:39

I didn't feel right attaching them to the Mantis, since she sells this, so I just emailed you the two scripts from the telepad, with instructions on how to make and set up your own to test with.
(0026827)
justincc (administrator)
2014-09-11 15:47

Yes, git bisect is a very useful tool in situations like this. Thanks also for the script examples. Fixed in git master a3bd708.
(0026831)
smxy (reporter)
2014-09-11 19:31

I can confirm that the issue I reported has been fixed. Thanks, Justin. :)

- Issue History
Date Modified Username Field Change
2014-09-06 14:48 smxy New Issue
2014-09-06 14:50 smxy Description Updated View Revisions
2014-09-06 16:20 smxy Note Added: 0026800
2014-09-06 16:54 smxy Description Updated View Revisions
2014-09-06 16:56 smxy Note Added: 0026801
2014-09-06 17:01 smxy Note Edited: 0026801 View Revisions
2014-09-09 16:05 justincc Assigned To => justincc
2014-09-09 16:05 justincc Status new => assigned
2014-09-09 16:05 justincc Note Added: 0026817
2014-09-09 16:39 smxy Note Added: 0026820
2014-09-11 15:47 justincc Note Added: 0026827
2014-09-11 15:47 justincc Status assigned => resolved
2014-09-11 15:47 justincc Resolution open => fixed
2014-09-11 19:31 smxy Note Added: 0026831
2014-09-11 19:31 smxy Status resolved => closed
2014-09-11 19:31 smxy Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker