Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007249opensim[REGION] Physics Enginespublic2014-07-03 10:362015-01-09 02:49
Reporterdjphil 
Assigned ToRobert Adams 
PriorityhighSeverityblockReproducibilityrandom
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS VersionSeven
Product Version 
Target VersionFixed in Version 
Summary0007249: [BULLETSIM LINKSET COMPOUND] Linkset rebuild warning If this happen s more than one or two times
Description19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=2, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=3, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=4, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=5, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=6, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=7, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=8, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=9, shape=<phy=<p=unknown,s=
SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=10, shape=<phy=<p=unknown,s
=SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETSIM LINKSET COMPOUND]: Linkset rebuild warning. If this happen
s more than one or two times, please report in Mantis 7191
19:27:04 - [BULLETSIM LINKSET COMPOUND]: pName=Deep Sea ATV (Positioned and Scri
pted)/96c713ca-7221-44e0-b230-81f8a1fb4d64, childIdx=11, shape=<phy=<p=unknown,s
=SHAPE_UNKNOWN,k=0,n=False>,c=1>
19:27:04 - [BULLETS SCENE]: ProcessPostTaintTaints: BSLinksetCompound.ScheduleRe
build-2067801766: Exception: System.NullReferenceException: La référence d'objet
 n'est pas définie à une instance d'un objet.
   à OpenSim.Region.Physics.BulletSPlugin.BSAPIUnman.AddToCollisionFlags(BulletB
ody obj, CollisionFlags flags) dans k:\OSGRID\opensim-ca2379e\OpenSim\Region\Phy
sics\BulletSPlugin\BSAPIUnman.cs:ligne 968
   à OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<>c__DisplayClass3.<
RecomputeLinksetCompound>b__2(BSPrimLinkable cPrim) dans k:\OSGRID\opensim-ca237
9e\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:ligne 414
   à OpenSim.Region.Physics.BulletSPlugin.BSLinkset.ForEachMember(ForEachMemberA
ction action) dans k:\OSGRID\opensim-ca2379e\OpenSim\Region\Physics\BulletSPlugi
n\BSLinkset.cs:ligne 205
   à OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.RecomputeLinksetComp
ound() dans k:\OSGRID\opensim-ca2379e\OpenSim\Region\Physics\BulletSPlugin\BSLin
ksetCompound.cs:ligne 362
   à OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<ScheduleRebuild>b__
0() dans k:\OSGRID\opensim-ca2379e\OpenSim\Region\Physics\BulletSPlugin\BSLinkse
tCompound.cs:ligne 114
   à OpenSim.Region.Physics.BulletSPlugin.BSScene.ProcessPostTaintTaints() dans
k:\OSGRID\opensim-ca2379e\OpenSim\Region\Physics\BulletSPlugin\BSScene.cs:ligne
1046
19:27:26 - [SCENE]: Failed on region DigiZone03 with exception Une exception de
type 'System.OutOfMemoryException' a été levée. à System.Threading.Thread.Star
tInternal(IPrincipal principal, StackCrawlMark& stackMark)
   à System.Threading.Thread.Start(StackCrawlMark& stackMark)
   à System.Threading.Thread.Start()
   à OpenSim.Framework.Util.RunThreadNoTimeout(WaitCallback callback, String nam
e, Object obj)
   à OpenSim.Region.Framework.Scenes.Scene.UpdateStorageBackup()
   à OpenSim.Region.Framework.Scenes.Scene.Update(Int32 frames)
19:27:26 - [SCENE]: Failed on region DigiZone02 with exception Une exception de
type 'System.OutOfMemoryException' a été levée. à System.Threading.Thread.Star
tInternal(IPrincipal principal, StackCrawlMark& stackMark)
   à System.Threading.Thread.Start(StackCrawlMark& stackMark)
   à System.Threading.Thread.Start()
   à OpenSim.Framework.Util.RunThreadNoTimeout(WaitCallback callback, String nam
e, Object obj)
   à OpenSim.Region.Framework.Scenes.Scene.UpdateStorageBackup()
   à OpenSim.Region.Framework.Scenes.Scene.Update(Int32 frames)
19:27:26 - [SCENE]: Failed on region DigiZone01 with exception Une exception de
type 'System.OutOfMemoryException' a été levée. à System.Threading.Thread.Star
tInternal(IPrincipal principal, StackCrawlMark& stackMark)
   à System.Threading.Thread.Start(StackCrawlMark& stackMark)
   à System.Threading.Thread.Start()
   à OpenSim.Framework.Util.RunThreadNoTimeout(WaitCallback callback, String nam
e, Object obj)
   à OpenSim.Region.Framework.Scenes.Scene.UpdateStorageBackup()
   à OpenSim.Region.Framework.Scenes.Scene.Update(Int32 frames)
19:27:27 - [SCENE]: Failed on region DigiZone08 with exception Une exception de
type 'System.OutOfMemoryException' a été levée. à System.Threading.Thread.Star
tInternal(IPrincipal principal, StackCrawlMark& stackMark)
   à System.Threading.Thread.Start(StackCrawlMark& stackMark)
   à System.Threading.Thread.Start()
   à OpenSim.Framework.Util.RunThreadNoTimeout(WaitCallback callback, String nam
e, Object obj)
   à OpenSim.Region.Framework.Scenes.Scene.UpdateStorageBackup()
   à OpenSim.Region.Framework.Scenes.Scene.Update(Int32 frames)
19:27:27 - [SCENE]: Failed on region DigiZone04 with exception Une exception de
type 'System.OutOfMemoryException' a été levée. à System.Threading.Thread.Star
tInternal(IPrincipal principal, StackCrawlMark& stackMark)
   à System.Threading.Thread.Start(StackCrawlMark& stackMark)
   à System.Threading.Thread.Start()
   à OpenSim.Framework.Util.RunThreadNoTimeout(WaitCallback callback, String nam
e, Object obj)
   à OpenSim.Region.Framework.Scenes.Scene.UpdateStorageBackup()
   à OpenSim.Region.Framework.Scenes.Scene.Update(Int32 frames)
Region (root) #
Exception non gérée : System.AccessViolationException: Tentative de lecture ou d
'écriture de mémoire protégée. Cela indique souvent qu'une autre mémoire est end
ommagée.
   à OpenSim.Region.Physics.BulletSPlugin.BSAPIUnman.BSAPICPP.PhysicsStep2(IntPt
r world, Single timeStep, Int32 maxSubSteps, Single fixedTimeStep, Int32& update
dEntityCount, Int32& collidersCount)
   à OpenSim.Region.Physics.BulletSPlugin.BSAPIUnman.PhysicsStep(BulletWorld wor
ld, Single timeStep, Int32 maxSubSteps, Single fixedTimeStep, Int32& updatedEnti
tyCount, Int32& collidersCount) dans k:\OSGRID\opensim-ca2379e\OpenSim\Region\Ph
ysics\BulletSPlugin\BSAPIUnman.cs:ligne 208
   à OpenSim.Region.Physics.BulletSPlugin.BSScene.DoPhysicsStep(Single timeStep)
 dans k:\OSGRID\opensim-ca2379e\OpenSim\Region\Physics\BulletSPlugin\BSScene.cs:
ligne 615
   à OpenSim.Region.Physics.BulletSPlugin.BSScene.BulletSPluginPhysicsThread() d
ans k:\OSGRID\opensim-ca2379e\OpenSim\Region\Physics\BulletSPlugin\BSScene.cs:li
gne 824
   à System.Threading.ThreadHelper.ThreadStart_Context(Object state)
   à System.Threading.ExecutionContext.RunInternal(ExecutionContext executionCon
text, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   à System.Threading.ExecutionContext.Run(ExecutionContext executionContext, Co
ntextCallback callback, Object state, Boolean preserveSyncCtx)
   à System.Threading.ExecutionContext.Run(ExecutionContext executionContext, Co
ntextCallback callback, Object state)
   à System.Threading.ThreadHelper.ThreadStart()
19:27:30 - [SCENE]: Failed on region DigiZone05 with exception Une exception de
type 'System.OutOfMemoryException' a été levée. à System.Threading.Thread.Star
tInternal(IPrincipal principal, StackCrawlMark& stackMark)
   à System.Threading.Thread.Start(StackCrawlMark& stackMark)
   à System.Threading.Thread.Start()
   à OpenSim.Framework.Util.RunThreadNoTimeout(WaitCallback callback, String nam
e, Object obj) dans k:\OSGRID\opensim-ca2379e\OpenSim\Framework\Util.cs:ligne 24
45
   à OpenSim.Region.Framework.Scenes.Scene.UpdateStorageBackup() dans k:\OSGRID\
opensim-ca2379e\OpenSim\Region\Framework\Scenes\Scene.cs:ligne 1685
   à OpenSim.Region.Framework.Scenes.Scene.Update(Int32 frames) dans k:\OSGRID\o
pensim-ca2379e\OpenSim\Region\Framework\Scenes\Scene.cs:ligne 1526
19:27:31 - [SCENE]: Failed on region Digital Concepts with exception Une excepti
on de type 'System.OutOfMemoryException' a été levée. à System.Threading.Threa
d.StartInternal(IPrincipal principal, StackCrawlMark& stackMark)
   à System.Threading.Thread.Start(StackCrawlMark& stackMark)
   à System.Threading.Thread.Start()
   à OpenSim.Framework.Util.RunThreadNoTimeout(WaitCallback callback, String nam
e, Object obj) dans k:\OSGRID\opensim-ca2379e\OpenSim\Framework\Util.cs:ligne 24
45
   à OpenSim.Region.Framework.Scenes.Scene.Update(Int32 frames) dans k:\OSGRID\o
pensim-ca2379e\OpenSim\Region\Framework\Scenes\Scene.cs:ligne 1512
Region (root) #
Steps To ReproduceThis happens when I ground a vehicle mesh composed of several parts.
This on normal region, no Var Region.
Additional Informationrelated with : http://opensimulator.org/mantis/view.php?id=7191 [^]
TagsNo tags attached.
Git Revision or version numberOsGrid 0.8.1
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows32
Mono VersionNone
ViewerSingularity, FireStorm
Attached Filesjpg file icon 2014-07-03_19-29-48.jpg [^] (597,462 bytes) 2014-07-03 10:36

- Relationships
duplicate of 0007191closedRobert Adams [BULLETSIM] exception with linkset on startup 

-  Notes
(0026597)
djphil (reporter)
2014-07-26 04:29

Any help to fix this bug would be appreciated. Thank you in advance
(0026732)
djphil (reporter)
2014-08-11 09:12

Today i update my sim to osgrid-opensim-08092014.v0.8.1.8738445
It seems to behave better now.
I do not see an error message or warrnings on the console and my simulator does not crash.

Do you think we can consider the problem solved and close the mantis?
(0027188)
djphil (reporter)
2015-01-09 02:49

Seems resolved, thank you!
(0027189)
djphil (reporter)
2015-01-09 02:49

Seems resolved, thank you!

- Issue History
Date Modified Username Field Change
2014-07-03 10:36 djphil New Issue
2014-07-03 10:36 djphil File Added: 2014-07-03_19-29-48.jpg
2014-07-26 04:29 djphil Note Added: 0026597
2014-07-26 12:18 Robert Adams Assigned To => Robert Adams
2014-07-26 12:18 Robert Adams Status new => assigned
2014-07-26 12:31 Robert Adams Relationship added duplicate of 0007191
2014-08-11 09:12 djphil Note Added: 0026732
2015-01-09 02:49 djphil Note Added: 0027188
2015-01-09 02:49 djphil Status assigned => resolved
2015-01-09 02:49 djphil Resolution open => fixed
2015-01-09 02:49 djphil Note Added: 0027189
2015-01-09 02:49 djphil Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker