Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007230opensim[REGION] OpenSim Corepublic2014-06-22 06:452014-08-15 19:49
Reporterkenvc 
Assigned Tokenvc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual Quad core Xeon 3.2 ghzOSWindows 64 wi 32gbOS VersionServer 2012
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007230: Teleport into SW 256x256 area of a var causes terrain to load reverse order than normal.
DescriptionWhen I teleport into a var region and the var has the landing point set to the far SW sim 256x256 area, the terrain starts loading with the far NE corner of the var first and loads the spot where the AV is standing last. This is reverse of what it should be doing. If the AV flies to the center of the var and logs off, then logs back in to the last location in the var middle, the terrain loads correctly starting at the spot where the av is located and out from there. The load order is hard to see on really fast connections.

This is repeatable 100% of the time under these conditions with SendTerrainUpdatesByViewDistance = true
Steps To ReproduceThis can be tested by teleporting to Commonwealth sim and watching the terrain load. It is hard to see on a fast connection because the terrain loads so fast now.
TagsNo tags attached.
Git Revision or version numberr 24897
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics, BulletSim
EnvironmentUnknown, .NET / Windows64
Mono VersionNone
ViewerReflex, Sing, FS
Attached Filespng file icon Snapshot _ COMMONWEALTH ESTATE, Commonwealth Estate (404, 395, .png [^] (859,258 bytes) 2014-06-22 11:01

- Relationships

-  Notes
(0026347)
danbanner (manager)
2014-06-22 07:32
edited on: 2014-06-22 07:39

for whatever reason, i cant reproduce this. When i teleport to SW corner of a 1024 var with 128 draw distance the only part of the var that draws is the SW part.
http://i.imgur.com/q8GTA2x.png [^]

If i increase my draw more area becomes visible but the last part to draw is always the farthest part away

i assume you refer to Commonwealth estate? seems okay to me

http://i.imgur.com/XwY5uYN.png [^]

higher draw distance:
http://i.imgur.com/eJkOe6a.png [^]

(0026348)
kenvc (reporter)
2014-06-22 07:52

This is with draw distance set to 1024. I am not on a super fast internet connection and its really easy to see the terrain loading first at the far end of the 1024 distance and progressively loading toward the AV.
(0026349)
danbanner (manager)
2014-06-22 09:07
edited on: 2014-06-22 09:08

the terrain on the other end of commonwealth didnt even draw for me at 1024 dd

http://i.imgur.com/Ew7l2rY.png [^]

(0026350)
kenvc (reporter)
2014-06-22 11:02
edited on: 2014-06-22 11:11

I just attached a snapshot taken immediately after teleporting into Commonwealth that clearly shows the terrain loading from the far side of the var first. I am using Replex with draw distance set to 1024 and teleported from a normal (non-var) sim using the same and latest dev master software as of today's date. I cannot explain why I see this happen and others don't.

(0026353)
kenvc (reporter)
2014-06-22 11:17

Please note that this problem does NOT happen when logging in directly to Commonwealth. I only see the problem when already logged in somewhere else and then teleport to Commonwealth using the default location it selects on the map when you do a map search for Commonwealth.
(0026446)
kenvc (reporter)
2014-07-06 15:11
edited on: 2014-07-07 17:18

This is still happening as I saw it happen again several times today. It always happens under the exact conditions described, but never happens under any other conditions. It happens under these conditions regardless of the viewer being used and on every computer and speed of connection I have tried (2/30mb cable internet, hotel internet, etc.) I have only tested it on Windows 7, and Windows 8 64 bit so far because that's all I have available anymore. The terrain still loads fast enough on a var now even when this happens.

Photos are attached that prove this is happening, but this issue can be closed if the devs cannot reproduce this issue on their super fast connections.

(0026539)
kenvc (reporter)
2014-07-21 19:45

Found the way to reproduce this issue and also how to resolve it. If the landing point is set to the far SE 256x256 area, the terrain loads normally. If the landing point is set to the center of the var, it loads in reverse order when you tp in, but normal order if you login.

This isn't that big of a deal anyway, so marking it as resolved even though its still happening.

- Issue History
Date Modified Username Field Change
2014-06-22 06:45 kenvc New Issue
2014-06-22 06:51 kenvc Description Updated View Revisions
2014-06-22 06:51 kenvc Steps to Reproduce Updated View Revisions
2014-06-22 07:32 danbanner Note Added: 0026347
2014-06-22 07:33 danbanner Note Edited: 0026347 View Revisions
2014-06-22 07:37 danbanner Note Edited: 0026347 View Revisions
2014-06-22 07:39 danbanner Note Edited: 0026347 View Revisions
2014-06-22 07:52 kenvc Note Added: 0026348
2014-06-22 09:07 danbanner Note Added: 0026349
2014-06-22 09:08 danbanner Note Edited: 0026349 View Revisions
2014-06-22 11:01 kenvc File Added: Snapshot _ COMMONWEALTH ESTATE, Commonwealth Estate (404, 395, .png
2014-06-22 11:02 kenvc Note Added: 0026350
2014-06-22 11:11 kenvc Note Edited: 0026350 View Revisions
2014-06-22 11:17 kenvc Note Added: 0026353
2014-07-06 15:11 kenvc Note Added: 0026446
2014-07-07 17:18 kenvc Note Edited: 0026446 View Revisions
2014-07-21 19:45 kenvc Note Added: 0026539
2014-07-21 19:45 kenvc Status new => resolved
2014-07-21 19:45 kenvc Fixed in Version => master (dev code)
2014-07-21 19:45 kenvc Resolution open => fixed
2014-07-21 19:45 kenvc Assigned To => kenvc
2014-08-15 19:49 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker