Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007229opensim[REGION] OpenSim Corepublic2014-06-21 07:142015-04-06 20:42
Reporterkenvc 
Assigned ToRobert Adams 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual Quad core Xeon 3.0ghzOSWindows 32GB ramOS VersionServer 2012 64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007229: Teleport from Var to normal sim, both with latest dev master and Viewer locks up about 10-15 secs after TP completes.
DescriptionTeleport from Var to normal sim, both with latest dev master and Viewer locks up about 10-15 secs after TP completes. I have never seen this on a TP from normal to a var, only a normal sim to a var, and rarely on a normal to a normal.

This has been happening for a long time as others have told me about it too.

The viewer typically stays frozen indefinitely until you click on the viewer then it sometimes says not responding and ccloses. A few times it will eventually un-freeze after 30 seconds to a minute and continue as if nothing happened. This seems very repeatable when teleporting from a var in one instance to a normal sim in another, but I and others have also seen it happen between 2 normal sims.
Steps To Reproduce1. TP from a normal sim to a var.
2. Try to TP back to the normal sim after a long time, or immediately, it doesn't seem to matter.
3. Teleport will complete normally and most things will rez, then 10-15 seconds later the viewer freezes.
4. After a few minutes if you click the viewer, it says not responding and crashes.
Additional InformationThe log file from the var originating TP sim (CW file) and the log from the normal destination sim (H file) are attached. In my case the var and normal sim are in a different instances with both running on a different server but on the same LAN. I've seen this happen with every viewer I've tried.
TagsNo tags attached.
Git Revision or version numberr/24896
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerSing, FS, Replex
Attached Filestxt file icon Opensim-CW-Log.txt.txt [^] (19,680 bytes) 2014-06-21 07:14 [Show Content]
txt file icon Opensim-H-Log.txt.txt [^] (35,621 bytes) 2014-06-21 07:14 [Show Content]

- Relationships

-  Notes
(0026329)
Robert Adams (administrator)
2014-06-21 07:20

Which viewer is this? There are some known problems with viewers and TPing between regions with different dimensions.
(0026330)
kenvc (reporter)
2014-06-21 07:23
edited on: 2014-06-21 07:31

Robert,

I have experienced this personally with Sing, FS, and now Replex, which is what I use most of the time now. It happens 80-90% of the time I TP from the CW var to another of my normal sims, both running the latest dev master. I do not know what viewers are being used by the others who have mentioned this same problem to me in the past.

I am not absolutely positive this is isolated only to teleporting from a var, but it certainly happens MUCH more often under that situation.

(0026335)
kenvc (reporter)
2014-06-21 18:21

Just updated to r/24897 since that fix was related to var regions and teleporting, but it did not seem to change this issue. The viewer locked up with the typical white screen about 10 15 seconds after the teleport completed. It did eventually un-freeze as if nothing happened several minutes later rather than totally locking up this time.
(0026336)
kenvc (reporter)
2014-06-21 19:02

Robert,

I found a strange work-around for this issue. I did a double click teleport to a spot a few feet away immediately after the teleport from the var to the normal sim completed, and the viewer did not freeze up. I tried this multiple times and it works every time.

I don't know if this provides any clue as to the cause of this issue, but thought you should know.
(0026337)
Nicky Perian (reporter)
2014-06-21 20:00

with Kokua Nightly build https://sourceforge.net/projects/kokua.team-purple.p/files/Nightly/ [^]
TP between Sandbox Plaza III and LBSA and back and back and back without any freezes.
(0026345)
kenvc (reporter)
2014-06-22 06:27
edited on: 2014-06-22 06:34

I dont have any issues between those 2 Sims with any viewers either. Sandbox plaza 3 rarely has many prims on it and both of those Sims are on super fast internet connections, so I assume that may be the difference. The CW and other var regions where I have seen this happen have up to 30,000 prims on the var and a lot on the normal destination sim too.

I have seen this happen when teleporting from the Commonwealth sim to Wright Plaza as well, and it happens most often when you are not on a really fast connection.

(0026362)
Bruce (reporter)
2014-06-24 04:56
edited on: 2014-06-30 06:23

Confirming that this is happening (r24897; Standalone varregion 1280x1280; BulletSim; .Net / Windows 64; Firestorm, Singularity alpha, Replex alpha)

(0026363)
Nicky Perian (reporter)
2014-06-24 07:52

I don't think this is a teleport issue. I logged on to Commonwealth with Kokua and
received many server textures not found warnings. I crashed once 10 minutes in while walking around commonwealth but could not duplicate the crash. My gut feel is that the region was built up with OARs and the connections to textures is not solid so, the warnings are taking over time in the viewer and it gets behind and finally crashes. The method of teleport by first hitting SW 128,128,x and then moving to the center of the var may be suspect also. Building the scene may be starting at SW 128,128,x and then the immediate move to var landing point may cause confusion as to what textures need rendered.
(0026415)
Bruce (reporter)
2014-06-30 06:11
edited on: 2014-06-30 06:21

Sun 29 Jun 14: Varregion to Lbsa Plaza, arrived destination, Replex viewer froze for 2+ minutes after arrival. Tested with Singularity, result same as with Replex. Tested with Firestorm, arrived destination, viewer froze and crashed after about 3 minutes. Varregion simulator console showing messages for events that occurred at Lbsa Plaza, e.g. people not being able to teleport from Lbsa Plaza to another region in OSGrid or to a region on another grid. This happened when at Lbsa Plaza and Lbsa related messages continued to show-up on the console for the Varregion simulator when back at Varregion. Messages were totally unrelated with what was going on at the Varregion. Teleporting back from Lbsa Plaza to Varregion was almost instantaneous each time. Just reporting this and my apologies for being unable to attach a log for the Varregion simulator for that period (r24902; Standalone varregion 768x768; BulletSim; .Net / Windows 64; Firestorm, Singularity alpha, Replex).

(0026440)
kenvc (reporter)
2014-07-05 14:39
edited on: 2014-07-05 14:42

Update: The work around I mentioned in the previous note does not always work.

I have seen this when teleporting from other vars as well. Commonwealth is a just an example. I see the same issue sometimes when teleporting between 2 non-var regions, but it never totally locks up and if there is a freeze shortly after arriving at the destination sim, it is a very very short freeze.

(0026441)
smxy (reporter)
2014-07-05 16:33
edited on: 2014-07-07 06:57

I'm not seeing this at all. I'm running current HEAD (219d273 - r24921) and doing continuous A->B->A teleports between a 768x768 varregion and a 256x256 region, once every 30 seconds. The regions are not neighbors, nor do they have neighbors. I'm up to 65 circuits, currently - 130 consecutive TPs - and am seeing no problems at all. I'm using the latest ReplexAlpha 1.8.5 (5995). I'll let the test continue, and see if it makes it to 2000 circuits (4000 TPs).

Additional info:
Server's running on CentOS 6.5 & Mono 3.6.1. Viewer's running on MacOS 10.6.8 (I've not seen issues under 10.9.3 or 10.9.4, either). The computer running the viewer is on the same switch as the servers (though a different VLAN).

Up to 838 circuits (1676 consecutive TPs), with no issues, other than 30 seconds generally isn't enough time for all the textures in my varregion to rez, before I TP back.

Test successfully completed at 2000 circuits (4000 consecutive TPs).

(0026442)
Ken_S (reporter)
2014-07-05 18:13

smxy, this is obviously an issue that only effects certain configurations, whether is be the version of OS for the server, for the viewer, or what, we don't yet know.
(0026443)
smxy (reporter)
2014-07-05 18:41

Yes, and I'm just passing along my results, for comparison. That is useful data as well, you know.
(0026447)
kenvc (reporter)
2014-07-06 15:17
edited on: 2014-07-07 17:17

Experienced this several times again today. Sometimes the freeze lasts only 30 seconds, other times its several minutes, and other times it never unfreezes and the viewer must be forcefully closed. Apparently others are experiencing this same issue according to the notes. Maybe we can isolate the conditions where this happens. My sim are running on windows server 2012, and the viewers have been tested on windows 7 and windows 8 64 bit on several different computers and the behavior is the same on all of them. I have tested this on 2/30mb cable internet, as well as slower hotel internet with the same consistent repeatable results. If everyone else having this issue can post their configurations here in the notes, maybe we can find a pattern.

(0026452)
Bruce (reporter)
2014-07-08 17:11

Tested with r24921. Same results as reported by kenvc on 06 Jul and by myself on 24 Jun and 30 Jun. Simulator is on a VM running win2k12 standard server (CPU: 2 Xeon E5506; RAM: 16GB; BW: 5000GB; Port Speed: 1000Mbps). Viewers (Firestorm, Singularity alpha and Replex) are on an iMac running OS X 10.9.4. With a 1280 x 1280 varregion it took almost 2 minutes to pass the handshake stage on login. With a 768 x 768 varregion it now takes about 50 seconds. Data Rate (Kbps) for viewer machine is down 8128 and up 768. In my case, I suspect it is my slow internet connection.
(0026453)
nebadon (administrator)
2014-07-08 17:15

I have been experiencing this myself, its not completely unbearable but I have noticed it too, I use Replex viewer myself.
(0026454)
kenvc (reporter)
2014-07-08 17:35

I created a new var region a few days ago that currently has no prims on it. Teleporting from this var works perfect with no freeze or delay at all. It appears to somehow be related to what is on the departing var... could be prims, textures, or scripts...
(0026455)
Bruce (reporter)
2014-07-08 18:05
edited on: 2014-07-08 18:11

In my case the departing varregion has 3579 objects using 46318 prims and 3125 scripts.

CONNECTION STATISTICS
Client logouts due to no data receive timeout: 0

SAMPLE FRAME STATISTICS
Dilatn SimFPS PhyFPS AgntUp RootAg ChldAg Prims AtvPrm AtvScr ScrLPS
  1.00 34 33.9 0.0 0 0 46318 0 3125 1

PktsIn PktOut PendDl PendUl UnackB TotlFt NetFt PhysFt OthrFt AgntFt ImgsFt
     0 0 0 0 0 29.3 0.0 0.6 0.0 0.0 0.0

MEMORY STATISTICS
Heap allocated to OpenSim : 534 MB
Last heap allocation rate : 0.056 MB/s
Average heap allocation rate: 3.844 MB/s
Process memory : 1951 MB

(0026750)
kenvc (reporter)
2014-08-15 19:46

Bruce, is this still happeneing to you with todays dev master? I just updated and restarted and tested this issues, and so far it has not happened. This is the first time Ive been able to tp from Commonwealth Estates back to my home non-var sim without seeing this long delay or crash.
(0027070)
kenvc (reporter)
2014-12-05 08:55

I have not seen this in a while, so I think it is now fixed.
(0027983)
kenvc (reporter)
2015-04-06 20:42

Closing because var no longer locks up indefinitely, it now locks up for up to a minute, but it usually unfreezes and recovers now rather than crashing. The ne symptoms are in another mantis so closing this one.

- Issue History
Date Modified Username Field Change
2014-06-21 07:14 kenvc New Issue
2014-06-21 07:14 kenvc File Added: Opensim-CW-Log.txt.txt
2014-06-21 07:14 kenvc File Added: Opensim-H-Log.txt.txt
2014-06-21 07:19 kenvc Steps to Reproduce Updated View Revisions
2014-06-21 07:19 kenvc Additional Information Updated View Revisions
2014-06-21 07:20 Robert Adams Note Added: 0026329
2014-06-21 07:20 Robert Adams Assigned To => Robert Adams
2014-06-21 07:20 Robert Adams Status new => assigned
2014-06-21 07:20 kenvc Git Revision or version number => r/24896
2014-06-21 07:20 kenvc Status assigned => new
2014-06-21 07:20 kenvc Description Updated View Revisions
2014-06-21 07:20 kenvc Steps to Reproduce Updated View Revisions
2014-06-21 07:23 kenvc Note Added: 0026330
2014-06-21 07:31 kenvc Note Edited: 0026330 View Revisions
2014-06-21 18:21 kenvc Note Added: 0026335
2014-06-21 19:02 kenvc Note Added: 0026336
2014-06-21 20:00 Nicky Perian Note Added: 0026337
2014-06-22 06:27 kenvc Note Added: 0026345
2014-06-22 06:28 kenvc Note Edited: 0026345 View Revisions
2014-06-22 06:30 kenvc Note Edited: 0026345 View Revisions
2014-06-22 06:31 kenvc Note Edited: 0026345 View Revisions
2014-06-22 06:32 kenvc Note Edited: 0026345 View Revisions
2014-06-22 06:33 kenvc Note Edited: 0026345 View Revisions
2014-06-22 06:33 kenvc Note Edited: 0026345 View Revisions
2014-06-22 06:33 kenvc Note Edited: 0026345 View Revisions
2014-06-22 06:34 kenvc Note Edited: 0026345 View Revisions
2014-06-24 04:56 Bruce Note Added: 0026362
2014-06-24 04:58 Bruce Note Edited: 0026362 View Revisions
2014-06-24 07:52 Nicky Perian Note Added: 0026363
2014-06-30 06:11 Bruce Note Added: 0026415
2014-06-30 06:21 Bruce Note Edited: 0026415 View Revisions
2014-06-30 06:23 Bruce Note Edited: 0026362 View Revisions
2014-07-05 14:39 kenvc Note Added: 0026440
2014-07-05 14:42 kenvc Note Edited: 0026440 View Revisions
2014-07-05 16:33 smxy Note Added: 0026441
2014-07-05 18:13 Ken_S Note Added: 0026442
2014-07-05 18:41 smxy Note Added: 0026443
2014-07-06 07:51 smxy Note Edited: 0026441 View Revisions
2014-07-06 07:52 smxy Note Edited: 0026441 View Revisions
2014-07-06 07:53 smxy Note Edited: 0026441 View Revisions
2014-07-06 07:54 smxy Note Edited: 0026441 View Revisions
2014-07-06 07:54 smxy Note Edited: 0026441 View Revisions
2014-07-06 07:58 smxy Note Edited: 0026441 View Revisions
2014-07-06 15:17 kenvc Note Added: 0026447
2014-07-06 16:00 smxy Note Edited: 0026441 View Revisions
2014-07-07 06:57 smxy Note Edited: 0026441 View Revisions
2014-07-07 17:17 kenvc Note Edited: 0026447 View Revisions
2014-07-08 17:11 Bruce Note Added: 0026452
2014-07-08 17:15 nebadon Note Added: 0026453
2014-07-08 17:15 nebadon Status new => confirmed
2014-07-08 17:35 kenvc Note Added: 0026454
2014-07-08 18:05 Bruce Note Added: 0026455
2014-07-08 18:11 Bruce Note Edited: 0026455 View Revisions
2014-08-15 19:46 kenvc Note Added: 0026750
2014-12-05 08:55 kenvc Note Added: 0027070
2014-12-05 08:55 kenvc Status confirmed => resolved
2014-12-05 08:55 kenvc Fixed in Version => master (dev code)
2014-12-05 08:55 kenvc Resolution open => fixed
2015-04-06 20:42 kenvc Note Added: 0027983
2015-04-06 20:42 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker