Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007228opensim[REGION] OpenSim Corepublic2014-06-21 06:102017-11-15 21:48
ReporterRichardus Raymaker 
Assigned ToRobert Adams 
PrioritynormalSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0007228: Var terrain loading (still) terrible slow.
DescriptionI readed that it must be fixed. waited until 0.8 release for this to try.
But its still not fix, its loading slow from outside to the inner side.
added the following line in opensim.ini

[Terrain]
    SendTerrainUpdatesByViewDistance = true;

strange thing, its loading very fast on normal region, but not on the important variable region. thats not changed at all.

TagsNo tags attached.
Git Revision or version number0.8 release
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerSingularity 1.8.5 (5617)
Attached Files

- Relationships

-  Notes
(0026325)
danbanner (manager)
2014-06-21 06:55

You might want to use 'config show Terrain' in the console to see if that setting is actually being used. I have added this to my vars and they load terrain quickly
(0026327)
Richardus Raymaker (reporter)
2014-06-21 07:05

console is saying, SendTerrainUpdatesByViewDistance = true;
but not see any difference compared to some version from april.
(0026328)
Robert Adams (administrator)
2014-06-21 07:17

Is it possible you could use Fraps or similar and capture a video of the slow loading?
(0026332)
Richardus Raymaker (reporter)
2014-06-21 07:36
edited on: 2014-06-21 07:46

Posting a video soon, noted one thing. when i login on the var. or teleport in for the first time its loading slow. the next time you teleport in its showing things fast.

Add: Here's the video. getting the idea that var region terrain need to be buffer at startup of the simulator, otherwise i could not explain why its loading fast the second time i go back to the region in one session. After relog its again slow for the first time. well slow...

https://www.youtube.com/watch?v=QgJ4uGMtG7A&feature=youtu.be [^]

(0026357)
Garmin Kawaguichi (reporter)
2014-06-23 08:16
edited on: 2014-06-23 08:18

Using an extended minimap and a 1280x1280 varregion, it gives a better idea of the appearance of the terrain in a spiral fashion.

(0032441)
TomTheDragon (reporter)
2017-11-15 21:48

I can confirm that this is still an issue in master.

- Issue History
Date Modified Username Field Change
2014-06-21 06:10 Richardus Raymaker New Issue
2014-06-21 06:55 danbanner Note Added: 0026325
2014-06-21 07:05 Richardus Raymaker Note Added: 0026327
2014-06-21 07:17 Robert Adams Note Added: 0026328
2014-06-21 07:17 Robert Adams Assigned To => Robert Adams
2014-06-21 07:17 Robert Adams Status new => assigned
2014-06-21 07:36 Richardus Raymaker Note Added: 0026332
2014-06-21 07:46 Richardus Raymaker Note Edited: 0026332 View Revisions
2014-06-23 08:16 Garmin Kawaguichi Note Added: 0026357
2014-06-23 08:18 Garmin Kawaguichi Note Edited: 0026357 View Revisions
2017-11-15 21:48 TomTheDragon Note Added: 0032441


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker