Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007214opensim[REGION] Script Functionspublic2014-06-12 05:422016-12-14 14:26
Reporterdjphil 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformPCOSWindowsOS VersionSeven
Product Version 
Target VersionFixed in Version 
Summary0007214: [SCRIPT] PRIM_MEDIA_AUTO_PLAY TRUE does not work with llSetLinkMedia
DescriptionI see PRIM_MEDIA_AUTO_PLAY, TRUE does not work when I use it in the llSetLinkMedia function. I have to click a second time to display the content. The content is not displayed automatically.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows32
Mono VersionNone
ViewerSingularity, FireStorm
Attached Files

- Relationships

-  Notes
(0026598)
djphil (reporter)
2014-07-26 04:36

Have you also noticed this bug? It really does not operate correctly.
(0031454)
djphil (reporter)
2016-12-14 14:26
edited on: 2016-12-14 14:27

I ha retested this one today and it do not work yet.

default
{
    state_entry()
    {
        llSay(0, "Script running");
        
        llSetPrimMediaParams(0, [
        // llSetLinkMedia(2, 0, [
            PRIM_MEDIA_CURRENT_URL, "data:text/html," + "Autoplay test", 
            PRIM_MEDIA_WIDTH_PIXELS, 128,
            PRIM_MEDIA_HEIGHT_PIXELS, 128, 
            PRIM_MEDIA_PERMS_INTERACT, 
            PRIM_MEDIA_PERM_NONE, 
            PRIM_MEDIA_PERMS_CONTROL, 
            PRIM_MEDIA_PERM_NONE, 
            PRIM_MEDIA_AUTO_PLAY, TRUE
        ]);
    }

    touch_start(integer number)
    {
        // llSetPrimMediaParams(0, [
        llSetLinkMedia(2, 0, [
            PRIM_MEDIA_CURRENT_URL, "data:text/html," + "Autoplay test", 
            PRIM_MEDIA_WIDTH_PIXELS, 128,
            PRIM_MEDIA_HEIGHT_PIXELS, 128, 
            PRIM_MEDIA_PERMS_INTERACT, 
            PRIM_MEDIA_PERM_NONE, 
            PRIM_MEDIA_PERMS_CONTROL, 
            PRIM_MEDIA_PERM_NONE, 
            PRIM_MEDIA_AUTO_PLAY, TRUE
        ]);  
    }
}

Tested with Firestorm, with and without "Allow media to auto-play"
(preference/sound and media/media)


- Issue History
Date Modified Username Field Change
2014-06-12 05:42 djphil New Issue
2014-07-26 04:36 djphil Note Added: 0026598
2016-12-14 14:26 djphil Note Added: 0031454
2016-12-14 14:27 djphil Note Edited: 0031454 View Revisions
2016-12-14 14:27 djphil Note Edited: 0031454 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker