Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007212opensim[GRID] Hypergridpublic2014-06-11 19:592014-07-29 13:43
Reporterkenvc 
Assigned Tokenvc 
PrioritynormalSeveritycrashReproducibilityrandom
StatusclosedResolutionfixed 
PlatformDual quad core Xeon processorsOSWindows 64 32gbOS VersionServer 2012
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007212: Sim crash caused by hypergrid inventory duplicate key
DescriptionThe log file indicates the crash was caused by an inventory item with a duplicate key.
Steps To ReproduceNot sure how to reproduce this, but inventory should not cause a sim crash
Additional Information

2014-06-11 21:02:58,444 DEBUG - OpenSim.Region.Framework.Scenes.ScenePresence [SCENE PRESENCE]: Making Lumen.One @120.146.220.162 a child agent in Free Mall 1
2014-06-11 21:03:00,019 INFO - OpenSim.Framework.SynchronousRestObjectRequester [LOGHTTP]: Slow SynchronousRestObject request 6806 POST to http://120.146.220.162:9000/assets/ [^] took 3073ms, 483ms writing, ?<?xml version="1.0" encoding="utf-8"?><AssetBase xmlns:xsd="http://www.w3.org/2001/XMLSchema" [^] xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><Data>PD94bWwgdmVyc2lvbj0iMS4wIiBlbmNvZGluZz0idXRmL [^]
2014-06-11 21:03:00,035 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 056aa4b6-8e93-4673-ab75-45295e059999 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:02,531 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 046d5a1b-e80d-414b-a965-c0fb287088fb from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:03,436 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset aca5c867-ab53-4949-b0dc-1eeccb017e06 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:04,325 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 488e5baa-595a-4a66-aac3-4b9225ae9630 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:05,167 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 8b464e4a-7049-46e1-bee5-9c65e8c8c84e from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:07,289 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 16f5b498-b59c-4d8d-ba36-4f9bac7306f8 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:08,147 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 1566448b-9d59-4ad9-a54c-40b27375f828 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:08,428 INFO - OpenSim.Framework.WebUtil [LOGHTTP]: Slow JSON-RPC request 6813 DELETE to http://93.56.126.213:9000/agent/92d80716-d89c-4a9c-9715-f01d795706fd/65ad13d1-87d7-47e0-a5ee-fc192d602d3d/?auth=3dc79240-a1fc-4750-b4f1-003ba58d545a [^] took 10030ms, 0ms writing,
2014-06-11 21:03:08,428 DEBUG - OpenSim.Framework.WebUtil [LOGHTTP]: JSON-RPC request 6813 DELETE to http://93.56.126.213:9000/agent/92d80716-d89c-4a9c-9715-f01d795706fd/65ad13d1-87d7-47e0-a5ee-fc192d602d3d/?auth=3dc79240-a1fc-4750-b4f1-003ba58d545a [^] FAILED: The operation has timed out
2014-06-11 21:03:08,958 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 1d8b8e5e-db52-482b-ab7a-8ec526f66203 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:09,863 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 99fc22a1-f619-47a2-9a7f-9b837c02bc29 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:12,250 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 4a52d2fd-d67c-4b3d-b4b4-0f5b02215d88 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:13,108 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset cc45e11e-bf76-4f7d-8b7d-71727c49c5fe from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:13,467 DEBUG - OpenSim.Region.CoreModules.Framework.EntityTransfer.EntityTransferModule [ENTITY TRANSFER MODULE]: Closing agent Lumen.One @120.146.220.162 in Free Mall 1 after teleport
2014-06-11 21:03:13,467 DEBUG - OpenSim.Region.ClientStack.LindenUDP.LLClientView [CLIENT]: Close has been called for Lumen.One @120.146.220.162 attached to scene Free Mall 1
2014-06-11 21:03:13,467 DEBUG - OpenSim.Region.Framework.Scenes.Scene [SCENE]: Removing child agent Lumen.One @120.146.220.162 92d80716-d89c-4a9c-9715-f01d795706fd from Free Mall 1
2014-06-11 21:03:13,467 DEBUG - OpenSim.Region.CoreModules.Framework.CapabilitiesModule [CAPS]: Remove caps for agent 92d80716-d89c-4a9c-9715-f01d795706fd in region Free Mall 1
2014-06-11 21:03:13,482 DEBUG - OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.HGInventoryBroker [HG INVENTORY CONNECTOR]: Removed http://120.146.220.162:9000 [^] from the cache of inventory URLs
2014-06-11 21:03:13,482 DEBUG - OpenSim.Region.CoreModules.Framework.EntityTransfer.EntityTransferStateMachine [ENTITY TRANSFER STATE MACHINE]: Agent 92d80716-d89c-4a9c-9715-f01d795706fd cleared from transit in Free Mall 1
2014-06-11 21:03:14,512 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset bf01654b-dfe3-4785-b87d-5d5ef8c9ef87 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:14,839 DEBUG - OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.HGInventoryBroker [HG INVENTORY CONNECTOR]: Added http://120.146.220.162:9000 [^] to the cache of inventory URLs
2014-06-11 21:03:15,323 DEBUG - OpenSim.Region.CoreModules.Framework.InventoryAccess.HGAssetMapper [HG ASSET MAPPER]: Posted copy of asset 66220490-095c-418e-bd12-1346253b9891 from local asset server to http://120.146.220.162:9000/ [^]
2014-06-11 21:03:15,448 ERROR - OpenSim.Application [APPLICATION]:
APPLICATION EXCEPTION DETECTED: System.UnhandledExceptionEventArgs

Exception: System.ArgumentException: An item with the same key has already been added.
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)
   at OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.HGInventoryBroker.CacheInventoryServiceURL(UUID userID) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\CoreModules\ServiceConnectorsOut\Inventory\HGInventoryBroker.cs:line 265
   at OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.HGInventoryBroker.GetInventoryServiceURL(UUID userID) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\CoreModules\ServiceConnectorsOut\Inventory\HGInventoryBroker.cs:line 290
   at OpenSim.Region.CoreModules.ServiceConnectorsOut.Inventory.HGInventoryBroker.GetFolder(InventoryFolderBase folder) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\CoreModules\ServiceConnectorsOut\Inventory\HGInventoryBroker.cs:line 585
   at OpenSim.Capabilities.Handlers.WebFetchInvDescHandler.Fetch(UUID agentID, UUID folderID, UUID ownerID, Boolean fetchFolders, Boolean fetchItems, Int32 sortOrder, Int32& version, Int32& descendents) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Capabilities\Handlers\WebFetchInventoryDescendents\WebFetchInvDescHandler.cs:line 253
   at OpenSim.Capabilities.Handlers.WebFetchInvDescHandler.FetchInventoryReply(LLSDFetchInventoryDescendents invFetch) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Capabilities\Handlers\WebFetchInventoryDescendents\WebFetchInvDescHandler.cs:line 161
   at OpenSim.Capabilities.Handlers.WebFetchInvDescHandler.FetchInventoryDescendentsRequest(String request, String path, String param, IOSHttpRequest httpRequest, IOSHttpResponse httpResponse) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Capabilities\Handlers\WebFetchInventoryDescendents\WebFetchInvDescHandler.cs:line 111
   at OpenSim.Region.ClientStack.Linden.WebFetchInvDescModule.PollServiceInventoryEventArgs.Process(aPollRequest requestinfo) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\ClientStack\Linden\Caps\WebFetchInvDescModule.cs:line 364
   at OpenSim.Region.ClientStack.Linden.WebFetchInvDescModule.WaitProcessQueuedInventoryRequest() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\ClientStack\Linden\Caps\WebFetchInvDescModule.cs:line 441
   at OpenSim.Region.ClientStack.Linden.WebFetchInvDescModule.DoInventoryRequests() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\ClientStack\Linden\Caps\WebFetchInvDescModule.cs:line 432
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

Application is terminating: True
TagsNo tags attached.
Git Revision or version numberr24841
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics, ODE, BulletSim
EnvironmentUnknown, .NET / Windows32
Mono VersionNone
Viewerna
Attached Filespatch file icon InventoryURLFix.patch [^] (911 bytes) 2014-06-15 07:12 [Show Content]

- Relationships

-  Notes
(0026260)
FreakyTech (reporter)
2014-06-15 07:12

I digged that thing on my forked version already. So I added that patch for it.
(0026262)
Diva (administrator)
2014-06-15 07:20

This patch is ok, but I get this error when applying it:
git.exe am --3way --ignore-space-change --keep-cr "C:\Users\crista\Downloads\InventoryURLFix.patch"
Patch format detection failed.

Fail
(0026263)
Diva (administrator)
2014-06-15 07:27

I made the change in the code.

[07:26] <cia-opensim> opensim: diva * rdcd8e745846a OpenSim/Region/CoreModules/ServiceConnectorsOut/Inventory (HGInventoryBroker.cs):
[07:26] <cia-opensim> Manual change as per patch in mantis 0007212. (the patch failed to apply, but the fix was good) Thanks FreakyTech.

In the future, please send patches in a way that we can apply them with git, preferably with your information in it, so that your id goes on record. Thanks!
(0026331)
kenvc (reporter)
2014-06-21 07:26

This was something that rarely happened, so I am not sure I can absolutely prove this is fixed, but it has not happened since this patch was submitted, so closing it as fixed.

- Issue History
Date Modified Username Field Change
2014-06-11 19:59 kenvc New Issue
2014-06-15 07:12 FreakyTech File Added: InventoryURLFix.patch
2014-06-15 07:12 FreakyTech Note Added: 0026260
2014-06-15 07:12 FreakyTech Status new => patch included
2014-06-15 07:20 Diva Note Added: 0026262
2014-06-15 07:27 Diva Note Added: 0026263
2014-06-21 07:26 kenvc Note Added: 0026331
2014-06-21 07:26 kenvc Status patch included => resolved
2014-06-21 07:26 kenvc Fixed in Version => master (dev code)
2014-06-21 07:26 kenvc Resolution open => fixed
2014-06-21 07:26 kenvc Assigned To => kenvc
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker