Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000721opensim[REGION] OpenSim Corepublic2008-03-05 13:012011-07-26 21:39
ReporterMind Booster Noori 
Assigned ToAdam 
PrioritylowSeverityfeatureReproducibilityalways
StatusconfirmedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000721: opensim does not support https in *STANDALONE*
Descriptionopensim does not support https, which is a showstopper for a lot of people... It would be awsome to see HTTPS support on the roadmap!
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineBasicPhysics
Script Engine
EnvironmentMono / Linux32
Mono VersionNone
Viewer
Attached Files

- Relationships

-  Notes
(0000818)
Teravus (administrator)
2008-03-05 13:03

There's HTTPS support on the UserServer, just a FYI.
(0000908)
Sakai (developer)
2008-03-08 07:52

do you still require this to be open?
(0001028)
sdague (administrator)
2008-03-14 07:34

no response to feedback after a week. Closing out due to lack of specificity.
(0001053)
Mind Booster Noori (reporter)
2008-03-14 08:16

I'm sorry I took so long to reply.
As far as I understand, UserServer is only used in grid mode, and not in the Standalone mode. If someone wants to have one standalone OpenSim server (which is my case), then https isn't available (please correct me if I'm wrong), and my feature request was to have https in standalone mode (sorry for not being this explicit before).
(0002550)
cfk (administrator)
2008-05-25 19:13

Please confirm that this is still an issue and that it should still be open. If this is an issue, please add a note with some more details to allow the developers to duplicate it.

The issue is that we have so many Mantis that it is becoming difficult to focus, so confirming notes with more data to allow duplication is becoming very important.
(0006561)
Fly-Man- (developer)
2008-10-26 17:02

Adam, is there a patch for this issue or is it safe to close it ?
(0008410)
cfk (administrator)
2008-12-24 12:16

I am closing this as I believe there are lots of larger issues to contend with.

Charles
(0008420)
Mind Booster Noori (reporter)
2008-12-24 13:40

Hi there,

I understand that this issue is an "wishlist" item more than a bug, and I also understand that when there are bugs to solve, looking to this issue might have no priority in all. So, I would be happy to see this mantis entry marked as a low priority item or, if that's really the case, as a "WONTFIX" (well, I would not like to see it in that state, but it would be quite understandable). Yet, having this marked as "fixed" is erroneous, so I'm reopening this bug entry, and asking you to please reconsider it.

Best regards,
--
Marcos Marado
(0008421)
Teravus (administrator)
2008-12-24 13:40

I also vouch for the importance of this issue. It really has re-occured since the switch of the HTTP server
(0010323)
Adam (administrator)
2009-04-01 18:28

This is a really long standing issue - but we're adding support for this at the moment actually. Our developers had a patch for me yesterday, but I sent it back for an additional round of reworking.

There obviously will be some limits - you will need a cert in your opensim dir (we're making it ini configurable). Fingers crossed should be in soon.
(0019069)
makopoppo (manager)
2011-07-24 03:14

Reminder sent to: BlueWall, justincc

I'm not sure the current status of this issue, any change has made after the post above?
(0019135)
BlueWall (administrator)
2011-07-26 21:39
edited on: 2011-07-26 21:41

https does work in standalone like in grid mode. It is just for utility purposes (remote admin, lsl webserver, etc.) and not for servicing the viewer and logins.


- Issue History
Date Modified Username Field Change
2008-03-05 13:01 Mind Booster Noori New Issue
2008-03-05 13:01 Mind Booster Noori Environment => Mono / Linux32
2008-03-05 13:01 Mind Booster Noori Physics Engine => BasicPhysics
2008-03-05 13:01 Mind Booster Noori Run Mode => Standalone (1 Region)
2008-03-05 13:01 Mind Booster Noori SVN Revision => 0
2008-03-05 13:03 Teravus Note Added: 0000818
2008-03-08 07:52 Sakai Note Added: 0000908
2008-03-08 07:52 Sakai Status new => feedback
2008-03-14 07:34 sdague Status feedback => closed
2008-03-14 07:34 sdague Note Added: 0001028
2008-03-14 07:34 sdague Resolution open => suspended
2008-03-14 08:16 Mind Booster Noori Status closed => feedback
2008-03-14 08:16 Mind Booster Noori Resolution suspended => reopened
2008-03-14 08:16 Mind Booster Noori Note Added: 0001053
2008-03-14 08:55 Teravus Status feedback => new
2008-03-14 08:55 Teravus Resolution reopened => open
2008-03-14 08:55 Teravus Category [GRID] Grid Server => [REGION] OpenSim Core
2008-03-14 08:55 Teravus Product Version => SVN
2008-03-14 08:55 Teravus Summary opensim does not support https => opensim does not support https in *STANDALONE*
2008-05-25 19:13 cfk Note Added: 0002550
2008-05-26 14:07 cfk Status new => assigned
2008-05-26 14:07 cfk Assigned To => Adam
2008-10-26 17:02 Fly-Man- Note Added: 0006561
2008-10-26 17:02 Fly-Man- Status assigned => feedback
2008-12-24 12:16 cfk Mono Version => None
2008-12-24 12:16 cfk Status feedback => resolved
2008-12-24 12:16 cfk Resolution open => fixed
2008-12-24 12:16 cfk Note Added: 0008410
2008-12-24 13:40 Mind Booster Noori Status resolved => feedback
2008-12-24 13:40 Mind Booster Noori Resolution fixed => reopened
2008-12-24 13:40 Mind Booster Noori Note Added: 0008420
2008-12-24 13:40 Teravus Note Added: 0008421
2008-12-24 13:41 Mind Booster Noori Run Mode Standalone (1 Region) => Standalone (1 Region)
2008-12-24 13:41 Mind Booster Noori Physics Engine BasicPhysics => BasicPhysics
2008-12-24 13:41 Mind Booster Noori Environment Mono / Linux32 => Mono / Linux32
2008-12-24 13:41 Mind Booster Noori Priority normal => low
2008-12-24 13:41 Mind Booster Noori Status feedback => confirmed
2008-12-26 14:09 Teravus Target Version => 0.6.2
2009-04-01 18:28 Adam Note Added: 0010323
2011-07-24 03:14 makopoppo Note Added: 0019069
2011-07-26 21:39 BlueWall Note Added: 0019135
2011-07-26 21:41 BlueWall Note Edited: 0019135


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker