Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007209opensim[REGION] Script Functionspublic2014-06-06 02:352016-07-06 01:08
Reporterdjphil 
Assigned Todjphil 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS VersionSeven
Product Version 
Target VersionFixed in Version 
Summary0007209: [Script] PRIM_OMEGA return no values
DescriptionPRIM_OMEGA return no values.

Tested with:
llGetPrimitiveParams([PRIM_OMEGA]);

and with:
llGetLinkPrimitiveParams(LINK_ROOT, [PRIM_OMEGA]);
Steps To ReproduceScript for testing:

default
{
    state_entry()
    {
       llTargetOmega(<1.0,1.0,1.0>*llGetRot(), 0.1, 0.01);
    }

    touch_start(integer number)
    {
        list params = llGetPrimitiveParams([PRIM_OMEGA]);
        // list params = llGetLinkPrimitiveParams(LINK_ROOT, [PRIM_OMEGA]);
        string msg = "\nAxis = " + llList2String(params, 0);
        msg += "\nSpinrate = " + llList2String(params, 1);
        msg += "\nGain = " + llList2String(params, 2);
        llSay(0, (string)msg);
        llSay(0, llList2CSV(params));
    }
}
TagsNo tags attached.
Git Revision or version numberOsGrid 0.8.0
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
EnvironmentUnknown
Mono VersionNone
ViewerSingularity, FireStorm
Attached Files

- Relationships

-  Notes
(0026599)
djphil (reporter)
2014-07-26 04:36

Have you also noticed this bug? It really does not operate correctly.
(0030032)
djphil (reporter)
2016-01-28 04:31

The problem persists in OS v0.9.x
(0030363)
djphil (reporter)
2016-05-22 07:59

No change in OpenSim 0.9.0.0 Dev
OSgrid 0.9.0.0 (Dev) 057d1b2: 2016-05-16 (Win/.NET)
(0030789)
UbitUmarov (administrator)
2016-06-26 06:49

added code to return some values.
this values will be different from SL because we don't do target omega the same way. we don't support gain for example ( will return 1.0 or 0.0 if stopped)
in your example above it returns:
Object: <0.577350, 0.577350, 0.577350>, 0.173205, 1.000000
because you did not normalized the axis vector. <1,1,1> has norm 1.73205
did not test much :(
(0030792)
UbitUmarov (administrator)
2016-06-26 14:26

this is just like llGetOmega, but returned axis is the normalized angular velocity (omega) and spinrate its magnitude.
as I said gain will be 1.0 if rotating, 0.0 if not.

it is the omega of the prim containing the script, so on child prims axis maybe relative to prim local axis.

keep in mind that in 0.9 opensim, lltargetomega on root physical prims will cause a real object rotation around object center of mass, while on child physical prims its viewer side effect only as in non physical case.
(0030873)
djphil (reporter)
2016-07-05 21:30

It returns values now but I am not sure that these values are correct.

llTargetOmega(<1.0, 1.0, 1.0>, 0.5, 0.5);
return
[21:27] Object: <0.577350, 0.577350, 0.577350>, 0.866025, 1.000000

What do you think ?
(0030875)
UbitUmarov (administrator)
2016-07-06 00:54

they are correct, as we talked in irc and my notes above
(0030876)
djphil (reporter)
2016-07-06 01:08

Thank you for your explanation, i took notes!

- Issue History
Date Modified Username Field Change
2014-06-06 02:35 djphil New Issue
2014-07-26 04:36 djphil Note Added: 0026599
2016-01-28 04:31 djphil Note Added: 0030032
2016-05-22 07:59 djphil Note Added: 0030363
2016-06-26 06:49 UbitUmarov Note Added: 0030789
2016-06-26 14:26 UbitUmarov Note Added: 0030792
2016-07-05 21:30 djphil Note Added: 0030873
2016-07-06 00:54 UbitUmarov Note Added: 0030875
2016-07-06 01:08 djphil Status new => resolved
2016-07-06 01:08 djphil Resolution open => fixed
2016-07-06 01:08 djphil Assigned To => djphil
2016-07-06 01:08 djphil Note Added: 0030876
2016-07-06 01:08 djphil Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker