Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007207opensim[REGION] Specific OpenSim Modulepublic2014-06-04 07:262014-07-29 13:43
ReporterAliciaRaven 
Assigned Tonebadon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOperating SystemWindows & LinuxOperating System Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007207: [PATCH] Fix for AutoBackupModule
DescriptionThe AutoBackup module is broken. It fails silently because when the timer goes off to do the backups, it reads from a list that is never assigned to, so does nothing. Also it uses the flag 'Scene.RegionReady' which as far as i can tell is also not assigned to and always returns region down. Another problem after fixing those is that it was calling the archiver module and passing null in the options field causing an exception.

As well as the fixes above to get the module working again, I included an extra option to skip saving assets. If the assets database is backed up separately this would be preferable because it means that AutoBackup doesn't take much resources during a backup cycle.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentUnknown
Mono Version2.10
Viewer
Attached Filespatch file icon 0001-Fix-AutoBackupModule-and-include-option-to-skip-savi.patch [^] (5,772 bytes) 2014-06-04 07:26 [Show Content]

- Relationships

-  Notes
(0026236)
nebadon (administrator)
2014-06-04 19:15

patch applied in master branch

http://opensimulator.org/viewgit/?a=commit&p=opensim&h=c1bdd22274511d255faf670fb001bc604c8a986f [^]

- Issue History
Date Modified Username Field Change
2014-06-04 07:26 AliciaRaven New Issue
2014-06-04 07:26 AliciaRaven File Added: 0001-Fix-AutoBackupModule-and-include-option-to-skip-savi.patch
2014-06-04 07:26 AliciaRaven Status new => patch included
2014-06-04 19:15 nebadon Note Added: 0026236
2014-06-04 19:15 nebadon Status patch included => resolved
2014-06-04 19:15 nebadon Resolution open => fixed
2014-06-04 19:15 nebadon Assigned To => nebadon
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker