Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007204opensim[REGION] Physics Enginespublic2014-06-02 12:582014-07-29 13:43
Reporterkenvc 
Assigned ToRobert Adams 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual Quad Core Xeon 32gbOSWindowsOS VersionSever 2012 64
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007204: Bulletsim VarRegion recently started crashing on sim startup - Red errors: Exception: System.NullReferenceException
DescriptionBulletsim: Just started last few days - Crash on sim startup - Exception: System.NullReferenceException.

Nothing has changed on this instance other than staying updated to latest dev master as always every day or so. This seemed to start sometime within the last few days. The only change to opensim.ini during this time was to add the new setting [Terrain]SendTerrainUpdatesByViewDistance=true
Additional Information3 logs are attached. Two are from a clean start where the instance crashed on startup. The other log is from a clean start where the same error happened but the instance did not crash. Not sure why it crashes sometimes and not others.

2014-06-02 23:30:53,981 ERROR - OpenSim.Region.Physics.BulletSPlugin.BSScene [BULLETS SCENE]: ProcessPostTaintTaints: BSLinksetCompound.ScheduleRebuild-1216177134: Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at OpenSim.Region.Physics.BulletSPlugin.BSAPIUnman.AddChildShapeToCompoundShape(BulletShape shape, BulletShape addShape, Vector3 pos, Quaternion rot) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSAPIUnman.cs:line 350
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<>c__DisplayClass3.<RecomputeLinksetCompound>b__2(BSPrimLinkable cPrim) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 379
   at OpenSim.Region.Physics.BulletSPlugin.BSLinkset.ForEachMember(ForEachMemberAction action) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinkset.cs:line 205
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.RecomputeLinksetCompound() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 358
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<ScheduleRebuild>b__0() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 114
   at OpenSim.Region.Physics.BulletSPlugin.BSScene.ProcessPostTaintTaints() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSScene.cs:line 1040
TagsNo tags attached.
Git Revision or version numberr/24825
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerFS, sing, Replex
Attached Fileslog file icon OpenSim-Crash.log [^] (40,826 bytes) 2014-06-02 12:58
log file icon OpenSim-NoCrash.log [^] (44,097 bytes) 2014-06-02 12:58
log file icon OpenSim-AnotherCrash.log [^] (41,278 bytes) 2014-06-02 20:37

- Relationships
related to 0007191closedRobert Adams [BULLETSIM] exception with linkset on startup 

-  Notes
(0026232)
kenvc (reporter)
2014-06-02 20:46

One other bit of info on this. Not sure if this is coincidence or important info, but this particular var appears to be crashing on first startup after updating the sim software.

Restarting after the crash still gets the same red error messages in the log file, but it usually doesn't crash on the 2nd start.
(0026233)
Robert Adams (administrator)
2014-06-02 21:04

This does look like another instance of the rebuilding of linksets failing because of mesh/sculptie assets being loaded. It is a timing thing so assets being in the cache would be different than cases where assets were still in the database.
(0026235)
kenvc (reporter)
2014-06-04 12:00

Not sure what it is, but I see this red spew on every startup now. Sometimes it crashes and sometimes it doesn't. Not sure if its related, but boats on this var now have a very bad rubberband effect when moving and are almost useless:

2014-06-04 13:54:22,094 ERROR - OpenSim.Region.Physics.BulletSPlugin.BSScene [BULLETS SCENE]: ProcessPostTaintTaints: BSLinksetCompound.ScheduleRebuild-1515101655: Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at OpenSim.Region.Physics.BulletSPlugin.BSAPIUnman.AddChildShapeToCompoundShape(BulletShape shape, BulletShape addShape, Vector3 pos, Quaternion rot) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSAPIUnman.cs:line 350
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<>c__DisplayClass3.<RecomputeLinksetCompound>b__2(BSPrimLinkable cPrim) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 379
   at OpenSim.Region.Physics.BulletSPlugin.BSLinkset.ForEachMember(ForEachMemberAction action) in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinkset.cs:line 205
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.RecomputeLinksetCompound() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 358
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<ScheduleRebuild>b__0() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 114
   at OpenSim.Region.Physics.BulletSPlugin.BSScene.ProcessPostTaintTaints() in c:\Users\Administrator\Desktop\Opensim\Opensim Dev Master\OpenSim\Region\Physics\BulletSPlugin\BSScene.cs:line 1040
2014-06-04 13:54:22,874 DEBUG - OpenSim.Region.Physics.BulletSPlugin.BSScene [BULLETSIM SHAPE MESH] All mesh triangles degenerate. Prim=Object/c639a293-b1b8-4677-bd0c-39a5db40c1ed/pos=<272.9033, 267.2345, 54.81113>/rgn=BulletSim/Moorea Sailing
2014-06-04 13:54:22,874 WARN - OpenSim.Region.Physics.BulletSPlugin.BSScene [BULLETSIM SHAPE] Mesh asset would not mesh. prim=Object/c639a293-b1b8-4677-bd0c-39a5db40c1ed/pos=<272.9033, 267.2345, 54.81113>/rgn=BulletSim/Moorea Sailing, texture=00000000-0000-0000-0000-000000000000
(0026247)
Robert Adams (administrator)
2014-06-08 09:15

I checked in a fix for this exception by checking for the null pointer and rebuilding the linkset again the next simulation tick. When this happens, a warning message is output. There should only be one or two of these warning messages. If there are more, then please report that. I tried to prevent infinite rebuildings of the linkset but that should not be happening. If it is, there is a different problem.
(0026251)
kenvc (reporter)
2014-06-09 16:55

Robert, this fix does appear to have solved the problem. I am seeing one warning message, but do not know if it is the warning you are referring to. I reported it in mantis 7211 before I saw your note here. If that is the same warning you are referring to, then you can delete mantis 7211.
(0026256)
kenvc (reporter)
2014-06-11 20:04

Have not seen this issue happen since Robert's fix. It appears to be resolved.

- Issue History
Date Modified Username Field Change
2014-06-02 12:58 kenvc New Issue
2014-06-02 12:58 kenvc File Added: OpenSim-Crash.log
2014-06-02 12:58 kenvc File Added: OpenSim-NoCrash.log
2014-06-02 12:59 kenvc Summary Bulletsim VarRegion: Recently started crashing on sim startup - Exception: System.NullReferenceException => Bulletsim VarRegion recently started crashing on sim startup - Red errors: Exception: System.NullReferenceException
2014-06-02 20:37 kenvc File Added: OpenSim-AnotherCrash.log
2014-06-02 20:42 kenvc Description Updated View Revisions
2014-06-02 20:42 kenvc Additional Information Updated View Revisions
2014-06-02 20:46 kenvc Note Added: 0026232
2014-06-02 21:00 Robert Adams Assigned To => Robert Adams
2014-06-02 21:00 Robert Adams Status new => assigned
2014-06-02 21:04 Robert Adams Note Added: 0026233
2014-06-02 21:34 kenvc Additional Information Updated View Revisions
2014-06-04 12:00 kenvc Note Added: 0026235
2014-06-08 09:12 Robert Adams Relationship added related to 0007191
2014-06-08 09:15 Robert Adams Note Added: 0026247
2014-06-09 16:55 kenvc Note Added: 0026251
2014-06-11 20:04 kenvc Note Added: 0026256
2014-06-11 20:04 kenvc Status assigned => resolved
2014-06-11 20:04 kenvc Fixed in Version => 0.8-rc3
2014-06-11 20:04 kenvc Resolution open => fixed
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker