Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007198opensim[REGION] OpenSim Corepublic2014-05-31 11:112014-05-31 11:11
Reportermewtwo0641 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007198: Sit camera rotation not correct when prim to be sat on is not rotated <0,0,0> or is not root
DescriptionSince commit 5015b0b; When sitting on a prim that has a sit camera script in it and that prim isn't rotated <0,0,0> (when not root) or isn't the root prim (rotation of the prim doesn't seem to matter in that case), the camera will not look at the intended point.
Steps To ReproduceLoad the attached camtest2.iar and there should be a folder named "Camera Test 2" with tests objects in it named "Camera Test 2 (Red Z 180 Green Z 0)" and "Camera Test 2 (Red Z 180 Green Z 270)"

These are red/green prims that have a small sit camera script in the red prims with the green prims set as root by default.

In one of the test objects the green prim is rotated <0,0,0> and the red one rotated <0,0,180>. The other test object is to test the effects on the camera when the root prim isn't rotated at <0,0,0>. It has the green prim rotated <0,0,270> (just an arbitrary rotation I picked out) and the red one still at <0,0,180>.

------------------------------------------------------------

1. Rez "Camera Test 2 (Red Z 180 Green Z 0)" making sure green is root and sit on the red prim. Expected result is to see the green prim (somewhat) center on the screen and directly ahead. Actual result is the camera is somewhere inside the red prim.

2. Unlink and relink the object with red as root and sit back on the red prim. The camera should now be in the expected position.

3. Repeat steps 1 and 2 with "Camera Test 2 (Red Z 180 Green Z 270)" to test a situation when neither prim is rotated <0,0,0> and similar results should be seen with the minor variation that in step 1 the camera will sort of look at the corner of the red prim instead of directly at the green prim.
Additional InformationI ran Steps to Reproduce on SL and results were as expected; green prim front and center (I got the original sit camera values from an identically constructed test object on SL and did the testing there first before testing on OS with the same values).

-------------------------------------------------------------------------

This has a previous relation to http://opensimulator.org/mantis/view.php?id=7176 [^] but I decided to open a new mantis because it seems to be a slightly different issue (seems to be a rotational instead of a positional issue now; but it is hard for me to tell).
TagsNo tags attached.
Git Revision or version numberMaster
Run Mode Standalone (Multiple Regions)
Physics EngineODE
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerAll
Attached Files? file icon camtest2.iar [^] (5,891 bytes) 2014-05-31 11:11

- Relationships
related to 0007176closedjustincc Sit camera not working correctly when prim the camera settings applied to is not root 

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2014-05-31 11:11 mewtwo0641 New Issue
2014-05-31 11:11 mewtwo0641 Relationship added related to 0007176
2014-05-31 11:11 mewtwo0641 File Added: camtest2.iar


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker