Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007193opensim[REGION] Script Functionspublic2014-05-27 13:502014-05-29 00:54
Reporterargus Portal 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0007193: llLoopSound breaks, when called more than one time
DescriptionWhen llLoopSound the first time is called, it works normal. But when you call it after then, the Sound stops.

In SecondLife this doesn't happens. There you can call llLoopSoudn as often as you want.

Workaround:

Call llStopSound before llLoopSound, then wait a moment.
Steps To Reproduce
Test that script and llLoopSound will stop after you clicked the object the 2nd time.

And it stays quiet as long as you didn't reset the script.

Workaround: comment in the two lines and the script behaves as expected and how it works on SecondLife:


default
{
    state_entry()
    {
        
    }
    
    touch_start(integer nr)
    {
       // llStopSound();
       // llSleep(0.2);
        llLoopSound("testsound",1.0);
    }
}
TagsNo tags attached.
Git Revision or version number9bae636ff0dc426e913e26c45b6936f16131f6d5
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
Script Engine
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships
related to 0007186new Looping Sounds Stops 

-  Notes
(0026197)
djphil (reporter)
2014-05-28 01:29

I confirm this bug and I would also like to mention another problem.
If you place the loopsound in state_entry it only works randomly. To work correctly you have to put stopsound at what is not normal.

default
{
    state_entry()
    {
        llStopSound(); // Not normal ...
        llLoopSound("testsound",1.0);
    }
}
(0026207)
argus Portal (reporter)
2014-05-28 08:36

I have to use the llSleep after llStopSound before i call llLoopSound. Otherwise llLoopSound will not work here.
(0026209)
Nicky Perian (reporter)
2014-05-28 21:26

Is this a regression of maturity defaulting to PG? As is explained
here: http://redmine.kokuaviewer.org/issues/1289#note-12 [^]
(0026210)
argus Portal (reporter)
2014-05-29 00:54

@Nicky: I switchted just now for testing a region from "PG" to "adult": Same behaviour.

Newest Firestorm and Singularity behaves equal.

- Issue History
Date Modified Username Field Change
2014-05-27 13:50 argus Portal New Issue
2014-05-28 01:29 djphil Note Added: 0026197
2014-05-28 02:13 danbanner Relationship added related to 0007186
2014-05-28 08:36 argus Portal Note Added: 0026207
2014-05-28 21:26 Nicky Perian Note Added: 0026209
2014-05-29 00:54 argus Portal Note Added: 0026210


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker