Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007190opensim[GRID] Other Servicepublic2014-05-25 05:052014-05-25 05:25
Reporterkimbletechnologies 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionopen 
Platformopensim .8-rc1OSUbuntuOS Version12.04 LTS
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007190: [MAP IMAGE CONNECTOR] error message no map graphics
DescriptionMap images not posting with messages that regions are not found. Error message from simulator repeats the following message for coordinates as if they were 256 X 256 squares (16 times) when there is only one varregion of 1024 X 1024.

Message from simulator log is:
2014-05-25 06:40:44,961 DEBUG - OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer [TEXTURED MAPTILE RENDERER] Fetched texture b8d3965a-ad78-bf43-699b-bff8eca6c975, found: True
2014-05-25 06:40:44,969 DEBUG - OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer [TEXTURED MAPTILE RENDERER] Fetched texture abb783e6-3e93-26c0-248a-247666855da3, found: True
2014-05-25 06:40:44,975 DEBUG - OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer [TEXTURED MAPTILE RENDERER] Fetched texture 179cdabd-398a-9b6b-1391-4dc333ba321f, found: True
2014-05-25 06:40:44,982 DEBUG - OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer [TEXTURED MAPTILE RENDERER] Fetched texture beb169c7-11ea-fff2-efe5-0f24dc881df2, found: True
2014-05-25 06:40:45,640 DEBUG - OpenSim.Region.CoreModules.World.LegacyMap.TexturedMapTileRenderer [TEXTURED MAP TILE RENDERER]: Generating Maptile Step 1: Done in 682 ms
2014-05-25 06:40:45,641 DEBUG - OpenSim.Region.CoreModules.World.LegacyMap.MapImageModule [MAPTILE]: Generating Maptile Step 2: Object Volume Profile
2014-05-25 06:40:45,642 DEBUG - OpenSim.Region.CoreModules.World.LegacyMap.MapImageModule [MAPTILE]: Generating Maptile Step 2: Done in 2 ms
2014-05-25 06:40:45,667 WARN - OpenSim.Services.Connectors.MapImageServicesConnector [MAP IMAGE CONNECTOR]: Map post to http://192.168.48.6:8003/map [^] failed: IP address of caller does not match IP address of registered region
2014-05-25 06:40:45,668 DEBUG - OpenSim.Services.Connectors.MapImageServicesConnector [MAP IMAGE CONNECTOR]: map tile uploaded in 17ms
2014-05-25 06:40:45,670 DEBUG - OpenSim.Region.CoreModules.ServiceConnectorsOut.MapImage.MapImageServiceModule [MAP IMAGE SERVICE MODULE] Unable to upload tile image for Hawaii A1 at 10014-9995: Map post to http://192.168.48.6:8003/map [^] failed: IP address of caller does not match IP address of registered region

CORRESPONDING MESSAGE FROM ROBUST LOG:
2014-05-25 06:40:21,976 DEBUG - OpenSim.Services.GridService.GridService [GRID SERVICE]: Region Hawaii A1 (5d756393-4473-4eb4-8e5f-08a10fe9a59c) registered successfully at 10014-9995 with flags RegionOnline
2014-05-25 06:40:38,178 DEBUG - OpenSim.Server.Handlers.MapImage.MapServerPostHandler [MAP ADD SERVER CONNECTOR]: Received map data for region at 10014-9995
2014-05-25 06:40:38,188 WARN - OpenSim.Server.Handlers.MapImage.MapServerPostHandler [MAP IMAGE HANDLER]: IP address 192.168.48.7 may be trying to impersonate region in IP 24.175.179.58
2014-05-25 06:40:38,198 DEBUG - OpenSim.Server.Handlers.MapImage.MapServerPostHandler [MAP ADD SERVER CONNECTOR]: Received map data for region at 10014-9996
2014-05-25 06:40:38,201 WARN - OpenSim.Server.Handlers.MapImage.MapServerPostHandler [MAP IMAGE HANDLER]: IP address 192.168.48.7 may be rogue. Region not found at coordinates 10014-9996
2014-05-25 06:40:38,209 DEBUG - OpenSim.Server.Handlers.MapImage.MapServerPostHandler [MAP ADD SERVER CONNECTOR]: Received map data for region at 10014-9997
2
Steps To ReproduceMapImageServer is set to the same url as all the other service i.e. MapImageServerURI=http://192.168.48.6:8003 [^] which is the local address of the robust instance
Additional Informationwhen I change the MapImageServerURI to the external ip the same message about the ip address being rogue is displayed only this time it gives my gateway address of 192.168.48.1
TagsNo tags attached.
Git Revision or version number.8-rc1
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
EnvironmentMono / Linux64
Mono Version2.10
ViewerSingularity
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2014-05-25 05:05 kimbletechnologies New Issue
2014-05-25 05:25 kimbletechnologies Additional Information Updated View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker