Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007165opensim[REGION] OpenSim Corepublic2014-05-13 04:242014-07-29 13:43
ReporterMata Hari 
Assigned Tojustincc 
PriorityurgentSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel i7 930 quad coreOSWindows .NETOS VersionWin7 x64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007165: Large number of errors thrown by [SynchronousRestObjectRequester] with r/24732
DescriptionThis morning I noticed a number of new git updates so I made a fresh clean build using r/24732 opensim-484aa72. On start-up a large number of maptile and script errors are thrown and on avi login a further large number of errors are also thrown and no textures appear on any of my worn mesh. Most messages seem to relate to the changes made to [SynchronousRestObjectRequester].

I re-downloaded the git, rebuilt it and repeated the test in case something odd happened the first time but the results were identical.

I've attached a log with shows the full startup sequence followed by me logging in and the out again.

I'll revert back to r/24717 opensim-a845c1a which I was using prior to this morning and showed no errors on startup or login.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFS 4.6.5 (40833) x64
Attached Fileslog file icon OpenSim.log [^] (137,855 bytes) 2014-05-13 04:24

- Relationships

-  Notes
(0026058)
Mata Hari (reporter)
2014-05-13 04:28

Just confirming that all errors disappeared again when I reverted to a845c1a.
(0026060)
orenh (administrator)
2014-05-13 04:52

Justin added timeouts to HTTP requests. I guess before, there were no timeouts.
(0026061)
Mata Hari (reporter)
2014-05-13 04:55

I guess the value of that timer needs to be bumped (quite a lot) then, at least during sim startup and avi login
(0026062)
danbanner (manager)
2014-05-13 04:59

ya same thing happening on our plazas: http://pastebin.com/Jrr7v1g3 [^] i guess i'll revert until it gets fixed.
(0026071)
smxy (reporter)
2014-05-13 12:24

I just updated to this and am seeing it also. Tons of red everywhere. :(
(0026072)
aiaustin (developer)
2014-05-13 13:52
edited on: 2014-05-13 13:59

Mata Hari's tests were on an OSGrid addon region.

Could it be that we are just really now seeing errors hidden before? The area that Justin is setting apparently unused timeouts is where code seems to be locking up on issue 7110.

http://opensimulator.org/mantis/view.php?id=7110#c25986 [^]

(0026073)
justincc (administrator)
2014-05-13 14:44
edited on: 2014-05-13 14:46

Okay, please try git master 4569c59.

In git master bbc1dc6 I inadvertently changed behaviour because I assumed the default timeout of HttpWebRequest was never when in fact it is 100 seconds, according to [1].

But this is puzzling since my code change should have resulted in requests never timing out rather than practically immediately. But in the interests of fixing the build, I have restored the previous behaviour of not attempting to set any timeout unless one is explicitly given, which no current code does apart from the URL version of offline IM.

Please test this change as soon as you can.

[1] http://msdn.microsoft.com/en-us/library/system.net.httpwebrequest.timeout%28v=vs.100%29.aspx [^]

(0026074)
Mata Hari (reporter)
2014-05-13 15:12

Same result with r/24733 opensim-4569c59....sea of red and the error messages are the same as the ones in the log from this morning.
(0026075)
Mata Hari (reporter)
2014-05-13 15:24
edited on: 2014-05-13 15:24

Instead of reverting again I built r/2723 opensim-bf8f64e instead and it started without error

(0026076)
justincc (administrator)
2014-05-13 15:36

Please tell me what happens if you build bf8f64e
(0026077)
justincc (administrator)
2014-05-13 15:44

Ok, I'm also going to need corroboration from other people with latest code, since everything is now back to how it was in bf8f64e (with the exception of offline IM which is not connected with these failures) so I don't see where it's going wrong. Needless to say, there have not been any problems on my Ubuntu 14.04, Mono 3.2.8 test system.
(0026078)
smxy (reporter)
2014-05-13 15:59

I built the latest code (4569c59 - r24733) and I'm still seeing lots of red.
(0026079)
justincc (administrator)
2014-05-13 16:00

Yeah, I think I just discovered the bug. Update shortly.
(0026080)
justincc (administrator)
2014-05-13 16:33
edited on: 2014-05-13 16:34

Okay, please try git master c23d37a. It turns that my use of the previously present but unused timeout value revealed an existing bug in AssetServicesConnector where it mistakenly passed in a 30 ms timeout. This was high enough not to trigger problems in my local tests. Hopefully, the problems are now resolved.

(0026081)
smxy (reporter)
2014-05-13 16:38

No red spew on start up this time. Thanks, Justin.
(0026082)
Mata Hari (reporter)
2014-05-13 16:39

r/24734 opensim-c23d37a starts without error and logins also without error. That appears to have fixed it
(0026083)
Mata Hari (reporter)
2014-05-13 16:42

marking resolved r/24734 opensim-c23d37a

- Issue History
Date Modified Username Field Change
2014-05-13 04:24 Mata Hari New Issue
2014-05-13 04:24 Mata Hari File Added: OpenSim.log
2014-05-13 04:28 Mata Hari Note Added: 0026058
2014-05-13 04:52 orenh Note Added: 0026060
2014-05-13 04:55 Mata Hari Note Added: 0026061
2014-05-13 04:59 danbanner Note Added: 0026062
2014-05-13 12:24 smxy Note Added: 0026071
2014-05-13 13:52 aiaustin Note Added: 0026072
2014-05-13 13:55 aiaustin Note Edited: 0026072 View Revisions
2014-05-13 13:59 aiaustin Note Edited: 0026072 View Revisions
2014-05-13 14:25 justincc Assigned To => justincc
2014-05-13 14:25 justincc Status new => assigned
2014-05-13 14:44 justincc Note Added: 0026073
2014-05-13 14:46 justincc Note Edited: 0026073 View Revisions
2014-05-13 14:46 justincc Note Edited: 0026073 View Revisions
2014-05-13 15:12 Mata Hari Note Added: 0026074
2014-05-13 15:24 Mata Hari Note Added: 0026075
2014-05-13 15:24 Mata Hari Note Edited: 0026075 View Revisions
2014-05-13 15:36 justincc Note Added: 0026076
2014-05-13 15:44 justincc Note Added: 0026077
2014-05-13 15:59 smxy Note Added: 0026078
2014-05-13 16:00 justincc Note Added: 0026079
2014-05-13 16:33 justincc Note Added: 0026080
2014-05-13 16:34 justincc Note Edited: 0026080 View Revisions
2014-05-13 16:38 smxy Note Added: 0026081
2014-05-13 16:39 Mata Hari Note Added: 0026082
2014-05-13 16:42 Mata Hari Note Added: 0026083
2014-05-13 16:42 Mata Hari Status assigned => resolved
2014-05-13 16:42 Mata Hari Fixed in Version => master (dev code)
2014-05-13 16:42 Mata Hari Resolution open => fixed
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker