Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007131opensim[REGION] OpenSim Corepublic2014-04-25 05:492014-04-25 14:34
Reporteraiaustin 
Assigned To 
PrioritynormalSeverityminorReproducibilityrandom
StatusnewResolutionopen 
PlatformPCOSWindowsOS Version8.1
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007131: Avatar names shows with @grid:port even on login to home grid
DescriptionI have begun seeing the grid name after the avatar name label when logging in to a home grid (seen on OSGrid and Openvue grid) rather than just when the avatar is on a foreign grid via the hypergrid. The @grid:port does not disappear even after a teleport between regions on the home grid.

I wonder if some of the recent changes to force the update of the avatar name on HG TP may be causing this?

I will try to spot the circumstances under which this occurs and whether I left the avatar logged in to the foreign grid before this happens on next home grid relog or not.
TagsNo tags attached.
Git Revision or version numberr/24655
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 4.6.1
Attached Files

- Relationships

-  Notes
(0025896)
orenh (administrator)
2014-04-25 06:42

AiAustin, the patch you're referring to deals with this problem, but it only does anything when you Hypergrid teleport, not during an initial login. During an initial login, your avatar name is probably cached from whatever the viewer had last seen. E.g., if you were last in a foreign grid, then the viewer may have cached your "foreign" name, and that's what you're seeing. Try clearing the viewer cache and logging-in again; does that fix your avatar name?
(0025897)
aiaustin (developer)
2014-04-25 06:52
edited on: 2014-04-25 06:55

You are right, the viewer cache clearing made the avatar name appear normal again. I wonder if this problem could be addressed by doing whatever you fixed on a HG teleport once on viewer login too to prevent this sort of thing?

Clearing the cache when we have several avatars and some with very large inventories is a bit of a pain.

(0025898)
orenh (administrator)
2014-04-25 07:01

The problem is that the trick that fixes the avatar name is visible to the user, because we have to change his group name to "(Loading)" for 5 seconds. It's undesirable to do this on every login, since most of the time it's not needed.
(0025901)
aiaustin (developer)
2014-04-25 14:34

Yes... understood... that would be annoying for the majority of cases.

- Issue History
Date Modified Username Field Change
2014-04-25 05:49 aiaustin New Issue
2014-04-25 06:42 orenh Note Added: 0025896
2014-04-25 06:52 aiaustin Note Added: 0025897
2014-04-25 06:55 aiaustin Note Edited: 0025897 View Revisions
2014-04-25 07:01 orenh Note Added: 0025898
2014-04-25 14:34 aiaustin Note Added: 0025901


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker