Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007128opensim[GRID] Hypergridpublic2014-04-23 09:102014-04-24 05:56
Reportersmxy 
Assigned Toorenh 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007128: Teleports to default region don't work.
DescriptionNone of my gates that do not specify a remote region - i.e., you land at the remote grid's default region - work any more. They only work if I specify an address. I get an instant popup in the viewer about the destination region not being found, and nothing logged in the region log or at its console.
Steps To ReproduceThe script I've provided shows the problem for my grid. The commented out destination used to work, now I must specify a region.

If I simply search for: craft-world.org:8002
in my viewer, it is found and I can TP to it. This seems to be an issue with the osTeleportAgent function.

Use your own agent's UUID, of course.
Additional Information
key     gAgentToTransfer    = "6d989e4b-53ed-4217-98a8-4626a6d5cbda";
//string  gDestination        = "http://craft-world.org:8002"; [^]
string  gDestination        = "http://craft-world.org:8002 [^] Hydra";
vector  gLandingPoint          = <128.0,128.0,25.0>;

default
{
    touch_start(integer numDetected)
    {
        osTeleportAgent( gAgentToTransfer, gDestination, gLandingPoint, <1,1,0> );
    }
}
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
EnvironmentMono / Linux64
Mono Version3.2
Viewer
Attached Files

- Relationships

-  Notes
(0025864)
smxy (reporter)
2014-04-23 09:40
edited on: 2014-04-23 12:15

This was known to be working on March 5th. I don't always update with every build I make, but based on the build dates, I was likely running 5038a59 (r/24394) then. I suspect it broke closer to now, however, as the problem was only first reported to me over the past weekend.

Update: I confirmed that I was indeed running that code on March 5th, according to my logs. Also, I successfully teleported to Craft that day.

(0025879)
orenh (administrator)
2014-04-23 22:23

Fixed in Git master 6efc203c
(0025881)
smxy (reporter)
2014-04-24 05:56

Works perfectly now. Thanks!

- Issue History
Date Modified Username Field Change
2014-04-23 09:10 smxy New Issue
2014-04-23 09:14 orenh Additional Information Updated View Revisions
2014-04-23 09:14 orenh Note Added: 0025862
2014-04-23 09:15 orenh Note Edited: 0025862 View Revisions
2014-04-23 09:15 orenh Note Edited: 0025862 View Revisions
2014-04-23 09:16 orenh Additional Information Updated View Revisions
2014-04-23 09:16 orenh Note Deleted: 0025862
2014-04-23 09:40 smxy Note Added: 0025864
2014-04-23 09:40 orenh Assigned To => orenh
2014-04-23 09:40 orenh Status new => assigned
2014-04-23 12:15 smxy Note Edited: 0025864 View Revisions
2014-04-23 22:23 orenh Note Added: 0025879
2014-04-23 22:23 orenh Status assigned => resolved
2014-04-23 22:23 orenh Resolution open => fixed
2014-04-24 05:56 smxy Note Added: 0025881
2014-04-24 05:56 smxy Status resolved => closed
2014-04-24 05:56 smxy Fixed in Version => master (dev code)


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker