Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007113opensim[REGION] Script Functionspublic2014-04-15 10:512015-02-21 11:31
ReporterDayna Bedrosian 
Assigned ToBlueWall 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows 2008OS Versionv2
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007113: llGiveInventory
DescriptionWe are having issues with delivering items to people in different Sims than the one sending it to them. For example an Update Server. The user has to log off and log in again to see the item in their inventory.
Steps To ReproduceUse. llGiveInventory to send an object to them on a different sim.
Additional InformationWe think it may be related to the issue# 0006867
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
Environment.NET / Windows32
Mono VersionOther
ViewerAll viewers
Attached Files

- Relationships

-  Notes
(0026039)
hack13 (reporter)
2014-05-11 22:20

I am unable to duplicate this issue, here are my system setup.

Grid Mode
Different simulators
Debian 7 x86_64
Mono 2.10.8
(0026056)
eumario (reporter)
2014-05-12 20:23

I can confirm, that this is not working, even tested on OSGrid, and confirmed that the item is sent to the user, but the user does not get a Blue Box Confirmation of the item being sent to them, and it doesn't show in their inventory till they have re-logged.
(0026094)
justincc (administrator)
2014-05-14 10:58

I can also not replicate this on current development code, either when the avatars are on different simulators or different regions on the same simulator. In both cases, the recipient sees the "blue box" accept/discard notification and it shows in their inventory on accept. The item given is an ordinary inventory object.

Will need a much more precise description of the steps you are performing, where the avatars are situated, what object is being given, etc, what appears in the debug level log of both systems, etc.
(0026156)
chrisx8416 (reporter)
2014-05-21 19:46

a friend and i been testing this on a 080rc grid and it does not deliver to avatars on another sim. both llGiveInventoryList and llGiveInventory do not work cross sims. However they do still work if the avatar is on the same sim as the prim running the script with those two functions in it.
(0026163)
usagabe (reporter)
2014-05-22 07:02

This is now happening to us as well using 080rc same issue as chrisx and also eumario
(0027076)
eumario (reporter)
2014-12-06 17:07

Just to note for all aspects of this. The issue isn't the fact that the Item is never delivered to the User. The item is in fact being delivered by the LSL_Api in the case of this:

-----[begin]-----
ScenePresence presence = World.GetScenePresence(destId);

if (presence == null)
{
  UserAccount account =
          World.UserAccountService.GetUserAccount(
          World.RegionInfo.ScopeID,
          destId);

-----[ end ]-----

In the case of this aspect, what occurs, is not a normal llInstantMessage() that llGiveInventory() executes. Instead, is resorts to manually placing the Item directly in the Database / Inventory Server, without ever actually executing a Inventory Refresh, and update packet to the User's Client. So the User never get's the Update message about the new Inventory item, and never get's an update to their Inventory Cache handle.

The only way that the Inventory get's updated, is when the User logs out of the grid, then logs back in, and the Inventory Cache is re-created/updated, to reflect that the item had indeed been placed in the user's inventory.

That is the specific problem that is occurring. Not that the item is never placed in the user's inventory, just that no updating from the server to the client to refresh their Inventory Cache to reflect the update.
(0027077)
chrisx8416 (reporter)
2014-12-06 17:25

at the time of my last post it was not being delivered, even after a relog the item did not show up but after the release of 0.8 the item(s) are delivered but the receiving user does not see the item(s) in their inventory until after they relog. I wrote in my vendor scripts a llInstantMessage to the receiver that they may need to relog to see the item in their inventory. A slight inconvenience but at least its some what working cross sim now.
(0027580)
BlueWall (administrator)
2015-02-21 11:31

Fixed in r023fd71ce508

- Issue History
Date Modified Username Field Change
2014-04-15 10:51 Dayna Bedrosian New Issue
2014-05-11 22:20 hack13 Note Added: 0026039
2014-05-12 20:23 eumario Note Added: 0026056
2014-05-14 10:58 justincc Note Added: 0026094
2014-05-14 10:58 justincc Assigned To => justincc
2014-05-14 10:58 justincc Status new => feedback
2014-05-21 19:46 chrisx8416 Note Added: 0026156
2014-05-22 07:02 usagabe Note Added: 0026163
2014-12-06 17:07 eumario Note Added: 0027076
2014-12-06 17:25 chrisx8416 Note Added: 0027077
2015-02-21 11:31 BlueWall Mono Version None => Other
2015-02-21 11:31 BlueWall Note Added: 0027580
2015-02-21 11:31 BlueWall Status feedback => resolved
2015-02-21 11:31 BlueWall Fixed in Version => master (dev code)
2015-02-21 11:31 BlueWall Resolution open => fixed
2015-02-21 11:31 BlueWall Assigned To justincc => BlueWall
2015-02-21 11:31 BlueWall Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker