Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007106opensim[REGION] OpenSim Corepublic2014-04-10 05:132015-04-08 11:37
ReporterRichardus Raymaker 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionreopened 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007106: Avatar feets follow terrain instead of the object its walking on.
DescriptionThe avatar feet always follow the underlying terrain when using BulletSim even if it is far below the position of the avatar. In case you stand on flat prim with rough terrain under it, the feet still follow the terrain, so feet are bent at wrong angle instead of using the visible prim or mesh as surface.
TagsNo tags attached.
Git Revision or version numberr/25776
Run Mode Grid (1 Region per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerSingularity 1.8.5
Attached Filesjpg file icon OSGrid-24592-Wonky-Ankles.jpg [^] (60,384 bytes) 2014-04-10 06:15


jpg file icon OSGrid-24592-Wonky-Ankles-on-Steps-over-Steep-Slope.jpg [^] (78,466 bytes) 2014-04-10 06:19


jpg file icon 2015-01-09-Wonky-Feet.jpg [^] (47,673 bytes) 2015-01-09 07:34


jpg file icon 2015-02-03-r25776-Wonky-Feet.jpg [^] (108,766 bytes) 2015-02-03 05:52

- Relationships
related to 0007105new Avatar Capsule Issue - Ankles bent upwards or sideways 
related to 0007067assignedRobert Adams Avatars highly distanced from the ground 

-  Notes
(0025738)
aiaustin (developer)
2014-04-10 06:14
edited on: 2014-04-10 06:19

I can confirm this. I had seen the "wonky ankles" problem with ankles bent up and sideways recently and thought it was related to the new capsule shape and hover adjustments made by Robert Adams for BulletSim. But I now can see the angle of the ankles may be a separate issue and can confirm that the angle of the ankles follows the underlying terrain even if its 2 or 3m below the prim surface. See image "OSGrid-24592-Wonky-Ankles.jpg" and an extreme version going up steps over a steep slope with ankles bent up at 80deg angle in image "OSGrid-24592-Wonky-Ankles-on-Steps-over-Steep-Slope.jpg".

(0025739)
aiaustin (developer)
2014-04-10 06:25
edited on: 2014-04-10 06:26

As a test I altered the avatar hover height to be MUCH too high and hence the feet were will above the surfaces... and the feet are still wonky (aligned with the underlying terrain) when avatar is at rest. So it seems not to relate to the avatar being set so it is sunk into the prim.

Firestorm 4.6.1 used for all my tests and BulletSim is enabled on my OSGrid regions used for these tests.

(0025740)
Robert Adams (administrator)
2014-04-10 06:26

I'm pretty sure the ankle turning feature is being done by the viewer. Does SL also twist ankles to the terrain and not prims?
(0025741)
Robert Adams (administrator)
2014-04-10 06:47

In SL, the ankle turning only happens when the avatar is standing on the terrain. In OpenSim, the ankle turning is relative to the underlying terrain no matter how far the avatar is above the ground -- I built platforms at various heights above steep terrain and, up to a few hundred feet, the avatar standing on the platform had twisted ankles relative to the terrain.

OpenSim must be sending something different to the viewer than SL is. We need to get a viewer expert in here.
(0025742)
melanie (administrator)
2014-04-10 06:55

OpenSim is simply NOT sending something - the surface normals for the capsule contact point. These need to be found by physics and sent.
I'm not sure if this was fixed in ODE.
(0025743)
Robert Adams (administrator)
2014-04-10 07:15

It seems that BulletSim is sending the collision normal for the terrain no matter what the avatar is colliding with. Will have to find where that is being done.
(0025782)
aiaustin (developer)
2014-04-14 12:25

Avatar AO must be off to observe this bug... as AO often locks ankles in correct position.
(0027078)
Luisillo_Contepomi (reporter)
2014-12-08 09:43

This bug continue present in 0.8.0.3.
(0027194)
aiaustin (developer)
2015-01-09 07:31
edited on: 2015-01-09 07:32

This is still there in 0.8.1 dev master as at r/25684 on 9-Jan-2015. Note the attached image 2015-01-09-Wonky-Feet.jpg for an extreme example. the ground here is mesh and its properly acting as the base physically in the sim. but when I looked why the feet were so angled - almost 90 degrees - I found the actual terrain was 50m lower and a very steep edge. So foot angle follows terrain however far below it is rather than respecting the angle of the prim or mesh the avatar is actually expected to be standing on.

(0027458)
Richardus Raymaker (reporter)
2015-02-03 05:35

Fixed in openensim version 0.8.1rc1
(0027460)
aiaustin (developer)
2015-02-03 05:48
edited on: 2015-02-03 05:51

No its not Richardus... nor in the latest dev master.

Make sure you don't have an AO on which can lock your ankles.

Current dev versions and 0.8.1rc1 give this same result as shown on 9th January 2015 on a further test today

See attached file 2015-02-03-r25776-Wonky-Feet.jpg

(0027461)
Richardus Raymaker (reporter)
2015-02-03 06:03
edited on: 2015-02-03 06:42

I tried it again with viewer AO disabled. and it works perfect. i dont see any problem with bending feets. Only problem is that my avatar sometimes hovering in the air. That the Z-offset problem SL have to.

Maby it depends on avatar size.

(0027462)
aiaustin (developer)
2015-02-03 06:28

Interesting... as even with the latest Bullet .dll libraries in place (I am testing on pretty recent r/25776 on Windows 8.1 64 bit for the server and Firetorm 4.6.8 64 bit on Windows 64 bit fior the bviewer) it is still wonky on the test area I use to check this. The terrain is about 50m lower than the mesh surface I am on.

I thought it might be working for prims below the avatar position and not mesh, but I just tested that too, and even a prim I am stood directly on I have wonky feet for the avatar even though the underlying steep terrain is 20m lower than the visible prim I am stood on.

What is the environment for server and viewer you are using that it appears to work on and confirm you have BulletSim active please.
(0027463)
Richardus Raymaker (reporter)
2015-02-03 06:41

I removed the picture, because i made a hugh user error. Maby need to start drink cofee in my life. lol The last test where on old region thats running 0.8.0.x :O
On the 0.8.1rc1 it seems to work fine.

I use a 3x3 var region, windows 8.1 server.
opensim.ini: physics = BulletSim

Using singularity 1.8.6 32bit.
Not using 64bit viewers because missing suport for functions.

You can try it on my Astro region in metropolis.
(0027925)
Luisillo_Contepomi (reporter)
2015-03-21 12:06

OpenSim 0.8.1.0 Release the problem is on a prim but not when avatar is over terrain.
(0027928)
lmmz (reporter)
2015-03-21 14:31
edited on: 2015-03-21 14:39

Still an issue on Wright Plaza, running 0.8.2.0 Dev 5b31bb9: 2015-03-16 23:48:16 +0000. Viewer is Singularity Alpha (64 bit) 1.8.6(6337). The issue happens with or without AO, on prim feet or system feet. I have a pic, showing prim, ground underneath, and feet following underlying terrain instead of prim. But, Mantis wont let me attach the image. This may be a viewer issue, or the sim may be sending incorrect information to the viewer. Either way, the issue still seems to occur. My avatar's leg length is 59. I tried lengthening my legs to 100. The issue still occurs. I also tried changing my Z height modifier from 0.2 to 0.0. The issue still occurs.

(0027931)
aiaustin (developer)
2015-03-22 03:28
edited on: 2015-03-23 11:13

This is definitely still an outstanding issue and not resolved.

On a re-test on latest GIT master on one area with real terrain that has a steep slope and that is 20m under a mesh terrain the feet are still at an extreme angle... exactly as shown in previous image 2015-01-09-Wonky-Feet.jpg

Using an AO of course straightens up the feet.

(0027989)
lmmz (reporter)
2015-04-08 11:35

Still an issue.

- Issue History
Date Modified Username Field Change
2014-04-10 05:13 Richardus Raymaker New Issue
2014-04-10 05:13 Richardus Raymaker Summary Avatars feets follow terrain instead of the object its walking on. => Avatar feets follow terrain instead of the object its walking on.
2014-04-10 06:03 Mata Hari Relationship added related to 0007105
2014-04-10 06:04 Mata Hari Relationship added related to 0007067
2014-04-10 06:14 aiaustin Note Added: 0025738
2014-04-10 06:15 aiaustin File Added: OSGrid-24592-Wonky-Ankles.jpg
2014-04-10 06:19 aiaustin Note Edited: 0025738 View Revisions
2014-04-10 06:19 aiaustin Note Edited: 0025738 View Revisions
2014-04-10 06:19 aiaustin File Added: OSGrid-24592-Wonky-Ankles-on-Steps-over-Steep-Slope.jpg
2014-04-10 06:25 aiaustin Note Added: 0025739
2014-04-10 06:26 Robert Adams Note Added: 0025740
2014-04-10 06:26 aiaustin Note Edited: 0025739 View Revisions
2014-04-10 06:47 Robert Adams Note Added: 0025741
2014-04-10 06:55 melanie Note Added: 0025742
2014-04-10 07:15 Robert Adams Note Added: 0025743
2014-04-14 12:25 aiaustin Note Added: 0025782
2014-12-08 09:43 Luisillo_Contepomi Note Added: 0027078
2015-01-09 07:31 aiaustin Note Added: 0027194
2015-01-09 07:32 aiaustin Note Edited: 0027194 View Revisions
2015-01-09 07:34 aiaustin File Added: 2015-01-09-Wonky-Feet.jpg
2015-02-03 05:35 Richardus Raymaker Note Added: 0027458
2015-02-03 05:35 Richardus Raymaker Status new => resolved
2015-02-03 05:35 Richardus Raymaker Fixed in Version => 0.8.1-rc2
2015-02-03 05:35 Richardus Raymaker Resolution open => fixed
2015-02-03 05:35 Richardus Raymaker Assigned To => Richardus Raymaker
2015-02-03 05:48 aiaustin Assigned To Richardus Raymaker =>
2015-02-03 05:48 aiaustin Note Added: 0027460
2015-02-03 05:48 aiaustin Status resolved => feedback
2015-02-03 05:48 aiaustin Resolution fixed => reopened
2015-02-03 05:51 aiaustin Note Edited: 0027460 View Revisions
2015-02-03 05:52 aiaustin File Added: 2015-02-03-r25776-Wonky-Feet.jpg
2015-02-03 05:55 aiaustin Git Revision or version number aec723b => r/25776
2015-02-03 05:55 aiaustin Viewer Singularity 1.8.5 (5617) => Singularity 1.8.5/Firesto
2015-02-03 05:55 aiaustin Fixed in Version 0.8.1-rc2 =>
2015-02-03 05:55 aiaustin Description Updated View Revisions
2015-02-03 05:58 aiaustin Viewer Singularity 1.8.5/Firesto => Singularity 1.8.5
2015-02-03 05:58 aiaustin Description Updated View Revisions
2015-02-03 06:03 Richardus Raymaker Note Added: 0027461
2015-02-03 06:03 Richardus Raymaker Status feedback => new
2015-02-03 06:07 Richardus Raymaker Note Edited: 0027461 View Revisions
2015-02-03 06:09 Richardus Raymaker Note Edited: 0027461 View Revisions
2015-02-03 06:28 aiaustin Note Added: 0027462
2015-02-03 06:37 Richardus Raymaker Note Edited: 0027461 View Revisions
2015-02-03 06:41 Richardus Raymaker Note Added: 0027463
2015-02-03 06:42 Richardus Raymaker Note Edited: 0027461 View Revisions
2015-03-21 12:06 Luisillo_Contepomi Note Added: 0027925
2015-03-21 14:31 lmmz Note Added: 0027928
2015-03-21 14:32 lmmz Note Edited: 0027928 View Revisions
2015-03-21 14:34 lmmz Note Edited: 0027928 View Revisions
2015-03-21 14:37 lmmz Note Edited: 0027928 View Revisions
2015-03-21 14:39 lmmz Note Edited: 0027928 View Revisions
2015-03-22 03:28 aiaustin Note Added: 0027931
2015-03-23 11:13 aiaustin Note Edited: 0027931 View Revisions
2015-04-08 11:35 lmmz Note Added: 0027989


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker