Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007086opensim[REGION] Specific OpenSim Modulepublic2014-04-01 17:462014-07-29 13:43
Reporterjustincc 
Assigned Tocmickeyb 
PrioritylowSeveritytextReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target Versionmaster (dev code)Fixed in Version 
Summary0007086: Unused code at the bottom of SunModule.SetSunParameter(string param, double value)
DescriptionFrom line 566

                // Generate shared values
                GenSunPos();

                // When sun settings are updated, we should update all clients with new settings.
                SunUpdateToAllClients();

are unused since they appear after an exception is thrown in the default clause of the switch. Where are they meant to be, if at all?
TagsNo tags attached.
Git Revision or version number7bafee28fa731fe09d54fb0f90dda4d33f530a1f
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBasicPhysics
EnvironmentMono / Linux32
Mono Version2.10
Viewer
Attached Files

- Relationships

-  Notes
(0025656)
cmickeyb (administrator)
2014-04-01 19:40

Should be moved outside the switch. Once the parameters are set, the results need to be sent to the client.
(0025657)
cmickeyb (administrator)
2014-04-01 19:53

Fix committed in #ac16a667e16bcdbc6d7e71774320a46680ee90b4
(0025658)
cmickeyb (administrator)
2014-04-01 19:53

ac16a667e16bcdbc6d7e71774320a46680ee90b4

- Issue History
Date Modified Username Field Change
2014-04-01 17:46 justincc New Issue
2014-04-01 17:46 justincc Status new => assigned
2014-04-01 17:46 justincc Assigned To => cmickeyb
2014-04-01 19:40 cmickeyb Note Added: 0025656
2014-04-01 19:53 cmickeyb Note Added: 0025657
2014-04-01 19:53 cmickeyb Note Added: 0025658
2014-04-01 19:53 cmickeyb Status assigned => resolved
2014-04-01 19:53 cmickeyb Resolution open => fixed
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker