Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007082opensim[REGION] OpenSim Corepublic2014-03-29 03:462014-03-29 13:03
Reporteraiaustin 
Assigned To 
PrioritynormalSeverityminorReproducibilityalways
StatusnewResolutionreopened 
PlatformPCOSWindowsOS Version8.1
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0007082: GroupsMessagingModule V2 requires MessageOnlineUsersOnly = true
DescriptionUsing r/24531 (for example) and using Groups V2 (as I have been for a while) I am seeing a new red ERROR message on the OpenSim.ini.exe console and error log which reports:

2014-03-29 10:21:35,874 ERROR - OpenSim.Groups.GroupsMessagingModule
[Groups.Messaging]: GroupsMessagingModule V2 requires MessageOnlineUsersOnly = true

However, I have this set to the defaults in my OpenSim.ini which is commented out and implies that groups V2 always has the option set to "on". It seems it must now be manually set to "true" to avoid the error.

Steps To ReproduceHere is the extract from OpenSim.ini.example...

    ;# {MessageOnlineUsersOnly} {Module:GroupsModule Module} {Message online users only?} {true false} false
    ; Experimental option to only message online users rather than all users
    ; Should make large groups with few online members messaging faster, as the expense of more calls to presence service
    ; Applies Flotsam Group only. V2 has this always on, no other option
    ; MessageOnlineUsersOnly = false
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships

-  Notes
(0025635)
orenh (administrator)
2014-03-29 04:41

The default for MessageOnlineUsersOnly is indeed 'false':

In OpenSimDefaults.ini:

 MessageOnlineUsersOnly = false

In OpenSim.ini.example:

 ; MessageOnlineUsersOnly = false

So you do need to change it to 'true' explicitly in order to make it work.
(0025636)
aiaustin (developer)
2014-03-29 05:43
edited on: 2014-03-29 05:53

I think this is a change of behaviour though Oren, as previously when using Groups V2 this red error did not show (as far as I am aware anyway). And we have other settings for modules which enforce necessary values without explicit user settings in their own .ini files.

It does seem that groups V2 ought (eventually) to allow the same group message IM capability as Flotsam Groups as part of the inbuilt behaviour... so we may not want people to set values in their OpenSim.ini that are there for purely technical current implementation restrictions?

And now that groups V2 is the default if groups are enabled, the default for this MessageOnlineUsersOnly option now ought to be consistent and set to true in OpenSimDefaults.ini and OpenSim.ini.example if its not auto enforced by the module.

But if it needs to be set then at least the comment in OpenSim.ini.example ought to be amended as it implies the system enforces the correct value here.

Could replace the entry in OpenSim.ini.example with this? Or some helpful comment to really explain what is happening?

    ;# {MessageOnlineUsersOnly} {Module:GroupsModule Module} {Message online users only?} {true false} true
     ; Experimental option to only message online users rather than all users
     ; Should make large groups with few online members messaging faster,
     ; at the expense of more calls to presence service
     ; Can be set to true or false for Flotsam Groups.
     ; Must be set to true for Groups v2
     ; MessageOnlineUsersOnly = true

(0025637)
orenh (administrator)
2014-03-29 06:45

The module, as currently written, doesn't support MessageOnlineUsersOnly=false. If that setting is in effect and you try to send a message to a group then it will cause a NullPointerException and the message won't be sent. (That's because GroupMessagingModule.m_usersOnlineCache will be null.) I was bit by this bug, and I added the warning so that it won't happen to me again. I added it to master OpenSim so that others won't be surprised by this behavior either. Without this warning, the module will *appear* to work when OpenSim is started, but if you actually try to send a group message then it will fail and won't be sent. It's better to be told up-front that your configuration is wrong then to have it fail later.

Certainly the module can be improved, but I didn't have the time or motivation to do so as when properly configured the module works fine. Until that happy day arrives, having this error message doesn't make the module work any less than it previously did; it just warns users when their configuration is such that the module isn't going to work.
(0025638)
melanie (administrator)
2014-03-29 07:01

The way we usually enforce this kind of restriction is to:
* ebort startup with a message
* issue a message at startup and disable the module
* silently assume the correct value

In this case, the module should, IMHO, silently assume the value "true", because, as was stated above, once the module is expanded to include that functionality, people would then have to go back and change the option to gain the feature.
(0025640)
orenh (administrator)
2014-03-29 08:45

The module now correctly detects an invalid configuration, issues a message, and disables itself. Previously it didn't work but didn't tell the user so.
(0025645)
aiaustin (developer)
2014-03-29 13:03
edited on: 2014-03-30 02:11

The issue is not yet fully resolved.

Remember the default groups module is groups v2 in 0.8.0 by default not flotsam. Yet the default for the experimental MessageOnlineUsersOnly sets that to =false ... which is (currently) not supported (but presumably will be one day) and hence its inconsistent and will immediately disable groups v2.

We need to set the default to MessageOnlineUsersOnly = true so its consistent with the groups module selected by default...

and I think Melanie is right to suggest the normal approach would be to silently set the correct value though its fine to issue a WARNING (not an error?) if its explicitly set to false... which would NOT be the default.

As discussed I am not assuming Oren is the person responsible.. but I hope whoever added the MessageOnlineUsersOnly capability can fix this, or Diva may look at the issue for Groups V2 to allow the MessageOnlineUsersOnly=false option (i.e. offline Group IMs are sent) option to work.


- Issue History
Date Modified Username Field Change
2014-03-29 03:46 aiaustin New Issue
2014-03-29 04:38 orenh Assigned To => orenh
2014-03-29 04:38 orenh Status new => assigned
2014-03-29 04:41 orenh Note Added: 0025635
2014-03-29 05:43 aiaustin Note Added: 0025636
2014-03-29 05:44 aiaustin Note Edited: 0025636 View Revisions
2014-03-29 05:47 aiaustin Note Edited: 0025636 View Revisions
2014-03-29 05:53 aiaustin Note Edited: 0025636 View Revisions
2014-03-29 06:45 orenh Note Added: 0025637
2014-03-29 07:01 melanie Note Added: 0025638
2014-03-29 08:45 orenh Note Added: 0025640
2014-03-29 08:45 orenh Status assigned => resolved
2014-03-29 08:45 orenh Resolution open => fixed
2014-03-29 11:45 orenh Assigned To orenh =>
2014-03-29 11:45 orenh Status resolved => feedback
2014-03-29 11:45 orenh Resolution fixed => reopened
2014-03-29 13:03 aiaustin Note Added: 0025645
2014-03-29 13:03 aiaustin Status feedback => new
2014-03-29 13:04 aiaustin Note Edited: 0025645 View Revisions
2014-03-29 13:07 aiaustin Note Edited: 0025645 View Revisions
2014-03-30 02:11 aiaustin Note Edited: 0025645 View Revisions


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker