Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007036opensim[REGION] OpenSim Corepublic2014-02-24 18:062014-07-29 13:43
Reporterjozee tungsten 
Assigned ToRobert Adams 
PriorityhighSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntuOS VersionRelease 10.04
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007036: Teleports between regions in a mega-region do not work
DescriptionWhen teleporting between sims in a mega-region the viewer throws the following message: "Cannot cross into non-existant region" and drops the avatar into a random location usually at the edge of one of the affected sims.
Steps To ReproduceRequest a teleport between sims in a mega-region.
Additional InformationA google of the unfortunate misspelling of "non-existant" revealed the following comment from Bluewall Commit 7fc289 "Properly restore position on crossing failure for mega-regions. Fix odd "cannot cross into banned parcel" viewer error message when crossing into non-existant region. Proper permission failure messages are now returned." which may or may not be germane to the issue.

Nothing is shown in the server log.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux32
Mono Version2.10
ViewerFirestorm 4.5.1 (38838)
Attached Files

- Relationships

-  Notes
(0025434)
jozee tungsten (reporter)
2014-03-12 10:12

I am blocked from further updates until this is fixed.
(0025436)
kenvc (reporter)
2014-03-12 10:49

I am having no issues teleporting around within my 6x6 mega. I used the map double click method and also used the map search method and both work exactly as expected for me. I am using the latest Dev Master on Windows Server 2012 64 bit and using the latest Singularity Alpha release.

I assume your mega is either square or a rectangle shaped and not irregular shaped?
(0025439)
jozee tungsten (reporter)
2014-03-13 09:04

My region is a 4x7 rectangle and works fine up to version osgrid-opensim-01242014.v0.8.0.966ab21. The fact that subsequent releases work in native mode on Windows leads me to conclude this may be a mono issue, or a mono version issue. Mono-2.10.8 is the most recent version certified to work on Ubuntu-12.0. I am, in fact, running Mono-3.2.3 while the latest mono is Mono-3.2.7.

I think a reasonable approach would be to identify the changes which broke the project and relate those to any outstanding mono issues.
(0025447)
NestorinMX (reporter)
2014-03-15 01:53

[es] Específicamente para el caso de "cannot cross into banned parcel", lo resolví desde la consola: change region (nombre de region con problemas)->restart->Enter.
[en] Specifically in the case of "can not cross into banned parcel", I solved it from the console: change region (problems region name)->restart->Enter.
(0025453)
jozee tungsten (reporter)
2014-03-16 11:20

The change region workaround does not work for me.

Further investigation reveals that the code was broken with commit 674a3a5 dated 2014-01-24. I downloaded and built the previous version (966ab21) on my Ubuntu machine and it works. I downloaded and built 674a3a5 (which is the subsequent commit) and it fails as discussed. I did a complete diff of the two versions and a partial rollback of EntityTransferModule.cs and related code which also works. My next step is to determine the failing piece of EntityTransferModule.cs.
(0025456)
NestorinMX (reporter)
2014-03-16 14:01

[es] Uno de los intentos que realicé con resultados aparentemente útiles, antes de lograr éxito los teleportes aplicando "restart", fue limpiando la base de datos. Es decir, las tablas deben conservarse, pero vacías. Por supuesto, esto implica iniciar de nuevo el Sim. Posiblemente te resulte.

[en]One of the attempts I made with seemingly useful results before applying succeed teleport "restart" was cleaning the database. That is, the tables should be retained, but empty. Of course, this means restart the Sim. Possibly you may be.
(0025459)
jozee tungsten (reporter)
2014-03-17 21:30

I emptied the tables and rebuilt the region as a 4x7 collection of pimple islands with identical results. EntityTransferModule is completely broken for mega regions and has been since commit 674a3a5.
The following is typical log output after attempting a tp within the mega region using the latest release (personal uuids removed):
21:02:03 - [ENTITY TRANSFER MODULE]: GetRegionContainingWorldLocation: possibleRegions cnt=0, range=4128
21:02:03 - [SCENE]: Region AF_31 authenticated and authorized incoming child agent (circuit code 1821880378)
21:02:03 - [EVENTQUEUE]: OnRegisterCaps: agentID caps OpenSim.Framework.Capabilities.Caps region AF_31
21:02:03 - [ENTITY TRANSFER MODULE]: GetRegionContainingWorldLocation: possibleRegions cnt=0, range=8256
21:02:03 - [ENTITY TRANSFER MODULE]: GetRegionContainingWorldLocation: Not found. Remembering loc=<2814463.95,2813183.95>
21:02:03 - [ENTITY TRANSFER MODULE]: GetDestination: region not found. Old region name=AF_41 at <10994,10989> of size <256,256>. Old pos=<-0.05, -0.05, 25.7823>
21:02:03 - [SCENE PRESENCE]: CheckForBorderCrossing: Crossing failed. Restoring old position.
21:02:04 - [SCENEGRAPH]: Error in AF_41: System.Exception: Region with id 1d3743bb-b0c7-401c-86c9-31684faca078 not found
  at OpenSim.Region.RegionCombinerModule.RegionCombinerModule.GetSizeOfMegaregion (UUID regionId) [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.ScenePresence.EnforceSanityOnPosition (Vector3 origPosition) [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.ScenePresence.CheckForBorderCrossing () [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.ScenePresence.Update () [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.SceneGraph.<UpdatePresences>m__12 (OpenSim.Region.Framework.Scenes.ScenePresence presence) [0x00000] in <filename unknown>:0
  at OpenSim.Region.Framework.Scenes.SceneGraph.ForEachScenePresence (System.Action`1 action) [0x00000] in <filename unknown>:0

I am attempting to rollback to the previous working GetDestination.
(0025460)
NestorinMX (reporter)
2014-03-17 21:42

josee tungsten. After clean the tables... Since you tried running the bin/Configure.exe file?
(0025463)
jozee tungsten (reporter)
2014-03-18 10:53

I updated to the latest configurations with exactly the same result as above. GetRegionContainingWorldLocation returns null which causes GetDestination to fail.
(0025464)
Robert Adams (administrator)
2014-03-18 11:02

I thought each of the individual regions in a mega-region registered themselves with the grid service but that must not be true. The varregions have to register the larger region into all the 256 region locations for them to work. There must be a special case for the mega-regions I didn't replace when varregions where added.

The teleportation logic now computes the world location of the out-of-region position and asks the grid service for the region that contains that location to find where to teleport/cross to. Mega-regions and varregions are both special cases built on top of the legacy, fixed-sized region assumptions in the services and protocols.

I will check into why mega-regions aren't working here.
(0025777)
jozee tungsten (reporter)
2014-04-13 16:46

Any progress?
(0025779)
Robert Adams (administrator)
2014-04-13 22:13

the problem does seem to be that the sub-regions of the mega-region are registered with the grid service but when they are found later (for the border crossing) the code in EntityTransferModule does not properly test for the destination being a sub-region of a mega-region. I will have to add some extra testing for mega-regions when transitioning between regions.
(0025780)
kenvc (reporter)
2014-04-13 22:49

Teleporting with a mega was working last time I checked this back about a month ago, but they are not working within a mega any longer. Teleporting using the map puts the AV frozen against the border of the far SW sim, and eventually you get logged out of the grid.
(0026351)
jozee tungsten (reporter)
2014-06-22 11:12

We have obviously decided to deprecate mega-regions. I have converted to a var. Nice touch communicating the intent by simply breaking the code and ignoring the mantis.
(0026352)
kenvc (reporter)
2014-06-22 11:15

This mantis is old news and most people have converted to vars by now. I don't know if it is fixed or not, but am closing it. If its not fixed and someone wants to report it again, they certainly can.

- Issue History
Date Modified Username Field Change
2014-02-24 18:06 jozee tungsten New Issue
2014-02-24 18:15 Robert Adams Assigned To => Robert Adams
2014-02-24 18:15 Robert Adams Status new => assigned
2014-03-12 10:11 jozee tungsten Priority normal => high
2014-03-12 10:12 jozee tungsten Note Added: 0025434
2014-03-12 10:49 kenvc Note Added: 0025436
2014-03-13 09:04 jozee tungsten Note Added: 0025439
2014-03-15 01:53 NestorinMX Note Added: 0025447
2014-03-16 11:20 jozee tungsten Note Added: 0025453
2014-03-16 14:01 NestorinMX Note Added: 0025456
2014-03-17 21:30 jozee tungsten Note Added: 0025459
2014-03-17 21:42 NestorinMX Note Added: 0025460
2014-03-18 10:53 jozee tungsten Note Added: 0025463
2014-03-18 11:02 Robert Adams Note Added: 0025464
2014-04-13 16:46 jozee tungsten Note Added: 0025777
2014-04-13 22:13 Robert Adams Note Added: 0025779
2014-04-13 22:49 kenvc Note Added: 0025780
2014-06-22 11:12 jozee tungsten Note Added: 0026351
2014-06-22 11:15 kenvc Note Added: 0026352
2014-06-22 11:15 kenvc Status assigned => resolved
2014-06-22 11:15 kenvc Fixed in Version => master (dev code)
2014-06-22 11:15 kenvc Resolution open => fixed
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker