Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007013opensim[REGION] Physics Enginespublic2014-02-18 10:572014-07-29 13:42
Reporterkenvc 
Assigned ToRobert Adams 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDual Xeon Quad core 32gbOSWindowsOS VersionServer 2012 64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0007013: Varregion with Bulletsim, wind appears to be blowing 200 mph
DescriptionI recently converted a 6x6 mega to a var using the same exact opensim.ini other than changing the one Combine region setting to false. Now the wind appears to be blowing 100-200 mph. The sound of the wind is MUCH louder than on the mega. Also the particle splash that is coming from a script in the rocks shoots all the way across the sim from south to north a fraction of a second after it emits. It is so fast its hard to even see it happen, but this seems to confirm the high wind theory from the loud wind noise.

I am not sure if this issue is with the var or Bulletsim, but other normal sims and megas running Bulletsim do not having this particular issue.
Steps To ReproduceThe var sim is Moorea Sailing. TP to the SW region. There is a large bright red cone there pointing to the rock with the splash script so you can see this happen. Also listen for the wind noise compared to what you hear on other normal sims.
TagsNo tags attached.
Git Revision or version numberr/24366
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFS or Sing
Attached Filespatch file icon 0001-varregion-Fix-to-crazy-wind-speed.patch [^] (4,855 bytes) 2014-02-21 10:59 [Show Content]

- Relationships

-  Notes
(0025224)
vegaslon (reporter)
2014-02-18 14:20

Since someone else has made a mantis of this before I got to it. I will state more information about this issue.

The wind in viewer goes only one direction and that is flowing north. Turning what used to be random wind that was in a 16 X 16 grid into a one direction high speed wind. When you turn the wind to 0 using the osSetWindParam, The veiwer still registers what would be state as a normal wind that goes in the northeast direction. Using the llWind function with a scripted object to rotate in direction of wind blowing will rotate as expected and show the random wind behavior in the 16 x 16 grid. Setting the wind to 0 will cause these prims to point to the north.

The script to show this behavior in viewer is simple particle mist script with the particles set to follow wind.

These same tests done on Aurora-Sim show the expected behavior on a varregion of the same size. Where the particles will move in a random stream as they hit the different wind zones and move at a normal wind speed of 1.
(0025260)
vegaslon (reporter)
2014-02-21 11:01
edited on: 2014-02-21 11:03

Did some digging on this issue and just ended up copying over these three functions from Aurora-Sim. I present a patch of them to be investigated. This fixes the problem.

(0025264)
kenvc (reporter)
2014-02-21 15:54

I can confirm that this patch works. Have not noticed any side effects and wind seems totally back to normal. Thanks Vegasion!
(0025281)
kenvc (reporter)
2014-02-23 10:52

This issue is now fixed in Dev Master r/24378

- Issue History
Date Modified Username Field Change
2014-02-18 10:57 kenvc New Issue
2014-02-18 10:59 kenvc Steps to Reproduce Updated View Revisions
2014-02-18 14:20 vegaslon Note Added: 0025224
2014-02-18 16:33 Robert Adams Assigned To => Robert Adams
2014-02-18 16:33 Robert Adams Status new => assigned
2014-02-21 10:59 vegaslon File Added: 0001-varregion-Fix-to-crazy-wind-speed.patch
2014-02-21 11:01 vegaslon Note Added: 0025260
2014-02-21 11:03 vegaslon Status assigned => patch included
2014-02-21 11:03 vegaslon Note Edited: 0025260 View Revisions
2014-02-21 15:54 kenvc Note Added: 0025264
2014-02-23 10:52 kenvc Note Added: 0025281
2014-02-23 10:52 kenvc Status patch included => resolved
2014-02-23 10:52 kenvc Fixed in Version => master (dev code)
2014-02-23 10:52 kenvc Resolution open => fixed
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker