Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006984opensim[REGION] OpenSim Corepublic2014-01-30 03:202014-02-24 12:01
Reporteraiaustin 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS Version8.1
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006984: [Map] RenderMeshes=true - Failed to decode mesh asset: Could not load file or assembly 'zlib.net,
DescriptionI get many instances of this error on a PC Windows 8.1 Pro 64 but system when I updated to r/24298 with the Varregion and map enhancement branch code merged into it when I enable

[Map]
     RenderMeshes = true;

11:31:18 - Failed to decode mesh asset: Could not load file or assembly 'zlib.net, Version=1.0.3.0, Culture=neutral, PublicKeyToken=47d7877cb3620160' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Could it be that some libraries need updating on some platforms to make the new map generation code work?

Steps To ReproduceEnable [Map] section RenderMeshes = true in OpenSim.ini on regions where meshes (and possibly sculpties) are present.

I have Warp3D rendering enabled.
TagsNo tags attached.
Git Revision or version numberr/24298
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerN/A
Attached Files

- Relationships
related to 0006990closedkenvc OpenSim.Region.Framework.Scenes.SceneGraph [SCENEGRAPH]: Problem processing action in ForEachSOG 

-  Notes
(0025082)
justincc (administrator)
2014-01-30 16:42

It looks like zlib.net.dll isn't used by OpenSimulator itself but rather by libomv. Interestingly, the zlib.net.dll in libomv is the same version but is signed whereas the one in OpenSimulator is not signed.

If you replace the OpenSimulator version with [1] does this make the problem go away?

[1] https://github.com/openmetaversefoundation/libopenmetaverse/blob/master/bin/zlib.net.dll [^]
(0025089)
aiaustin (developer)
2014-01-31 01:42
edited on: 2014-01-31 07:21

Yes, replacing zlib.net.dll in the latest master (using e.g. r/24317) and running with OpenSim.ini [Map] RenderMeshes = true now loads without the errors.

(0025091)
aiaustin (developer)
2014-01-31 07:16
edited on: 2014-01-31 07:21

Having said that... with [Map] RenderMeshes = true and after checking that the map tiles were regenerated using Warp3D rendering, some easily visible large meshes are not rendering any differently to previously and still look like large rectangular blocks or simple shapes.

(0025098)
justincc (administrator)
2014-01-31 15:38

Where did you find RenderMeshes = true? Looking through current source code I can't see any reference to such a setting.
(0025102)
aiaustin (developer)
2014-02-01 02:49
edited on: 2014-02-24 02:12

Its in [Map] section of OpenSimDefaults.ini - added by Robert Adams in the varregion branch on 2014-01-19 in a commit which improved map tile generation and it was recently merged into Master when the varregion branch was merged.

    ; Attempt to render meshes and sculpties on the map
    RenderMeshes = false

Its not in OpenSim.ini.example yet but I pointed out that missing entry at the time the commit appeared in the varregion branch.

It was commit "54a4b9" r/24228
http://opensimulator.org/viewgit/?a=commit&p=opensim&h=54a4b9eab4009711f574fe744e2dd82373c971c9 [^]

(0025104)
aiaustin (developer)
2014-02-01 08:12
edited on: 2014-02-01 08:18

I am noting here too a change in the Warp3D map tiles since the recent updates. Some simple "blank" texture prims with a diagonal greater than the set "TexturePrimSize" new OpenSimDefaults.ini parameter are showing as pure white.

I changed various things like making the colour darker, changing shininess and taking away nearby "lights" features and that makes no difference.

I think it is the case that the prim colour is not being applied for larger prims that have the blank texture (perhaps all textures) for objects whose diagonal is GREATER than TexturePrimSize. Blank (or texture) AND colour should be applied.

Smaller prims do seem to be coloured correctly. I altered the TexturePrimSize and showed this is the case as the colour comes back when the prim diagonal is LESS than TexturePrimSize.

I reported this separately as http://opensimulator.org/mantis/view.php?id=6989 [^]

(0025105)
aiaustin (developer)
2014-02-01 08:21

Of course if you can find no CODE that actually uses the "RenderMeshes" setting that would explain why mesh objects are not yet rendered as a decent shape and look as they always have done to date (crude blocks usually).
(0025292)
aiaustin (developer)
2014-02-24 02:14

The core issue here of problems with zlib.net.dll appears to have been fixed with the changes made by dahlia in commit r?24379 on 2014-02-23.
(0025293)
aiaustin (developer)
2014-02-24 02:15

Core issue of zlib.net.dll fixed in r/24379 on 2014-02-13

- Issue History
Date Modified Username Field Change
2014-01-30 03:20 aiaustin New Issue
2014-01-30 03:21 aiaustin Description Updated View Revisions
2014-01-30 03:21 aiaustin Description Updated View Revisions
2014-01-30 10:12 aiaustin Description Updated View Revisions
2014-01-30 10:13 aiaustin OS => Windows
2014-01-30 10:13 aiaustin OS Version => 8.1
2014-01-30 10:13 aiaustin Platform => PC
2014-01-30 16:42 justincc Note Added: 0025082
2014-01-30 16:42 justincc Status new => feedback
2014-01-31 01:42 aiaustin Note Added: 0025089
2014-01-31 01:42 aiaustin Status feedback => new
2014-01-31 01:43 aiaustin Status new => confirmed
2014-01-31 07:16 aiaustin Note Added: 0025091
2014-01-31 07:21 aiaustin Note Edited: 0025089 View Revisions
2014-01-31 07:21 aiaustin Note Edited: 0025091 View Revisions
2014-01-31 07:21 aiaustin Note Edited: 0025091 View Revisions
2014-01-31 15:38 justincc Note Added: 0025098
2014-02-01 02:49 aiaustin Note Added: 0025102
2014-02-01 02:51 aiaustin Note Edited: 0025102 View Revisions
2014-02-01 02:55 aiaustin Note Edited: 0025102 View Revisions
2014-02-01 03:00 aiaustin Note Edited: 0025102 View Revisions
2014-02-01 08:12 aiaustin Note Added: 0025104
2014-02-01 08:17 aiaustin Note Edited: 0025104 View Revisions
2014-02-01 08:18 aiaustin Note Edited: 0025104 View Revisions
2014-02-01 08:21 aiaustin Note Added: 0025105
2014-02-24 02:12 aiaustin Note Edited: 0025102 View Revisions
2014-02-24 02:14 aiaustin Note Added: 0025292
2014-02-24 02:15 aiaustin Note Added: 0025293
2014-02-24 02:15 aiaustin Status confirmed => resolved
2014-02-24 02:15 aiaustin Fixed in Version => master (dev code)
2014-02-24 02:15 aiaustin Resolution open => fixed
2014-02-24 02:15 aiaustin Assigned To => aiaustin
2014-02-24 11:58 justincc Relationship added related to 0006990
2014-02-24 12:01 justincc Status resolved => closed
2014-02-24 12:01 justincc Assigned To aiaustin =>


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker