Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006977opensim[REGION] OpenSim Corepublic2014-01-27 10:442015-08-05 15:05
Reporterdjphil 
Assigned Todjphil 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPCOSWindowsOS VersionSeven
Product Version 
Target VersionFixed in Version 
Summary0006977: Limit see and chat with avatars of others parcels do not work
DescriptionIn option About Land/Options/"The avatars of other parcels can see and chat with the avatars of this parcel"

The box remains grayed out, it is not checkable/uncheckable.

Normally it should be clickable to limit the chat and the avatar cam ... and probably too with scripts functions (llSay etc ...).

Tested with Singularity, Firestrom, Kokua.

NB: The voice parcel limitation work fine.
TagsNo tags attached.
Git Revision or version numberSim with 0.8.0 and Robust with 0.7.5
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Environment.NET / Windows32
Mono VersionNone
ViewerSingularity, FireStorm
Attached Filesjpg file icon 27-01-2014 19-04-55.jpg [^] (45,998 bytes) 2014-01-27 10:44


jpg file icon privacy.jpg [^] (3,219 bytes) 2015-03-18 02:05

- Relationships

-  Notes
(0025685)
Dubrovna (reporter)
2014-04-05 07:28

Noticed that local chat is readable in adjacent regions. This would be a nice addition if it was active.
(0026607)
djphil (reporter)
2014-07-26 04:46

Currently in Version v0.8.1 OSG I found that the problem persists. Have you tried to fix this bug? I do not see any information about it. Thank you in advance.
(0026618)
Luisillo_Contepomi (reporter)
2014-07-27 03:42

I thing is not a bug. I ask in the users mail list some time ago about this feature.
http://opensimulator.org/pipermail/opensim-users/2014-March/013263.html [^]

Lamentably Privacy option is not implemented yet in OpenSim
(0026619)
smxy (reporter)
2014-07-27 05:28
edited on: 2014-07-27 05:32

I asked about it as well. Melanie told me there is zero interest in making it work. However, if someone provided a patch, they might take it. Personally, I think it's a bit hypocritical to, on the one hand, say "opensim has to be just like SL" while, on the other hand, declining to add SL features you don't like.

(0026623)
Luisillo_Contepomi (reporter)
2014-07-27 06:21

mantis is for report bugs and this is not a bug is only a feature not implemented (as others)
(0027889)
wbalazic (reporter)
2015-03-18 02:06
edited on: 2015-03-18 02:06

Currently with 0.8.1 vs 0.8.0.x the privacy icon now appears at the top of the viewer which it did not in prior releases. Although as stated above it still does not function, that now appears above and you cannot turn it off. Is there a reason why it now appears and didn't in prior releases? (see image above).

(0027908)
Luisillo_Contepomi (reporter)
2015-03-20 12:23

Yes is in viewer but is viewer side. Is not a bug.

We can reopen this issue in the mail list and we can do a proposal to the developers for implement this feature in next versions.

I opened this subjet a year ago:
 
http://opensim-users.2152040.n2.nabble.com/Privacy-in-lands-td7581152.html [^]

As you can see the people like much more ban or close the region or install orbit security devices.

My experience is, if "smell" to SL will be "not".
(0028079)
djphil (reporter)
2015-04-24 15:34

It seems to work fine now.

tested with FS v4.6.9.2974
OSgrid 0.8.2.0 (Dev) 8d66284: 2015-04-05
git hash : 8d6628484107e3ebe2c29b2b754e43c164545cf1

Tank you very much!
(0029100)
kcozens (administrator)
2015-08-05 15:05

FYI, the issue may have been fixed as of the git hash mentioned in comment #28079 but that is not the hash code of the commit that addressed this issue.

- Issue History
Date Modified Username Field Change
2014-01-27 10:44 djphil New Issue
2014-01-27 10:44 djphil File Added: 27-01-2014 19-04-55.jpg
2014-04-05 07:28 Dubrovna Note Added: 0025685
2014-07-26 04:46 djphil Note Added: 0026607
2014-07-27 03:42 Luisillo_Contepomi Note Added: 0026618
2014-07-27 05:28 smxy Note Added: 0026619
2014-07-27 05:32 smxy Note Edited: 0026619 View Revisions
2014-07-27 06:21 Luisillo_Contepomi Note Added: 0026623
2015-03-18 02:05 wbalazic File Added: privacy.jpg
2015-03-18 02:06 wbalazic Note Added: 0027889
2015-03-18 02:06 wbalazic Note Edited: 0027889 View Revisions
2015-03-20 12:23 Luisillo_Contepomi Note Added: 0027908
2015-04-24 15:32 djphil Status new => resolved
2015-04-24 15:33 djphil Resolution open => fixed
2015-04-24 15:33 djphil Assigned To => djphil
2015-04-24 15:34 djphil Note Added: 0028079
2015-04-24 15:34 djphil Status resolved => closed
2015-08-05 15:05 kcozens Note Added: 0029100


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker