Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006973opensim[GRID] Robust Serverpublic2014-01-24 05:192014-07-29 13:43
Reportercloneu2 
Assigned Toorenh 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOperating SystemFedoraOperating System Version19
Product Version 
Target VersionFixed in Version 
Summary0006973: Offline IM's Fail
DescriptionRuns on regions BUT if running on robust get the following error
2014-01-24 07:56:26,138 DEBUG - OpenSim.OfflineIM.OfflineIMServicePostHandler [OFFLINE IM HANDLER]: Exception at Mono.Xml2.XmlTextReader.ReadText (Boolean notWhitespace) [0x00000] in <filename unknown>:0
  at Mono.Xml2.XmlTextReader.ReadContent () [0x00000] in <filename unknown>:0
  at Mono.Xml2.XmlTextReader.Read () [0x00000] in <filename unknown>:0
  at System.Xml.XmlTextReader.Read () [0x00000] in <filename unknown>:0
  at System.Xml.XmlReader.MoveToContent () [0x00000] in <filename unknown>:0
  at System.Xml.Serialization.XmlSerializationReaderInterpreter.ReadRoot () [0x00000] in <filename unknown>:0
  at System.Xml.Serialization.XmlSerializer.Deserialize (System.Xml.Serialization.XmlSerializationReader reader) [0x00000] in <filename unknown>:0
2014-01-24 07:56:29,596 DEBUG - OpenSim.Data.MySQL.UserProfilesData [PROFILES_DATA]: Getting data for af07a325-6ea8-428d-926b-945527bb6d65.

Dropped robust back to 24188 and NO error..
Steps To ReproduceJust load on ROBUST server
Additional InformationStill borked in 24380.. Guess the only solution is go back to Outside OS_Services and forget the built in code as it doesn't seem that OffLine IM's are a priority
TagsNo tags attached.
Git Revision or version numberr/24256
Run Mode Grid (1 Region per Sim)
Physics EngineODE
Script Engine
EnvironmentMono / Linux64
Mono Version2.10
Viewerfirestorm
Attached Filespatch file icon 0001-Fix-mantis-6973.-Prevent-BOM-being-prefixed-to-messa.patch [^] (1,209 bytes) 2014-05-21 17:02 [Show Content]

- Relationships
related to 0007123closedorenh V2 Offline Messaging: retrieval is broken. 

-  Notes
(0025307)
cloneu2 (reporter)
2014-02-24 14:09

OK gave up waiting for a fix SO... Took IM source from git 24188 along with IofflineIMService.cs source. Deleted the files from ver 24380. put in old source and compiled again. OffLine IM's work once again. They have not worked since someone added to the code routines to delete im's from a specific UUID.. Like that was needed as anyone that can run a MySql database cant do deletes...
(0025387)
gabzo (reporter)
2014-03-06 20:37

can you specify the exact files you removed and the exact files you replaced them with that can help.
(0025390)
cloneu2 (reporter)
2014-03-07 05:06

In version 24380 (or any new one I wish to compile) I would DELETE the entire opensim/OpenSim/Addons/OfflineIM directory. Then Copy over that directory from git 24188. Next would go to opensim/OpenSim/Services/Interfaces and do the same with the file IOfflineIMServices.cs
(0026151)
AliciaRaven (manager)
2014-05-21 17:06

Patch Included. This was caused by the UTF8 encoding prefixing the serialized message with a BOM character before saving to the database, the included patch changes that to force ommiting the bom char as it shouldnt be required anyway. Tested on windows, will test on linux in the morning.

:) My first fix, YAY
(0026152)
zadark (reporter)
2014-05-21 18:49

Is this related to mantis 0007123?
(0026153)
AliciaRaven (manager)
2014-05-21 19:07

Yes it is, thanks zadark i hadnt seen that report. The issue for them seemed to be resolved when the table was converted to UTF8, my table has those changes but the BOM is obviously still an issue for some. I have the problem on windows and linux.

orenh said there was a code fix but it would be at the cost of giving up Unicode characters. Is this what i have done?? :( to tired to look any further right now
(0026154)
AliciaRaven (manager)
2014-05-21 19:10

Quick look at wikipedia says that...

"The Unicode Standard permits the BOM in UTF-8, but does not require nor recommend its use"
(0026158)
AliciaRaven (manager)
2014-05-22 03:33

Ive done some more tests and i think the patch is still needed. To get unicode characters to show in offline IMs and not be ?'s you need to change the database settings like orenh said, but for people that don't know that information, this patch will at leased stop the exception and make offline ims work.
(0026160)
smxy (reporter)
2014-05-22 05:04

I think this patch would stop using UTF-8 from being used. This issue is fixed already - just set your DB up correctly. The world is moving to UTF-8. Don't take away functionality to save people from setting up their DB correctly. I'm not sure about anyone else, but I don't want this patch, for my grid.
(0026161)
AliciaRaven (manager)
2014-05-22 05:06

No thats not true, it does not prevent utf-8, i have tested and it works. This patch still uses utf8 encoding, it just dosnt save the bom character which isnt even needed.
(0026162)
orenh (administrator)
2014-05-22 05:19

Added in Git master 04aa13a. Thanks, Alicia.

I changed the patch a bit to simply use the built-in Util.UTF8NoBomEncoding object.

smxy: I tested and Unicode characters do still work after this patch.

- Issue History
Date Modified Username Field Change
2014-01-24 05:19 cloneu2 New Issue
2014-02-24 08:20 cloneu2 Additional Information Updated View Revisions
2014-02-24 14:09 cloneu2 Note Added: 0025307
2014-03-06 20:37 gabzo Note Added: 0025387
2014-03-07 05:06 cloneu2 Note Added: 0025390
2014-05-21 17:02 AliciaRaven File Added: 0001-Fix-mantis-6973.-Prevent-BOM-being-prefixed-to-messa.patch
2014-05-21 17:06 AliciaRaven Note Added: 0026151
2014-05-21 17:06 AliciaRaven Status new => patch included
2014-05-21 18:49 zadark Note Added: 0026152
2014-05-21 19:07 AliciaRaven Note Added: 0026153
2014-05-21 19:10 AliciaRaven Note Added: 0026154
2014-05-21 19:11 AliciaRaven Relationship added related to 0007123
2014-05-22 03:33 AliciaRaven Note Added: 0026158
2014-05-22 05:04 smxy Note Added: 0026160
2014-05-22 05:06 AliciaRaven Note Added: 0026161
2014-05-22 05:19 orenh Note Added: 0026162
2014-05-22 05:25 orenh Assigned To => orenh
2014-05-22 05:25 orenh Status patch included => assigned
2014-05-22 05:25 orenh Status assigned => resolved
2014-05-22 05:25 orenh Resolution open => fixed
2014-07-29 13:43 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker