Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006927opensim[REGION] OpenSim Corepublic2014-01-10 16:362017-10-01 04:15
Reporterdanbanner 
Assigned Todanbanner 
PrioritynormalSeveritymajorReproducibilitysometimes
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version 
Summary0006927: occasionally baked textures don't get sent and/or recieved
DescriptionThere seems to be an issue with console spam, caused by agent teleporting in to the region (r/24172 -> r24172) and even though the avatar rezzes and can be seen the console scrolls with messages creating approx 10mb of logs every minute

spam:
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (20) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Received texture update for Cuteulala Artis 7015566e-e5be-3010-e68c-86abc0a5546c
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (8) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (9) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (10) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (11) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (20) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Received texture update for Cuteulala Artis 7015566e-e5be-3010-e68c-86abc0a5546c
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (8) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (9) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (10) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (11) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (20) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Received texture update for Cuteulala Artis 7015566e-e5be-3010-e68c-86abc0a5546c
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (8) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (9) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (10) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (11) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (20) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Received texture update for Cuteulala Artis 7015566e-e5be-3010-e68c-86abc0a5546c
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (8) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (9) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (10) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (11) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (20) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Received texture update for Cuteulala Artis 7015566e-e5be-3010-e68c-86abc0a5546c
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (8) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (9) for Cuteulala Artis, requesting rebake.
18:18:53 - [AVFACTORY]: Missing baked texture 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (10) for Cuteulala Artis, requesting rebake.
Additional Informationreducing logging with OpenSim.exe.config prevents it but something doesn't seem right
TagsNo tags attached.
Git Revision or version numberr/24172
Run Mode Grid (1 Region per Sim)
Physics EngineODE, BulletSim
Environment.NET / Windows64
Mono VersionNone
Viewer
Attached Files

- Relationships
duplicate of 0007031closedjustincc On return to home avatar appears to flicker, sometimes remains white. 
related to 0008244new "Received texture update" looping in console 
child of 0006988assignedmelanie Master report for issues caused by Avinaion code drop - please link issues that qualify to this as children 

-  Notes
(0024972)
danbanner (manager)
2014-01-10 16:39
edited on: 2014-01-10 16:40

Checking the baked texture uuid's shows the baked textures in question

For Cuteulala Artis in Lbsa Plaza
Bake Type UUID
Head 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (uploaded)
UpperBody 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (uploaded)
LowerBody 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (uploaded)
Eyes 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (uploaded)
Skirt not set
Hair 3a367d1c-bef1-6d43-7595-e88c1e3aadb3 (uploaded)
Cuteulala Artis baked appearance texture is OK

(0024974)
danbanner (manager)
2014-01-10 16:44

another clue... typing show appearance show Cuteulala Artis in the console getting spammed seems to stop the scroll
(0024981)
danbanner (manager)
2014-01-11 08:46
edited on: 2014-01-11 08:54

did a fresh build r24188 and still seeing spam until i run "show appearance user name"


http://pastebin.com/S30ThKPU [^]

which seems to stop the scroll
not sure why the sim doesn't seem to acknowledge the baked uuid until i use "show appearance" but this is kind of serious issue that needs fixing soon..

(0025111)
Dev Random (reporter)
2014-02-03 07:27

Seeing this happen on login using a newly-built Standalone single-region config with a newly-created MySQL DB. Both server and client running on same machine. Viewer is Singularity Viewer 1.8.5 (5617) Jan 28 2014 11:14:09.

INFO - [SCENE]: Region Region01 authenticated and authorized incoming root agent Test User ae6fdb28-0e3a-4692-91ff-dbe84aab3fe9 (circuit code 711132848)
DEBUG - [EVENTQUEUE]: OnRegisterCaps: agentID ae6fdb28-0e3a-4692-91ff-dbe84aab3fe9 caps OpenSim.Framework.Capabilities.Caps region Region01
DEBUG - [EVENTQUEUE]: Adding new queue for agent ae6fdb28-0e3a-4692-91ff-dbe84aab3fe9 in region Region01
DEBUG - [LOGIN RESPONSE] LLLoginResponse create. sizeX=256, sizeY=256
DEBUG - [LLOGIN SERVICE]: All clear. Sending login response to Test User
DEBUG - [LOGIN RESPONSE] returning sizeX=256, sizeY=256
DEBUG - [CAPS]: Received SEED caps request in Region01 for agent ae6fdb28-0e3a-4692-91ff-dbe84aab3fe9
DEBUG - [SCENE]: Incoming client Test User in region Region01 via regular login. Client IP verification not performed.
DEBUG - LUDPServer [LLUDPSERVER]: Handling UseCircuitCode request for circuit 711132848 to Region01 from IP 192.168.1.101:58573
DEBUG - [SCENE]: Adding new child scene presence Test User ae6fdb28-0e3a-4692-91ff-dbe84aab3fe9 to scene Region01 at pos <128, 128, 0>
DEBUG - [LLUDPSERVER]: Handling CompleteAgentMovement request from 192.168.1.101:58573 in Region01
INFO - [SCENE PRESENCE]: Completing movement of Test User into region Region01 in position <128, 128, 0>
DEBUG - [AVFACTORY]: Received texture update for Test User ae6fdb28-0e3a-4692-91ff-dbe84aab3fe9
DEBUG - [AVFACTORY]: Missing baked texture 7fe5a167-0ece-4726-bd78-742836e0e0de (8) for Test User, requesting rebake.
DEBUG - [AVFACTORY]: Missing baked texture 94266c80-5701-4873-879e-3c2c30857080 (9) for Test User, requesting rebake.
DEBUG - [AVFACTORY]: Missing baked texture 6b5bc094-5cd5-4502-97e3-a20bf0f7c6d7 (10) for Test User, requesting rebake.
DEBUG - [AVFACTORY]: Missing baked texture 5a22f3a0-60df-46b8-acad-6fe9efb00b3c (11) for Test User, requesting rebake.
DEBUG - [AVFACTORY]: Missing baked texture 77d636fa-bd10-473a-8ca9-18b24079c861 (20) for Test User, requesting rebake.
DEBUG - [AVFACTORY]: Received texture update for Test User ae6fdb28-0e3a-4692-91ff-dbe84aab3fe9
(0025138)
melanie (administrator)
2014-02-06 17:25

Please retest after the latest code drop.
(0025139)
Dev Random (reporter)
2014-02-06 20:46

Re-built and tried with latest source (clean DB each time). Both Grid config and Standalone config looked good for me.
(0025239)
danbanner (manager)
2014-02-20 12:35

Tested on fc9930e (r/24336) and still happens but now contains even more spam since the xbake code added more lines http://pastebin.com/ggz6RHA9 [^]
(0025283)
danbanner (manager)
2014-02-23 11:19

This continues and has been reported by several more users. It seems to be caused by the alpha that mesh avatars wear.
(0025296)
justincc (administrator)
2014-02-24 11:39

Please try git master fd1b2a1c and tell me if this still occurs when users with mesh avatars log in.

It appears that mesh avatars use the library alpha texture instead of actually uploading bakes. This was causing the simulator to keep re-requesting bakes unless some other code brought the texture out of the asset service and inserted it into the cache (the "appearance show" commands do this).

This commit checks the asset service after checking the cache. We must do this to avoid this issue and others where baked textures have been permanently persisted (a pre-existing option).
(0025308)
danbanner (manager)
2014-02-24 14:49

Works great, thanks!

- Issue History
Date Modified Username Field Change
2014-01-10 16:36 danbanner New Issue
2014-01-10 16:39 danbanner Note Added: 0024972
2014-01-10 16:40 danbanner Note Edited: 0024972 View Revisions
2014-01-10 16:44 danbanner Note Added: 0024974
2014-01-11 08:46 danbanner Note Added: 0024981
2014-01-11 08:54 danbanner Note Edited: 0024981 View Revisions
2014-02-02 00:19 danbanner Relationship added child of 0006988
2014-02-03 04:02 danbanner Severity minor => major
2014-02-03 07:27 Dev Random Note Added: 0025111
2014-02-06 17:25 melanie Note Added: 0025138
2014-02-06 20:46 Dev Random Note Added: 0025139
2014-02-20 12:35 danbanner Note Added: 0025239
2014-02-23 11:19 danbanner Note Added: 0025283
2014-02-24 11:39 justincc Note Added: 0025296
2014-02-24 12:36 justincc Relationship added duplicate of 0007031
2014-02-24 14:49 danbanner Note Added: 0025308
2014-02-24 15:08 danbanner Status new => resolved
2014-02-24 15:08 danbanner Resolution open => fixed
2014-02-24 15:08 danbanner Assigned To => danbanner
2014-07-29 13:42 chi11ken Status resolved => closed
2017-10-01 04:15 ssm2017 Relationship added related to 0008244


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker