Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006854opensim[REGION] OpenSim Corepublic2013-11-17 12:512014-12-22 07:01
Reporterkenvc 
Assigned Tokenvc 
PrioritynormalSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006854: We need an option to not show AVs on map for privacy reasons.
DescriptionWe have an option to not draw maptiles for map view. We also need an option to not show AVs on map for privacy reasons. I have not experienced this myself, but a friend is being harassed each time more than one AV is on her sim by an old boyfriend. If there was an option to prevent others from seeing the AV count on your sim, that would solve this rather serious privacy issue.
TagsNo tags attached.
Git Revision or version numberr/24051
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerAll
Attached Files

- Relationships

-  Notes
(0024714)
melanie (administrator)
2013-11-17 15:14

The proper way to handle this is to ban said old boyfriend.

That said, avatars on maptiles can be hidden for the in world map, but not for the Minimap. So if that person is not banned, they can always still determine the right time to harass the victim by looking at the minimap. The minimap is generated by the viewer from information required for other things as well, so the avatar positions cannot be simply omitted from the viewer data stream - too much would break.

So, banning seems the easier solution.
(0024715)
kenvc (reporter)
2013-11-17 15:47

They can easily sign in using a different AV and email if they are banned and continue with the harrassment, so banning doesn't help if someone really wants to harass.

How can you prevent it from showing in the world map with our current setup Melanie?
(0024716)
melanie (administrator)
2013-11-17 15:49

There is no setting but the code change is trivial. Avatars are a map layer so all that is needed is to comment out the bit that sends it.
(0024718)
kenvc (reporter)
2013-11-17 16:12
edited on: 2013-11-17 16:26

Melanie, is this something in the opensim code so each sim can have their own setting, or is it in the robust code where its either all or none?

(0026758)
Luisillo_Contepomi (reporter)
2014-08-17 13:43

This sort of thing could be resolved with the privacy option in all viewers "about land" on a parcel but is not implemented.
(0027133)
kenvc (reporter)
2014-12-22 07:00

Marking this as resolved because nothing was ever done and there seems to be no interest in this issue.

- Issue History
Date Modified Username Field Change
2013-11-17 12:51 kenvc New Issue
2013-11-17 15:14 melanie Note Added: 0024714
2013-11-17 15:47 kenvc Note Added: 0024715
2013-11-17 15:49 melanie Note Added: 0024716
2013-11-17 16:12 kenvc Note Added: 0024718
2013-11-17 16:26 kenvc Note Edited: 0024718 View Revisions
2014-08-15 19:48 kenvc Status new => acknowledged
2014-08-17 13:43 Luisillo_Contepomi Note Added: 0026758
2014-12-22 07:00 kenvc Note Added: 0027133
2014-12-22 07:00 kenvc Status acknowledged => resolved
2014-12-22 07:00 kenvc Fixed in Version => master (dev code)
2014-12-22 07:00 kenvc Resolution open => fixed
2014-12-22 07:00 kenvc Assigned To => kenvc
2014-12-22 07:01 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker