Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006849opensim[REGION] Physics Enginespublic2013-11-16 00:082014-01-25 10:43
Reporterkenvc 
Assigned Tokenvc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006849: Bulletsim - AV's feet are correct when walking on terrain, but when walking on a prim they are sunk well below the surface.
DescriptionBulletsim - AV's feet are correct when walking on terrain, but when walking on a prim they are sunk well below the surface. With a tall AV the feet are not even visible... may not be as noticeable on a shorter AV, but others have said it is.
This may be a Bulletsim issue because I don't recall seeing this problem when using ODE.
TagsNo tags attached.
Git Revision or version numberr/24051
Run Mode Grid (Multiple Regions per Sim)
Physics EngineBulletSim
Script Engine
Environment.NET / Windows64
Mono VersionNone
ViewerAll
Attached Files

- Relationships

-  Notes
(0024679)
kenvc (reporter)
2013-11-16 10:17
edited on: 2013-11-16 10:55

Current default settings are:
AvatarHeightLowFudge = -0.2, AvatarHeightMidFudge = 0.1, AvatarHeightHighFudge = 0.1
After a lot of experimenting with different height AVs, I change to: AvatarHeightLowFudge = 0.0, AvatarHeightMidFudge = 0.25, AvatarHeightHighFudge = 0.55

It now seems to be almost perfect walking or standing on a prim with a max tall, mid, or max short AV. Walking on terrain however is now to high by the amount it was too low, but the error on terrain is kind of hard to see unless you are looking for it.

(0024680)
Bruce (reporter)
2013-11-16 10:37

Thanks kenvc for finding a solution for this.
(0024681)
Bruce (reporter)
2013-11-16 11:42

Tested using Advanced>Character>Show Collision Skeleton with Singularity for reference purposes, I can see that the bottom triangle box of the skeleton (the one for each foot) interacts correctly with a prim floor (whether or not an avatar wears shoes) and the sole of the feet or shoes are at the correct hight over the prim floor. However, standing on terrain those boxes float above ground. The measured heights above terrain were: (a) 0.06995 to the bottom of the skeleton box; and (b) 0.08503 to the sole of the avatar's feet or shoes.
(0024682)
kenvc (reporter)
2013-11-16 11:45

Bruce, IF this is with the settings changes I described in the previous note, that's exactly what I am seeing. Its good walking on a prim now, but a little high on terrain... but still better than the AV's feet being down inside the prim.
(0024685)
Bruce (reporter)
2013-11-16 15:38

My test was with AvatarHeightLowFudge = 0.0, AvatarHeightMidFudge = 0.2, AvatarHeightHighFudge = 0.5 With AvatarHeightLowFudge = 0.0, AvatarHeightMidFudge = 0.25, AvatarHeightHighFudge = 0.55 the avatar floats 0.13931 above terrain and 0.03301 above prim floor. For me that setting is too high. The test avatar is 2.10m tall (including shoes).
(0025062)
kenvc (reporter)
2014-01-25 10:43

Marking this as resolved because the behavior is no longer as stated in this mantis and the current behavior is covered in another mantis.

- Issue History
Date Modified Username Field Change
2013-11-16 00:08 kenvc New Issue
2013-11-16 00:12 kenvc Description Updated View Revisions
2013-11-16 10:17 kenvc Note Added: 0024679
2013-11-16 10:34 kenvc Note Edited: 0024679 View Revisions
2013-11-16 10:37 Bruce Note Added: 0024680
2013-11-16 10:55 kenvc Note Edited: 0024679 View Revisions
2013-11-16 11:42 Bruce Note Added: 0024681
2013-11-16 11:45 kenvc Note Added: 0024682
2013-11-16 15:38 Bruce Note Added: 0024685
2014-01-25 10:43 kenvc Note Added: 0025062
2014-01-25 10:43 kenvc Status new => resolved
2014-01-25 10:43 kenvc Fixed in Version => master (dev code)
2014-01-25 10:43 kenvc Resolution open => fixed
2014-01-25 10:43 kenvc Assigned To => kenvc
2014-01-25 10:43 kenvc Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker