Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006832opensim[REGION] Specific OpenSim Modulepublic2013-11-07 05:112014-07-29 13:42
ReporterMata Hari 
Assigned ToMata Hari 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel i7 930 quad coreOSWindows .NETOS VersionWin7 x64
Product Versionmaster (dev code) 
Target VersionFixed in Versionmaster (dev code) 
Summary0006832: Materials Module - Applying bump or specular map to more than 1 face but not all causes all faces to take the new map
DescriptionUsing the materials module and Firestorm Beta with r24018 I have been experimenting with applying bump and specular maps and noticed an error that may be a module bug or could be a Firestorm bug (unsure which).

If you apply a map to more than one face but not all, all faces will take the new map (overriding any map and map settings you've already assigned to them)
Steps To Reproduce1. Rez a cube
2. Select Face 0
3. Apply a bump map to it
4. Select Face 1 and 2
5. Apply a different bump map to them

You'll see that ALL sides will now have this new bump map, so it's overriding the change you made in step 3, applying the change from step 5, and also applying it to the remaining 3 faces.

Repeat the above with specular map...same result

If you select one face at a time to apply the maps it seems to work properly (or if you want to apply the same maps to all faces)
TagsNo tags attached.
Git Revision or version numberr24018 Opensim-3b2721c
Run Mode Standalone (Multiple Regions)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerFirestorm 4.5.1.38838 OS
Attached Files

- Relationships
related to 0006915closeddahlia [PATCH] Materials: save materials as assets; fixed bugs; removed "Demo" status 

-  Notes
(0024616)
Mata Hari (reporter)
2013-11-07 08:17
edited on: 2013-11-07 08:21

A few additional issues encountered...

It seems that the MaterialsDemoModule isn't always persisting changes to a material or its settings. I have been attempting to replace a normal map and to adjust the specular settings on the face of a mesh and even though it appears to process those changes (I see them take effect visually and the console reports the activity) as soon as I leave that face by selecting a different one (or leaving edit mode) the face reverts to its previous settings. It doesn't do this consistently though...attempting to make the changes 3-5 times will usually succeed in having it persist.

EDIT: and the other issue I encountered (probably related) is that it seems almost impossible to remove a normal or specular map. When I select "none" as the type, it will display properly but never seems to persist (or hasn't yet in 20+ attempts). Again, console appears to be processing the update with a [MaterialsDemoModule] line.

(0024617)
Mata Hari (reporter)
2013-11-07 09:35

Tested with Kokua 3.6.8.30064 (Oct 18 2013) release and encountered the same issues.
(0024618)
dahlia (administrator)
2013-11-07 11:47

The viewer controls which materials are applied to which faces. Please make sure the viewer you are using can apply materials to a particular face by trying it in SL.

In order to properly use materials and have them persist, your OpenSim.ini file must contain the section header:
[MaterialsDemoModule]
(0024619)
Mata Hari (reporter)
2013-11-07 13:59

I did have the [MaterialsDemoModule] in my Opensim.ini file so that part should be working.

I just uploaded to SL the identical mesh to the one that I was working on in Opensim as well as the textures, normal maps and specular maps. Using the Firestorm beta (SL version though) I had no trouble applying the correct textures and maps and then later removing them. In each case the changes persisted. About half-way through the process (my mesh has 5 unique faces) it applied the texture and maps for face 3 to the remaining untextured faces but didn't overwrite/change/lose the faces I'd already done. I was careful only to select one face at a time, so one can certainly infer that the Firestorm code to apply them isn't 100% perfect either, but definitely works much better in SL than in Opensim. I'll try a test with another (almost identical) mesh tomorrow when I finish working on it.

In the meantime I've found a (annoying) partial work-around in Opensim...it seems the change will almost always persist if you wear the item (even if it isn't intended as an attachment), then apply the texture and maps to one face, then un-wear it while still in edit mode, then re-wear it, do the next face, un-wear it, etc... It doesn't always persist but seems far more likely to (maybe a 75% success rate in persisting).
(0024620)
dahlia (administrator)
2013-11-07 15:10

if you do not have your OpenSim.ini configured correctly than any materials persistace you may see are just viewer caching artifacts. you MUST have the section [MaterialsDemoModule] in your OpenSim.ini file for any materials-related functionality to be enabled in OpenSim. If you do have it, then persistance should work normally.
(0024622)
Mata Hari (reporter)
2013-11-07 16:28

As I said above, I have a [MaterialsDemoModule] section in my Opensim.ini and, using the method I described above, I *am* able to get the changes to persist. At present that section is blank as per Nebadon's instructions on IRC (and as per the way it appears in the OSG version of the ini file) but if there are any additional settings that need to be added perhaps you could recommend them.
(0024623)
dahlia (administrator)
2013-11-07 18:24

currently there are no more settings. just having the section header will enable materials.
(0025046)
Mata Hari (reporter)
2014-01-23 03:28

Appears to now be working correctly as of r/24252

- Issue History
Date Modified Username Field Change
2013-11-07 05:11 Mata Hari New Issue
2013-11-07 08:17 Mata Hari Note Added: 0024616
2013-11-07 08:21 Mata Hari Note Edited: 0024616 View Revisions
2013-11-07 09:35 Mata Hari Note Added: 0024617
2013-11-07 11:47 dahlia Note Added: 0024618
2013-11-07 13:59 Mata Hari Note Added: 0024619
2013-11-07 15:10 dahlia Note Added: 0024620
2013-11-07 16:28 Mata Hari Note Added: 0024622
2013-11-07 18:24 dahlia Note Added: 0024623
2014-01-20 03:48 Mata Hari Relationship added related to 0006915
2014-01-23 03:28 Mata Hari Note Added: 0025046
2014-01-23 03:28 Mata Hari Status new => resolved
2014-01-23 03:28 Mata Hari Fixed in Version => master (dev code)
2014-01-23 03:28 Mata Hari Resolution open => fixed
2014-01-23 03:28 Mata Hari Assigned To => Mata Hari
2014-07-29 13:42 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker