Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006814opensim[REGION] OpenSim Corepublic2013-10-19 13:522015-08-18 09:35
ReporterRichardus Raymaker 
Assigned ToRobert Adams 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Versionmaster (dev code) 
Target VersionFixed in Version0.8.1-rc2 
Summary0006814: Terrain and building is not moving always smooth when you walk or fly
DescriptionIf am flying on emtpy standalone sim as example the terrain and objects dont move smooth, The have some normal , acceleration, normal habbit. This problem or is hacing some hic's between normal movement. started since 0.7.6 final. it worked fine and super smooth with 0.7.5.

I tried to record it, but the conversions changed the speed of the avatar and maby other things so it can be hard to see. Some similair problem i found around 2008-2010 things where not smooth to with moveing, sadly cant find the chat back in the logs.

At the end of the record http://www.youtube.com/watch?v=-DpfYRUsPYY [^] am walking a bit, there its maby better to spot if you watch the terrain. Its pretty annoying. Its really dissapoint to have it back.

I see the same problem still in osgrid to and on other opensim grid also. and offcorse my standalone thats running 0.8.0 a7e7bed-r/23962 problem appears on linux, windows , virtual machien , normal pc hardware. it doesnt matter.
TagsNo tags attached.
Git Revision or version number0.8.0 a7e7bed-r/23962
Run ModeStandalone (1 Region)
Physics EngineBulletSim
Environment.NET / Windows64
Mono VersionNone
ViewerKokua/singularity
Attached Files

- Relationships
related to 0006909new choppy movement of the avatar 

-  Notes
(0024543)
Richardus Raymaker (reporter)
2013-10-19 14:00

Found my old mantis back from years ago. i think its a bit similiar problem that i see now. http://opensimulator.org/mantis/view.php?id=5256 [^]
(0024547)
Richardus Raymaker (reporter)
2013-10-20 06:43

Many hours later.....
I tried to trace it back, but sofar every version i tried from git is wrong.
Compiled the 0.7.5 release source code and that works fine.

I need the revision number of the o.7.5 version thats on the wiki.
Then i compare. again.
(0024550)
Richardus Raymaker (reporter)
2013-10-20 11:24

Not want to hold it longer back. But i played with some numbers. and if i set,

MinFrameTime = 0.025

then my flying is super smooth ! Need to look more in the numbers and get more info about it seems the orginal MinFrameTime = 0.089 is not good enough.
Also MinFrameTime = 0.0445 its better, but still gives me problems with smoothness.
(0024569)
Richardus Raymaker (reporter)
2013-10-23 05:47

DOne the test with ode and MinFrameTime = 0.089 , i still see the world is moveing not smooth in speed. It gives me the same result s with bullet and MinFrameTime = 0.089.

On sim with prims, bulletsim seems to be more smooth with MinFrameTime = 0.089 then ode. , but still the effect you see. On etpry sim the both show more the jerky world movement.
(0024570)
justincc (administrator)
2013-10-24 17:19
edited on: 2013-10-24 17:19

Okay, I tested for myself, and on a completely blank island, avatar flight on BulletSim is noticeably jerky. Reducing MinFrameTime to 0.025 does make it smooth for me as well.

I believe what is happening is that BulletSim movement is not matching movement predicted by the viewer. Hence, on each update, the position correction jerks the avatar around. You can see updates coming through by turning the debug option on in the viewer (classically with the keyboard short ctrl+shift+u on the Linden Lab viewer).

When MinFrameTime is dropped to 0.025 for BulletSim, you can see updates come through at a much faster rate. This makes for much smaller corrections by the viewer and a smoother movement.

However, the far better answer is to match the server movement with the viewer's predicted movement when flying at a constantly velocity in a straight line. No updates (and hence traffic) are needed from server to viewer in this case. This is the tuning I had to do with ODE about a year back.

I can also confirm that switching my configuration to ODE (with MinFrameTime = 0.089) results in smooth flight on a blank region with very few server -> viewer ImprovedTerseObjectUpdate. So I do not see what Richardus is seeing with this aspect of things.

(0024610)
Richardus Raymaker (reporter)
2013-11-05 03:07

I checked it again. agree with ODE its not really visible. only when you start to fly (fast) forward there's in the begin a short hic. but then it seems you fly smooth. smoothness you can see very good if you fly back (cursor down) but bulletsim keepos jerkey
(0024929)
Richardus Raymaker (reporter)
2013-12-28 12:04

New info, i where testing other mantis from me on 0.8dev
The following script is a simpe avatra following cube,
The supriseing thing what happend is that the cube thats following your flying avatars is showing very visible the interuptions / missing frame.

Other words its whoing pretty nice how bad movement works, its not smooth.
Here is the test script, place it in <0.5, 0.5, 0.5> cube and start flying or walking.

---------------------------------

default
{
    state_entry()
    {
        vector pos = llGetPos();
        llSetStatus(STATUS_PHYSICS, TRUE);
        llSleep(0.1);
        llMoveToTarget(pos,0.4);

        llSensorRepeat("", llGetOwner(), AGENT, 20.0, PI,0.1);
    }
    sensor(integer total_number)
    {
        // Get position of detected owner
        vector pos = llDetectedPos(0);
        vector offset =<-3,0,2>;
        pos+=offset;
        llMoveToTarget(pos,0.4);
    }
}
(0026211)
justincc (administrator)
2014-05-30 14:28

For avatars, finally got a chance to investigate this and should be better in git master 3c992b0. Root cause appeared to be velocity fluctuations in BulletSim when there was a velocity update threshold, though haven't yet identified the root cause of why this was causing the fluctuation.

Any issue with cubes moving jerkily may have a similar cause (or may be entirely different). Hope to take a look at this one too. Though in this case, the parameter is configurable, so it would be interesting to know what you see if you set UpdateVelocityChangeThreshold = 0.4 or similar in [BulletSim] in ODE (default is 0.1).
(0026220)
Richardus Raymaker (reporter)
2014-06-01 04:16

UpdateVelocityChangeThreshold = 0.4 seems to work better, as long you fly at normal speed with your avatar and have a high draw distance.
It looks like you get disruptions in smoothness when something else happens.

if you disable UpdateVelocityChangeThreshold = 0.4
you fly faster but its really not smooth.

Its much better, so i hope this fix is going in before the 0.8 release.
flying is more stable. This tested on empty flat
region var and normal standalone localhost.
(0026324)
Richardus Raymaker (reporter)
2014-06-21 05:57
edited on: 2014-06-21 05:59

Installed own grid again, with 0.8 release.

UpdateVelocityChangeThreshold = 0.4 is best for mega
UpdateVelocityChangeThreshold = 0.1 seems better on normal region for me.

In time we will see if changes make things better.

Its still not perfect smooth, you see disruptions. hics

(0026334)
Robert Adams (administrator)
2014-06-21 17:37

I went looking at this problem and found that the parameter [BulletSim]UpdateVelocityChangeThreshold only applies to prim movement. Justin had changed avatar movement so any velocity change is passed through (no threshold damping). I am looking into this problem and might add an AvatarUpdateVelocityChangeThreshold but I need to understand this problem better.
(0026339)
Robert Adams (administrator)
2014-06-21 20:16
edited on: 2014-06-21 20:17

Looking into this problem I find that the velocity change smoother is indeed the problem. There is an avatar movement agent that tries to get the avatar to the requested speed (slow ramp up and niceties like that). What happens is it steps the avatar up to its fly speed but the velocity change damper doesn't let that change happen. The movement agent says "didn't get to the requested speed. I must have to push harder" and does that which causes an overshoot of the velocity.

If I remember the past correctly, the velocity damper was added to reduce jitter when standing. Justin's change to remove the threshold is good and will stay and I'll look into fixing the standing jitter a different way.

(0026579)
Robert Adams (administrator)
2014-07-24 22:07

Is the flying jitter problem fixed with the changes that have been made?
(0026580)
Richardus Raymaker (reporter)
2014-07-25 04:25

Version 3a87cce-r/24979 seems to move smooth on my 3x3 var.
(0027457)
Richardus Raymaker (reporter)
2015-02-03 05:27

Its fix for me in opensimulator 0.8.1rc1 flying is smooth as it where years ago.
(0029267)
aiaustin (developer)
2015-08-18 09:35

Resolved issue marked as closed. Please open a new issue and refer to this one if problems arise.

- Issue History
Date Modified Username Field Change
2013-10-19 13:52 Richardus Raymaker New Issue
2013-10-19 13:53 Richardus Raymaker Description Updated View Revisions
2013-10-19 14:00 Richardus Raymaker Note Added: 0024543
2013-10-20 06:43 Richardus Raymaker Note Added: 0024547
2013-10-20 11:02 aiaustin Summary Terrain and building is not moveing always smooth when you walk or fly => Terrain and building is not moving always smooth when you walk or fly
2013-10-20 11:24 Richardus Raymaker Note Added: 0024550
2013-10-23 05:47 Richardus Raymaker Note Added: 0024569
2013-10-24 17:19 justincc Note Added: 0024570
2013-10-24 17:19 justincc Note Edited: 0024570 View Revisions
2013-10-29 11:59 Robert Adams Assigned To => Robert Adams
2013-10-29 11:59 Robert Adams Status new => assigned
2013-11-05 03:07 Richardus Raymaker Note Added: 0024610
2013-12-27 11:06 Richardus Raymaker Relationship added related to 0006909
2013-12-28 12:04 Richardus Raymaker Note Added: 0024929
2014-05-30 14:28 justincc Note Added: 0026211
2014-06-01 04:16 Richardus Raymaker Note Added: 0026220
2014-06-21 05:57 Richardus Raymaker Note Added: 0026324
2014-06-21 05:59 Richardus Raymaker Note Edited: 0026324 View Revisions
2014-06-21 17:37 Robert Adams Note Added: 0026334
2014-06-21 20:16 Robert Adams Note Added: 0026339
2014-06-21 20:17 Robert Adams Note Edited: 0026339 View Revisions
2014-07-24 22:07 Robert Adams Note Added: 0026579
2014-07-25 04:25 Richardus Raymaker Note Added: 0026580
2015-02-03 05:27 Richardus Raymaker Note Added: 0027457
2015-02-03 05:27 Richardus Raymaker Status assigned => resolved
2015-02-03 05:27 Richardus Raymaker Fixed in Version => 0.8.1-rc2
2015-02-03 05:27 Richardus Raymaker Resolution open => fixed
2015-08-18 09:35 aiaustin Note Added: 0029267
2015-08-18 09:35 aiaustin Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker